]> git.pld-linux.org Git - packages/ipython.git/blob - ipython.spec
- updated to 0.8.4
[packages/ipython.git] / ipython.spec
1 %define         pname   IPython
2 Summary:        An enhanced Interactive Python shell
3 Summary(pl.UTF-8):      Interaktywna powłoka języka Python
4 Name:           ipython
5 Version:        0.8.4
6 Release:        1
7 License:        LGPL
8 Group:          Applications/Shells
9 Source0:        http://ipython.scipy.org/dist/%{name}-%{version}.tar.gz
10 # Source0-md5:  9b8b439d295defa694b9fbf799203680
11 Patch0:         %{name}-import_path.patch
12 Patch1:         %{name}-upgrade.patch
13 URL:            http://ipython.scipy.org
14 BuildRequires:  pydoc
15 BuildRequires:  python-devel
16 BuildRequires:  python-devel-tools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 Requires:       python-%{name} = %{version}-%{release}
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 IPython is a free software project which tries to:
25
26 1. Provide an interactive interpreter superior to Python's default.
27 IPython has many features for object introspection, shell access, and
28 its own special command system for adding functionality when working
29 interactively.
30
31 2. Serve as an embeddable, ready to use interpreter for your own
32 programs. IPython can be started with a single call from inside
33 another program, providing access to the current namespace. This can
34 be very useful both for debugging purposes and for situations where a
35 blend of batch-processing and interactive exploration are needed.
36
37 3. Offer a flexible framework which can be used as the base
38 environment for other systems with Python as the underlying language.
39 Specifically scientific environments like Mathematica, IDL and Mathcad
40 inspired its design, but similar ideas can be useful in many fields.
41
42 This package contains IPython shell.
43
44 %description -l pl.UTF-8
45 IPython jest wolnym oprogramowaniem, którego celem jest:
46
47 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
48 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
49 dostęp do powłoki oraz własny system poleceń, który umożliwia
50 rozszerzanie funkcjonalności podczas pracy interaktywnej.
51
52 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
53 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
54 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
55 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
56 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
57 wymagane połączenie przetwarzania wsadowego z interaktywną
58 introspekcją.
59
60 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
61 systemu, którego polecenia opierają się na zasadach języka Python.
62 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
63 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
64 w wielu przypadkach.
65
66 Pakiet ten zawiera powłokę IPython.
67
68 %package -n python-ipython
69 Summary:        An enhanced Interactive Python shell modules
70 Summary(pl.UTF-8):      Moduły interaktywnej powłoki języka Python
71 Group:          Libraries/Python
72 %pyrequires_eq  python-devel-tools
73 %pyrequires_eq  pydoc
74
75 %description -n python-ipython
76 IPython is a free software project which tries to:
77
78 1. Provide an interactive interpreter superior to Python's default.
79 IPython has many features for object introspection, shell access, and
80 its own special command system for adding functionality when working
81 interactively.
82
83 2. Serve as an embeddable, ready to use interpreter for your own
84 programs. IPython can be started with a single call from inside
85 another program, providing access to the current namespace. This can
86 be very useful both for debugging purposes and for situations where a
87 blend of batch-processing and interactive exploration are needed.
88
89 3. Offer a flexible framework which can be used as the base
90 environment for other systems with Python as the underlying language.
91 Specifically scientific environments like Mathematica, IDL and Mathcad
92 inspired its design, but similar ideas can be useful in many fields.
93
94 This package contains IPython modules.
95
96 %description -n python-ipython -l pl.UTF-8
97 IPython jest wolnym oprogramowaniem, którego celem jest:
98
99 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
100 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
101 dostęp do powłoki oraz własny system poleceń, który umożliwia
102 rozszerzanie funkcjonalności podczas pracy interaktywnej.
103
104 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
105 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
106 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
107 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
108 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
109 wymagane połączenie przetwarzania wsadowego z interaktywną
110 introspekcją.
111
112 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
113 systemu, którego polecenia opierają się na zasadach języka Python.
114 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
115 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
116 w wielu przypadkach.
117
118 Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
119
120 %prep
121 %setup -q
122 %patch0 -p1
123 %patch1 -p1
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
129
130 %py_postclean
131 rm -rf $RPM_BUILD_ROOT%{_docdir}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/*
139 %{_mandir}/man1/*
140
141 %files -n python-ipython
142 %defattr(644,root,root,755)
143 %doc README doc/ChangeLog doc/manual
144 %{py_sitescriptdir}/%{pname}
145 %{py_sitescriptdir}/*.egg-info
This page took 0.068089 seconds and 4 git commands to generate.