]> git.pld-linux.org Git - packages/ipython.git/blob - ipython.spec
- fixed requirements
[packages/ipython.git] / ipython.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define pname IPython
4
5 Summary:        An enhanced Interactive Python shell
6 Summary(pl):    Interaktywna pow³oka jêzyka Python
7 Name:           ipython
8 Version:        0.5.0
9 Release:        1
10 License:        LGPL
11 Group:          Applications/Shells
12 Source0:        http://ipython.scipy.org/dist/%{pname}-%{version}.tar.gz
13 # Source0-md5:  134ccdb03a4094f991def74230137b21
14 URL:            http://ipython.scipy.org
15 %pyrequires_eq  python
16 Requires:       python-%{name} = %{version}
17 BuildRequires:  rpm-pythonprov >= 4.0.2-50
18 BuildRequires:  python-devel
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 IPython is a free software project which tries to:
24
25 1. Provide an interactive interpreter superior to Python's default.
26 IPython has many features for object introspection, shell access, and
27 its own special command system for adding functionality when working
28 interactively.
29
30 2. Serve as an embeddable, ready to use interpreter for your own
31 programs. IPython can be started with a single call from inside
32 another program, providing access to the current namespace. This can
33 be very useful both for debugging purposes and for situations where a
34 blend of batch-processing and interactive exploration are needed.
35
36 3. Offer a flexible framework which can be used as the base
37 environment for other systems with Python as the underlying language.
38 Specifically scientific environments like Mathematica, IDL and Mathcad
39 inspired its design, but similar ideas can be useful in many fields.
40
41 This package contains IPython shell.
42
43 %description -l pl
44 IPython jest wolnym oprogramowaniem, którego celem jest:
45
46 1. Dostarczenie interaktywnej pow³oki lepszej od standardowej
47 dostarczanej z jêzykiem Python. IPython umo¿liwia badanie obiektów,
48 dostêp do pow³oki oraz w³asny system poleceñ, który umo¿liwia
49 rozszerzanie funkcjonalno¶ci podczas pracy interaktywnej.
50
51 2. Dostarczenie gotowego interpertera, który mo¿na do³±czaæ do w³asnej
52 aplikacji. IPython mo¿e zostaæ uruchomiony za pomoc± wywo³ania jednej
53 funkcji z poziomu innego programu umo¿liwiaj±c jednocze¶nie dostêp do
54 aktualnej przestrzeni nazw tego programu. Mo¿e to byæ bardzo u¿yteczne
55 do celów takich jak ¶ledzenie programu czy te¿ sytuacji gdzie jest
56 wymagane po³±czenie przetwarzania wsadowego z interaktywn±
57 introspekcj±.
58
59 3. Dostarczenie szkieletu, który mo¿e zostaæ u¿yty jako podstawa
60 systemu, którego polecenia opieraj± siê na zasadach jêzyka Python.
61 Projekt zosta³ zainspirowany przez oprogramowanie naukowe takie jak
62 Mathematica, IDL oraz Mathcad, gdzie podobne idee mog± byæ realizowane
63 w wielu przypadkach.
64
65 Pakiet ten zawiera pow³okê IPython.
66
67 %package -n python-ipython
68 Summary:        An enhanced Interactive Python shell modules
69 Summary(pl):    Modu³y interaktywnej pow³oki jêzyka Python
70 Group:          Libraries/Python
71 %pyrequires_eq  python-modules
72 %pyrequires_eq  pydoc
73
74 %description -n python-ipython
75 IPython is a free software project which tries to:
76
77 1. Provide an interactive interpreter superior to Python's default.
78 IPython has many features for object introspection, shell access, and
79 its own special command system for adding functionality when working
80 interactively.
81
82 2. Serve as an embeddable, ready to use interpreter for your own
83 programs. IPython can be started with a single call from inside
84 another program, providing access to the current namespace. This can
85 be very useful both for debugging purposes and for situations where a
86 blend of batch-processing and interactive exploration are needed.
87
88 3. Offer a flexible framework which can be used as the base
89 environment for other systems with Python as the underlying language.
90 Specifically scientific environments like Mathematica, IDL and Mathcad
91 inspired its design, but similar ideas can be useful in many fields.
92
93 This package contains IPython modules.
94
95 %description -n python-ipython -l pl
96 IPython jest wolnym oprogramowaniem, którego celem jest:
97
98 1. Dostarczenie interaktywnej pow³oki lepszej od standardowej
99 dostarczanej z jêzykiem Python. IPython umo¿liwia badanie obiektów,
100 dostêp do pow³oki oraz w³asny system poleceñ, który umo¿liwia
101 rozszerzanie funkcjonalno¶ci podczas pracy interaktywnej.
102
103 2. Dostarczenie gotowego interpertera, który mo¿na do³±czaæ do w³asnej
104 aplikacji. IPython mo¿e zostaæ uruchomiony za pomoc± wywo³ania jednej
105 funkcji z poziomu innego programu umo¿liwiaj±c jednocze¶nie dostêp do
106 aktualnej przestrzeni nazw tego programu. Mo¿e to byæ bardzo u¿yteczne
107 do celów takich jak ¶ledzenie programu czy te¿ sytuacji gdzie jest
108 wymagane po³±czenie przetwarzania wsadowego z interaktywn±
109 introspekcj±.
110
111 3. Dostarczenie szkieletu, który mo¿e zostaæ u¿yty jako podstawa
112 systemu, którego polecenia opieraj± siê na zasadach jêzyka Python.
113 Projekt zosta³ zainspirowany przez oprogramowanie naukowe takie jak
114 Mathematica, IDL oraz Mathcad, gdzie podobne idee mog± byæ realizowane
115 w wielu przypadkach.
116
117 Pakiet ten zawiera modu³y interaktywnej pow³oki jêzyka Python.
118
119 %prep
120 %setup  -q -n %{pname}-%{version}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/*
133 %{_mandir}/man1/*
134
135 %files -n python-ipython
136 %defattr(644,root,root,755)
137 %doc README doc/{ChangeLog,NEWS} doc/manual doc/*.pdf
138 %dir %{py_sitedir}/%{pname}
139 %dir %{py_sitedir}/%{pname}/Extensions
140 %dir %{py_sitedir}/%{pname}/UserConfig
141 %{py_sitedir}/%{pname}/*.py?
142 %{py_sitedir}/%{pname}/Extensions/*.py?
143 %{py_sitedir}/%{pname}/UserConfig
This page took 0.060511 seconds and 4 git commands to generate.