]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- 2.6.7
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_with     uClibc          # do some hacks to build with uClibc
9 %bcond_with     iec_complaint   # fix bitrate calculations
10 #
11 Summary:        Utility to control Networking behavior in.X kernels
12 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
13 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
14 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
15 Name:           iproute2
16 %define sdate   040608
17 Version:        2.6.7
18 Release:        0.1
19 License:        GPL
20 Vendor:         Stephen Hemminger <shemminger@osdl.org>
21 Group:          Networking/Admin
22 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-ss%{sdate}.tar.gz
23 # Source0-md5:  28196897deb1a45295cd606bd911a33d
24 Patch0:         %{name}-db.patch
25 Patch1:         %{name}-arp.patch
26 URL:            http://developer.osdl.org/dev/iproute2/
27 BuildRequires:  bison
28 BuildRequires:  linux-libc-headers >= 7:2.6.5.1-4
29 %if %{with doc}
30 BuildRequires:  psutils
31 BuildRequires:  sgml-tools
32 BuildRequires:  tetex-dvips
33 BuildRequires:  tetex-latex
34 BuildRequires:  tetex-tex-babel
35 %endif
36 Obsoletes:      iproute
37 Conflicts:      ifstat
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _sbindir        /sbin
41 %define         _sysconfdir     /etc/iproute2
42
43 %description
44 Linux maintains compatibility with the basic configuration
45 utilities of the network (ifconfig, route) but a new utility is
46 required to exploit the new characteristics and features of the
47 kernel. This package includes the new utilities.
48
49 %description -l es
50 Linux mantiene compatibilidad con los utilitarios estándares de
51 configuración de la red, pero se necesitan nuevos utilitarios para
52 usar los recursos y características del nuevo núcleo. Este paquete
53 incluye los nuevos utilitarios.
54
55 %description -l pl
56 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
57 aspektów dotycz±cych sieci.
58
59 %description -l pt_BR
60 O Linux mantém compatibilidade com os utilitários padrão de
61 configuração da rede, mas novos utilitários são necessários para fazer
62 uso das características e recursos da nova kernel. This package
63 includes the new utilities.
64
65 %package -n libnetlink-devel
66 Summary:        Library for the netlink interface
67 Summary(pl):    Biblioteka do interfejsu netlink
68 Group:          Development/Libraries
69
70 %description -n libnetlink-devel
71 This library provides an interface for kernel-user netlink interface.
72
73 %description -n libnetlink-devel -l pl
74 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
75 a przestrzeni± u¿ytkownika.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 %{__make} \
84         CC="%{__cc}" \
85         CCOPTS="-D_GNU_SOURCE %{rpmcflags}" \
86         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
87
88 %{?with_doc:%{__make} -C doc}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
93
94 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
95 install etc/iproute2/rt_protos \
96         etc/iproute2/rt_realms \
97         etc/iproute2/rt_scopes \
98         etc/iproute2/rt_tables \
99         $RPM_BUILD_ROOT%{_sysconfdir}
100 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
101 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
102 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
110 %attr(755,root,root) %{_sbindir}/*
111 %dir %{_sysconfdir}
112 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
113 %{_mandir}/man8/*
114
115 %files -n libnetlink-devel
116 %defattr(644,root,root,755)
117 %{_libdir}/lib*.a
118 %{_includedir}/*.h
This page took 0.079821 seconds and 4 git commands to generate.