]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- misc/ subdir uses ldflags too.
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_without  atm             # don't required ATM.
9 %bcond_with     uClibc          # do some hacks to build with uClibc
10 #
11 Summary:        Utility to control Networking behavior in.X kernels
12 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
13 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
14 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
15 Name:           iproute2
16 %define sdate   050330
17 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
18 Version:        2.6.11
19 Release:        1
20 License:        GPL
21 Vendor:         Stephen Hemminger <shemminger@osdl.org>
22 Group:          Networking/Admin
23 #Source0:       http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-ss%{sdate}.tar.gz
24 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
25 # Source0-md5:  e705f26b5ae93e0332e46ae3ff15d934
26 #Source0:       http://developer.osdl.org/dev/iproute2/download/%{name}-%{sdate}.tar.gz
27 Patch0:         %{name}-build.patch
28 Patch1:         %{name}-arp.patch
29 # extensions
30 Patch10:        %{name}-2.2.4-wrr.patch
31 Patch11:        %{name}-2.2.4-esfq.patch
32 URL:            http://developer.osdl.org/dev/iproute2/
33 BuildRequires:  bison
34 BuildRequires:  db-devel
35 %if %{with atm}
36 BuildRequires:  linux-atm-devel
37 %endif
38 BuildRequires:  linux-libc-headers >= 7:2.6.11.2-2
39 %if %{with doc}
40 BuildRequires:  psutils
41 BuildRequires:  sgml-tools
42 BuildRequires:  tetex-dvips
43 BuildRequires:  tetex-fonts-jknappen
44 BuildRequires:  tetex-format-latex
45 BuildRequires:  tetex-metafont
46 BuildRequires:  tetex-tex-babel
47 %endif
48 Obsoletes:      iproute
49 Obsoletes:      ifstat
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _sbindir        /sbin
53 %define         _sysconfdir     /etc/iproute2
54
55 %description
56 Linux maintains compatibility with the basic configuration
57 utilities of the network (ifconfig, route) but a new utility is
58 required to exploit the new characteristics and features of the
59 kernel. This package includes the new utilities.
60
61 %description -l es
62 Linux mantiene compatibilidad con los utilitarios estándares de
63 configuración de la red, pero se necesitan nuevos utilitarios para
64 usar los recursos y características del nuevo núcleo. Este paquete
65 incluye los nuevos utilitarios.
66
67 %description -l pl
68 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
69 aspektów dotycz±cych sieci.
70
71 %description -l pt_BR
72 O Linux mantém compatibilidade com os utilitários padrão de
73 configuração da rede, mas novos utilitários são necessários para fazer
74 uso das características e recursos da nova kernel. This package
75 includes the new utilities.
76
77 %package -n libnetlink-devel
78 Summary:        Library for the netlink interface
79 Summary(pl):    Biblioteka do interfejsu netlink
80 Group:          Development/Libraries
81
82 %description -n libnetlink-devel
83 This library provides an interface for kernel-user netlink interface.
84
85 %description -n libnetlink-devel -l pl
86 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
87 a przestrzeni± u¿ytkownika.
88
89 %prep
90 %setup -q -n %{name}-%{version}-%{sdate}
91 rm -rf include-glibc
92 %patch0 -p1
93 %patch1 -p1
94
95 %patch10 -p1
96 %patch11 -p1
97
98 %build
99 rm -rf include/linux
100
101 %{__make} \
102         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
103         OPT="%{rpmcflags}" \
104         %{!?with_tc:SUBDIRS="lib ip misc"} \
105         LDFLAGS="%{rpmldflags}"
106
107 %{?with_doc:%{__make} -C doc}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
112
113 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
114 install etc/iproute2/rt_protos \
115         etc/iproute2/rt_realms \
116         etc/iproute2/rt_scopes \
117         etc/iproute2/rt_tables \
118         $RPM_BUILD_ROOT%{_sysconfdir}
119
120 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
121 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
122 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
123
124 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
125 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
133 %attr(755,root,root) %{_sbindir}/*
134 %dir %{_sysconfdir}
135 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
136 %{_mandir}/man8/*
137
138 %files -n libnetlink-devel
139 %defattr(644,root,root,755)
140 %{_libdir}/lib*.a
141 %{_includedir}/*.h
This page took 0.064444 seconds and 4 git commands to generate.