]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- rel 2; fix usage on older kernels (like 2.6.21)
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - fix iface_descr patch
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # don't required ATM.
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 #%bcond_with    iface_descr     # build with interface description support
12 #
13 Summary:        Utility to control Networking behavior in.X kernels
14 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl.UTF-8):      Narzędzie do kontrolowania Sieci w kernelach
16 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
19 Version:        2.6.23
20 Release:        2
21 License:        GPL
22 Group:          Networking/Admin
23 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}.tar.bz2
24 # Source0-md5:  2e59da739ef19990408cf0a5cb0cae3e
25 Patch0:         %{name}-build.patch
26 Patch1:         %{name}-arp.patch
27 Patch3:         %{name}-iptables.patch
28 Patch4:         %{name}-iptables64.patch
29 Patch5:         %{name}-LDFLAGS.patch
30 Patch6:         %{name}-nl-detect.patch
31 # extensions
32 Patch10:        %{name}-2.2.4-wrr.patch
33 Patch11:        esfq-%{name}.patch
34 Patch12:        001-net-dev-iface-descr-0.1.diff
35 Patch13:        %{name}-q_atm_c.patch
36 Patch14:        %{name}-q_srr.v0.4.patch
37 URL:            http://linux-net.osdl.org/index.php/Iproute2
38 BuildRequires:  bison
39 BuildRequires:  db-devel
40 BuildRequires:  flex
41 %if %{with atm}
42 BuildRequires:  linux-atm-devel
43 %endif
44 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
45 %if %{with doc}
46 BuildRequires:  psutils
47 BuildRequires:  sgml-tools
48 BuildRequires:  tetex-dvips
49 BuildRequires:  tetex-fonts-jknappen
50 BuildRequires:  tetex-format-latex
51 BuildRequires:  tetex-metafont
52 BuildRequires:  tetex-tex-babel
53 %endif
54 Obsoletes:      iproute
55 Obsoletes:      ifstat
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _sbindir        /sbin
59 %define         _sysconfdir     /etc/iproute2
60
61 %description
62 Linux maintains compatibility with the basic configuration utilities
63 of the network (ifconfig, route) but a new utility is required to
64 exploit the new characteristics and features of the kernel. This
65 package includes the new utilities.
66
67 %description -l es.UTF-8
68 Linux mantiene compatibilidad con los utilitarios estándares de
69 configuración de la red, pero se necesitan nuevos utilitarios para
70 usar los recursos y características del nuevo núcleo. Este paquete
71 incluye los nuevos utilitarios.
72
73 %description -l pl.UTF-8
74 Ten pakiet zawiera programy pozwalające na kontrolę routingu i innych
75 aspektów dotyczących sieci.
76
77 %description -l pt_BR.UTF-8
78 O Linux mantém compatibilidade com os utilitários padrão de
79 configuração da rede, mas novos utilitários são necessários para fazer
80 uso das características e recursos da nova kernel. This package
81 includes the new utilities.
82
83 %package -n libnetlink-devel
84 Summary:        Library for the netlink interface
85 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
86 Group:          Development/Libraries
87
88 %description -n libnetlink-devel
89 This library provides an interface for kernel-user netlink interface.
90
91 %description -n libnetlink-devel -l pl.UTF-8
92 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
93 a przestrzenią użytkownika.
94
95 %prep
96 %setup -q
97 #rm -rf include/linux
98 %patch0 -p1
99 %patch1 -p1
100
101 %if "%{_lib}" == "lib64"
102 %patch4 -p1
103 %else
104 %patch3 -p1
105 %endif
106 %patch5 -p1
107 %patch6 -p1
108
109 # extensions:
110 %patch10 -p1
111 %patch11 -p1
112 #%{?with_iface_descr:%patch12 -p1}
113 %patch13 -p0
114 %patch14 -p1
115
116 %build
117 %{__make} \
118 %if %{with uClibc}
119         CC="%{_target_cpu}-uclibc-gcc" \
120         LD="%{_target_cpu}-uclibc-gcc" \
121 %else
122         CC="%{__cc}" \
123         LD="%{__cc}" \
124 %endif
125         HOSTCC="%{__cc}" \
126         OPT="%{rpmcflags}" \
127         LDFLAGS="%{rpmldflags}" \
128         %{!?with_tc:SUBDIRS="lib ip misc"}
129
130 %{?with_doc:%{__make} -C doc}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
135
136 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
137 install etc/iproute2/rt_protos \
138         etc/iproute2/rt_realms \
139         etc/iproute2/rt_scopes \
140         etc/iproute2/rt_tables \
141         $RPM_BUILD_ROOT%{_sysconfdir}
142
143 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
144 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
145 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
146
147 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
148 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
149 %{?with_tc:install tc/*.so $RPM_BUILD_ROOT%{_libdir}/tc}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(644,root,root,755)
156 %doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
157 %doc ChangeLog %{?with_doc:doc/*.ps}
158 %attr(755,root,root) %{_sbindir}/*
159 %dir %{_sysconfdir}
160 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
161 %{_mandir}/man8/*
162 %{?with_tc:%dir %{_libdir}/tc}
163 %{?with_tc:%attr(755,root,root) %{_libdir}/tc/*.so}
164
165 %files -n libnetlink-devel
166 %defattr(644,root,root,755)
167 %{_libdir}/lib*.a
168 %{_includedir}/*.h
This page took 0.198584 seconds and 4 git commands to generate.