]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- tabs in preamble
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_without  atm             # don't required ATM.
9 %bcond_with     uClibc          # do some hacks to build with uClibc
10 %bcond_with     iface_descr     # build with interface description support
11 #
12 Summary:        Utility to control Networking behavior in.X kernels
13 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
14 Summary(pl.UTF-8):      Narzędzie do kontrolowania Sieci w kernelach
15 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
16 Name:           iproute2
17 %define sdate   061002
18 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
19 Version:        2.6.18
20 Release:        1.1
21 License:        GPL
22 Vendor:         Stephen Hemminger <shemminger@osdl.org>
23 Group:          Networking/Admin
24 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
25 # Source0-md5:  193b570128cf852afba337438413adf9
26 Patch0:         %{name}-build.patch
27 Patch1:         %{name}-arp.patch
28 Patch2:         %{name}-lex.patch
29 Patch3:         %{name}-iptables.patch
30 Patch4:         %{name}-iptables64.patch
31 Patch5:         %{name}-LDFLAGS.patch
32 # extensions
33 Patch10:        %{name}-2.2.4-wrr.patch
34 Patch11:        esfq-%{name}.patch
35 Patch12:        001-net-dev-iface-descr-0.1.diff
36 URL:            http://linux-net.osdl.org/index.php/Iproute2
37 BuildRequires:  bison
38 BuildRequires:  db-devel
39 BuildRequires:  flex
40 %if %{with atm}
41 BuildRequires:  linux-atm-devel
42 %endif
43 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
44 %if %{with doc}
45 BuildRequires:  psutils
46 BuildRequires:  sgml-tools
47 BuildRequires:  tetex-dvips
48 BuildRequires:  tetex-fonts-jknappen
49 BuildRequires:  tetex-format-latex
50 BuildRequires:  tetex-metafont
51 BuildRequires:  tetex-tex-babel
52 %endif
53 Obsoletes:      iproute
54 Obsoletes:      ifstat
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _sbindir        /sbin
58 %define         _sysconfdir     /etc/iproute2
59
60 %description
61 Linux maintains compatibility with the basic configuration utilities
62 of the network (ifconfig, route) but a new utility is required to
63 exploit the new characteristics and features of the kernel. This
64 package includes the new utilities.
65
66 %description -l es.UTF-8
67 Linux mantiene compatibilidad con los utilitarios estándares de
68 configuración de la red, pero se necesitan nuevos utilitarios para
69 usar los recursos y características del nuevo núcleo. Este paquete
70 incluye los nuevos utilitarios.
71
72 %description -l pl.UTF-8
73 Ten pakiet zawiera programy pozwalające na kontrolę routingu i innych
74 aspektów dotyczących sieci.
75
76 %description -l pt_BR.UTF-8
77 O Linux mantém compatibilidade com os utilitários padrão de
78 configuração da rede, mas novos utilitários são necessários para fazer
79 uso das características e recursos da nova kernel. This package
80 includes the new utilities.
81
82 %package -n libnetlink-devel
83 Summary:        Library for the netlink interface
84 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
85 Group:          Development/Libraries
86
87 %description -n libnetlink-devel
88 This library provides an interface for kernel-user netlink interface.
89
90 %description -n libnetlink-devel -l pl.UTF-8
91 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
92 a przestrzenią użytkownika.
93
94 %prep
95 %setup -q -n %{name}-%{version}-%{sdate}
96 rm -rf include-glibc include/linux
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100 %if "%{_lib}" == "lib64"
101 %patch4 -p1
102 %else
103 %patch3 -p1
104 %endif
105 %patch5 -p1
106
107 # extensions:
108 %patch10 -p1
109 %patch11 -p1
110 %{?with_iface_descr:%patch12 -p1}
111
112 %build
113 %{__make} \
114 %if %{with uClibc}
115         CC="%{_target_cpu}-uclibc-gcc" \
116         LD="%{_target_cpu}-uclibc-gcc" \
117 %else
118         CC="%{__cc}" \
119         LD="%{__cc}" \
120 %endif
121         HOSTCC="%{__cc}" \
122         OPT="%{rpmcflags}" \
123         LDFLAGS="%{rpmldflags}" \
124         %{!?with_tc:SUBDIRS="lib ip misc"}
125
126 %{?with_doc:%{__make} -C doc}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
131
132 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
133 install etc/iproute2/rt_protos \
134         etc/iproute2/rt_realms \
135         etc/iproute2/rt_scopes \
136         etc/iproute2/rt_tables \
137         $RPM_BUILD_ROOT%{_sysconfdir}
138
139 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
140 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
141 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
142
143 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
144 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 %doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
152 %doc ChangeLog %{?with_doc:doc/*.ps}
153 %attr(755,root,root) %{_sbindir}/*
154 %dir %{_sysconfdir}
155 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
156 %{_mandir}/man8/*
157
158 %files -n libnetlink-devel
159 %defattr(644,root,root,755)
160 %{_libdir}/lib*.a
161 %{_includedir}/*.h
This page took 0.046805 seconds and 4 git commands to generate.