]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- HFSC support added ( http://www-2.cs.cmu.edu/~hzhang/HFSC/main.html ).
[packages/iproute2.git] / iproute2.spec
1 #
2 # Conditional build
3 %bcond_without  doc     # don't build documentation
4 %bcond_without  tc      # don't build tc program (it breaks static linkage)
5 %bcond_with     uClibc  # do some hacks to build with uClibc
6 #
7 Summary:        Utility to control Networking behavior in 2.2.X kernels
8 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
9 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
10 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
11 Name:           iproute2
12 %define         mainver         2.4.7
13 %define         snapshot        ss020116
14 Version:        %{mainver}.%{snapshot}
15 Release:        16
16 License:        GPL
17 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
18 Group:          Networking/Admin
19 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
20 # Source0-md5:  2c7e5f3a10e703745ecdc613f7a7d187
21 Source1:        %{name}-owl-man.tar.bz2
22 # Source1-md5:  cd4425df972a4ab001db31a5eb1c5da5
23 Patch0:         %{name}-Makefile.patch
24 Patch1:         %{name}-llh.patch
25 Patch2:         %{name}-diffserv-config.patch
26 Patch3:         %{name}-netlink.patch
27 Patch4:         %{name}-ipaddress.patch
28 Patch5:         %{name}-iprule.patch
29 # uClibc hacks
30 Patch6:         %{name}-uClibc.patch
31 # extensions
32 Patch10:        %{name}-htb3.6_tc.patch
33 Patch11:        %{name}-2.2.4-wrr.patch
34 Patch12:        %{name}-2.2.4-esfq.patch
35 Patch13:        %{name}-hfsc.patch
36 BuildRequires:  bison
37 BuildRequires:  linux-libc-headers >= 7:2.6.4.0-3
38 %if %{with doc}
39 BuildRequires:  psutils
40 BuildRequires:  sgml-tools
41 BuildRequires:  tetex-dvips
42 BuildRequires:  tetex-latex
43 BuildRequires:  tetex-tex-babel
44 %endif
45 Obsoletes:      iproute
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _sbindir        /sbin
49 %define         _sysconfdir     /etc/iproute2
50
51 %description
52 Linux 2.2 maintains compatibility with the basic configuration
53 utilities of the network (ifconfig, route) but a new utility is
54 required to exploit the new characteristics and features of the
55 kernel. This package includes the new utilities.
56
57 %description -l es
58 Linux mantiene compatibilidad con los utilitarios estándares de
59 configuración de la red, pero se necesitan nuevos utilitarios para
60 usar los recursos y características del nuevo núcleo. Este paquete
61 incluye los nuevos utilitarios.
62
63 %description -l pl
64 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
65 aspektów dotycz±cych sieci.
66
67 %description -l pt_BR
68 O Linux mantém compatibilidade com os utilitários padrão de
69 configuração da rede, mas novos utilitários são necessários para fazer
70 uso das características e recursos da nova kernel. This package
71 includes the new utilities.
72
73 %package -n libnetlink-devel
74 Summary:        Library for the netlink interface
75 Summary(pl):    Biblioteka do interfejsu netlink
76 Group:          Development/Libraries
77
78 %description -n libnetlink-devel
79 This library provides an interface for kernel-user netlink interface.
80
81 %description -n libnetlink-devel -l pl
82 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
83 a przestrzeni± u¿ytkownika.
84
85 %prep
86 %setup -q -n %{name} -a1
87 rm -rf include-glibc
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 %patch4 -p1
93 %patch5 -p1
94 %{?with_uClibc:%patch6 -p1}
95 %patch10 -p1
96 %patch11 -p1
97 %patch12 -p1
98 %patch13 -p1
99
100 %build
101 %{__make} \
102         CC="%{__cc}" \
103         OPT="%{rpmcflags}" \
104         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
105
106 %{?with_doc:%{__make} -C doc}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
111
112 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
113 install etc/iproute2/rt_protos \
114         etc/iproute2/rt_realms \
115         etc/iproute2/rt_scopes \
116         etc/iproute2/rt_tables \
117         $RPM_BUILD_ROOT%{_sysconfdir}
118 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
119 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
120 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
128 %attr(755,root,root) %{_sbindir}/*
129 %dir %{_sysconfdir}
130 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
131 %{_mandir}/man8/*
132
133 %files -n libnetlink-devel
134 %defattr(644,root,root,755)
135 %{_libdir}/lib*.a
136 %{_includedir}/*.h
This page took 0.108164 seconds and 4 git commands to generate.