]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- massive attack: source-md5
[packages/iproute2.git] / iproute2.spec
1 # conditional build
2 # --without tetex       # with tetex-2 there shuld be BR tetex-tex-babel
3 # --without tc (don't build tc program, it break static linkage)
4 # --without dist_kernel
5
6 %define         _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
7 %define mainver         2.4.7
8 %define snapshot        ss020116
9 Summary:        Utility to control Networking behavior in 2.2.X kernels
10 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
11 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
12 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
13 Name:           iproute2
14 Version:        %{mainver}.%{snapshot}
15 %define _rel    10
16 Release:        %{_rel}@%{_kernel_ver_str}
17 License:        GPL
18 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
19 Group:          Networking/Admin
20 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
21 # Source0-md5:  2c7e5f3a10e703745ecdc613f7a7d187
22 Source1:        %{name}-owl-man.tar.bz2
23 # Source1-md5: cd4425df972a4ab001db31a5eb1c5da5
24 Patch0:         %{name}-make.patch
25 Patch1:         %{name}-uClibc.patch
26 Patch2:         %{name}-fix-2_2.patch
27 Patch3:         %{name}-label.patch
28 Patch4:         %{name}-latest.patch
29 Patch5:         %{name}-htb2_tc.patch
30 Patch6:         wrr-iproute2-2.2.4.patch
31 Patch7:         htb3.6_tc.patch
32 Patch8:         %{name}-no_libresolv.patch
33 %{!?_without_tc:BuildRequires:  db-devel}
34 BuildRequires:  bison
35 %{!?_without_tetex:BuildRequires:       latex2html}
36 %{!?_without_tetex:BuildRequires:       psutils}
37 %{!?_without_tetex:BuildRequires:       sgml-tools}
38 %{!?_without_tetex:BuildRequires:       tetex-dvips}
39 %{!?_without_tetex:BuildRequires:       tetex-latex}
40 Obsoletes:      iproute
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _sbindir        /sbin
44 %define         _sysconfdir     /etc/iproute2
45
46 %description
47 Linux 2.2 maintains compatibility with the basic configuration
48 utilities of the network (ifconfig, route) but a new utility is
49 required to exploit the new characteristics and features of the
50 kernel. This package includes the new utilities.
51
52 %description -l es
53 Linux mantiene compatibilidad con los utilitarios estándares de
54 configuración de la red, pero se necesitan nuevos utilitarios para
55 usar los recursos y características del nuevo núcleo. Este paquete
56 incluye los nuevos utilitarios.
57
58 %description -l pl
59 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
60 aspektów dotycz±cych sieci.
61
62 %description -l pt_BR
63 O Linux mantém compatibilidade com os utilitários padrão de
64 configuração da rede, mas novos utilitários são necessários para fazer
65 uso das características e recursos da nova kernel. This package
66 includes the new utilities.
67
68 %package -n libnetlink-devel
69 Summary:        Library for the netlink interface
70 Summary(pl):    Biblioteka do interfejsu netlink
71 Group:          Development/Libraries
72
73 %description -n libnetlink-devel
74 This library provides an interface for kernel-user netlink interface.
75
76 %description -n libnetlink-devel -l pl
77 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
78 a przestrzeni± u¿ytkownika.
79
80 %prep
81 %setup -q -n %{name} -a1
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 #%%patch3 -p1
86 #%%patch4 -p1
87 %if %{_kernel24}
88 %patch7 -p1
89 %else
90 %patch5 -p1
91 %endif
92 %patch6 -p1
93 %patch8 -p1
94
95 %build
96 WRRDEF=""
97 grep -q tc_wrr_class_weight /usr/include/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"
98
99 %{__make} \
100         CC="%{__cc}" \
101         OPT="%{rpmcflags} ${WRRDEF}" \
102         KERNEL_INCLUDE="%{_kernelsrcdir}/include" \
103         %{?_without_tc:SUBDIRS="lib ip" LDFLAGS="%{rpmldflags}"}
104 %{!?_without_tetex:%{__make} -C doc}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
109
110 install ip/{ip,rtmon,routel} %{!?_without_tc:tc/tc} $RPM_BUILD_ROOT%{_sbindir}
111 install etc/iproute2/rt_protos \
112         etc/iproute2/rt_realms \
113         etc/iproute2/rt_scopes \
114         etc/iproute2/rt_tables \
115         $RPM_BUILD_ROOT%{_sysconfdir}
116 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
117 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
118 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc README README.iproute2+tc RELNOTES
126 %{!?_without_tetex:%doc doc/*.ps}
127 %attr(755,root,root) %{_sbindir}/*
128 %dir %{_sysconfdir}
129 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
130 %{_mandir}/man8/*
131
132 %files -n libnetlink-devel
133 %defattr(644,root,root,755)
134 %{_libdir}/*
135 %{_includedir}/*
This page took 0.042882 seconds and 4 git commands to generate.