]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- limit number of loop passes while address flushing to 10k; rel 16. (note that this...
[packages/iproute2.git] / iproute2.spec
1 #
2 # Conditional build
3 %bcond_without  tetex   # don't build documentation
4 %bcond_without  tc      # don't build tc program (it breaks static linkage)
5 %bcond_without  tc_esfq # build tc without esfq support (requires patched headers)
6 %bcond_without  tc_wrr  # build tc without wrr support
7 %bcond_with     uClibc  # do some hacks to build with uClibc
8
9 Summary:        Utility to control Networking behavior in 2.2.X kernels
10 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
11 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
12 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
13 Name:           iproute2
14 %define mainver 2.4.7
15 %define snapshot ss020116
16 Version:        %{mainver}.%{snapshot}
17 Release:        16
18 License:        GPL
19 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
20 Group:          Networking/Admin
21 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
22 # Source0-md5:  2c7e5f3a10e703745ecdc613f7a7d187
23 Source1:        %{name}-owl-man.tar.bz2
24 # Source1-md5:  cd4425df972a4ab001db31a5eb1c5da5
25 Patch0:         %{name}-make.patch
26 Patch1:         %{name}-no_libresolv.patch
27 Patch2:         %{name}-disable_arpd.patch
28 Patch3:         %{name}-uspace.patch
29 Patch4:         %{name}-diffserv-config.patch
30 Patch5:         %{name}-netlink.patch
31 Patch6:         %{name}-kernellast.patch
32 # uClibc hacks
33 Patch7:         %{name}-uClibc.patch
34 Patch8:         htb3.6_tc.patch
35 Patch9:         %{name}-stats.patch
36 # extensions
37 Patch10:        wrr-iproute2-2.2.4.patch
38 Patch11:        %{name}-2.2.4-now-ss001007-esfq.diff
39 Patch12:        %{name}-kernel_headers.patch
40 Patch13:        %{name}-ipaddress.patch
41 Patch14:        %{name}-a-flush-hack.patch
42 BuildRequires:  bison
43 %{?with_tetex:BuildRequires:    psutils}
44 %{?with_tetex:BuildRequires:    sgml-tools}
45 %{?with_tetex:BuildRequires:    tetex-dvips}
46 %{?with_tetex:BuildRequires:    tetex-latex}
47 %{?with_tetex:BuildRequires:    tetex-tex-babel}
48 Obsoletes:      iproute
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _sbindir        /sbin
52 %define         _sysconfdir     /etc/iproute2
53
54 %description
55 Linux 2.2 maintains compatibility with the basic configuration
56 utilities of the network (ifconfig, route) but a new utility is
57 required to exploit the new characteristics and features of the
58 kernel. This package includes the new utilities.
59
60 %description -l es
61 Linux mantiene compatibilidad con los utilitarios estándares de
62 configuración de la red, pero se necesitan nuevos utilitarios para
63 usar los recursos y características del nuevo núcleo. Este paquete
64 incluye los nuevos utilitarios.
65
66 %description -l pl
67 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
68 aspektów dotycz±cych sieci.
69
70 %description -l pt_BR
71 O Linux mantém compatibilidade com os utilitários padrão de
72 configuração da rede, mas novos utilitários são necessários para fazer
73 uso das características e recursos da nova kernel. This package
74 includes the new utilities.
75
76 %package -n libnetlink-devel
77 Summary:        Library for the netlink interface
78 Summary(pl):    Biblioteka do interfejsu netlink
79 Group:          Development/Libraries
80
81 %description -n libnetlink-devel
82 This library provides an interface for kernel-user netlink interface.
83
84 %description -n libnetlink-devel -l pl
85 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
86 a przestrzeni± u¿ytkownika.
87
88 %prep
89 %setup -q -n %{name} -a1
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93 %patch3 -p1
94 %patch4 -p1
95 %patch5 -p1
96 %patch6 -p1
97 %{?with_uClibc:%patch7 -p1}
98 %patch8 -p1
99 %patch9 -p1
100 %{?with_tc_wrr:%patch10 -p1}
101 %{?with_tc_esfq:%patch11 -p1}
102 %patch12 -p1
103 %patch13 -p1
104 %patch14 -p1
105
106 %build
107 WRRDEF=""
108 %{?with_tc_wrr:grep -q tc_wrr_class_weight kernel-headers/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"}
109
110 %{__make} \
111         CC="%{__cc}" \
112         OPT="%{rpmcflags} ${WRRDEF}" \
113         KERNEL_INCLUDE="`pwd`/kernel-headers" \
114         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
115
116 %{?with_tetex:%{__make} -C doc}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
121
122 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat} $RPM_BUILD_ROOT%{_sbindir}
123 install etc/iproute2/rt_protos \
124         etc/iproute2/rt_realms \
125         etc/iproute2/rt_scopes \
126         etc/iproute2/rt_tables \
127         $RPM_BUILD_ROOT%{_sysconfdir}
128 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
129 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
130 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc README README.iproute2+tc RELNOTES %{?with_tetex:doc/*.ps}
138 %attr(755,root,root) %{_sbindir}/*
139 %dir %{_sysconfdir}
140 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
141 %{_mandir}/man8/*
142
143 %files -n libnetlink-devel
144 %defattr(644,root,root,755)
145 %{_libdir}/lib*.a
146 %{_includedir}/*.h
This page took 0.073 seconds and 4 git commands to generate.