]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- atm enabled.
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_with     uClibc          # do some hacks to build with uClibc
9 %bcond_with     iec_complaint   # fix bitrate calculations
10 #
11 Summary:        Utility to control Networking behavior in.X kernels
12 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
13 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
14 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
15 Name:           iproute2
16 %define sdate   040730
17 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
18 Version:        2.6.8
19 Release:        2
20 License:        GPL
21 Vendor:         Stephen Hemminger <shemminger@osdl.org>
22 Group:          Networking/Admin
23 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-2.6.8-ss%{sdate}.tar.gz
24 # Source0-md5:  0d8c23f6c3a42bb680c3bdf9f580987a
25 Patch0:         %{name}-build.patch
26 Patch2:         %{name}-arp.patch
27 Patch4:         %{name}-ipaddress.patch
28 # extensions
29 Patch10:        %{name}-2.2.4-wrr.patch
30 Patch11:        %{name}-2.2.4-esfq.patch
31 Patch13:        %{name}-rates-1024-fix.patch
32 URL:            http://developer.osdl.org/dev/iproute2/
33 BuildRequires:  bison
34 BuildRequires:  db-devel
35 BuildRequires:  linux-atm-devel
36 BuildRequires:  linux-libc-headers >= 7:2.6.7.0-9
37 %if %{with doc}
38 BuildRequires:  psutils
39 BuildRequires:  sgml-tools
40 BuildRequires:  tetex-dvips
41 BuildRequires:  tetex-fonts-jknappen
42 BuildRequires:  tetex-format-latex
43 BuildRequires:  tetex-metafont
44 BuildRequires:  tetex-tex-babel
45 %endif
46 Obsoletes:      iproute
47 Obsoletes:      ifstat
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _sbindir        /sbin
51 %define         _sysconfdir     /etc/iproute2
52
53 %description
54 Linux maintains compatibility with the basic configuration
55 utilities of the network (ifconfig, route) but a new utility is
56 required to exploit the new characteristics and features of the
57 kernel. This package includes the new utilities.
58
59 %description -l es
60 Linux mantiene compatibilidad con los utilitarios estándares de
61 configuración de la red, pero se necesitan nuevos utilitarios para
62 usar los recursos y características del nuevo núcleo. Este paquete
63 incluye los nuevos utilitarios.
64
65 %description -l pl
66 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
67 aspektów dotycz±cych sieci.
68
69 %description -l pt_BR
70 O Linux mantém compatibilidade com os utilitários padrão de
71 configuração da rede, mas novos utilitários são necessários para fazer
72 uso das características e recursos da nova kernel. This package
73 includes the new utilities.
74
75 %package -n libnetlink-devel
76 Summary:        Library for the netlink interface
77 Summary(pl):    Biblioteka do interfejsu netlink
78 Group:          Development/Libraries
79
80 %description -n libnetlink-devel
81 This library provides an interface for kernel-user netlink interface.
82
83 %description -n libnetlink-devel -l pl
84 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
85 a przestrzeni± u¿ytkownika.
86
87 %prep
88 %setup -q
89 rm -rf include-glibc
90 %patch0 -p1
91 %patch2 -p1
92 %patch4 -p1
93
94 %patch10 -p1
95 %patch11 -p1
96 %{?with_iec_complaint:%patch13 -p1}
97
98 %build
99 %{__make} \
100         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
101         OPT="%{rpmcflags}" \
102         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
103
104 %{?with_doc:%{__make} -C doc}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
109
110 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
111 install etc/iproute2/rt_protos \
112         etc/iproute2/rt_realms \
113         etc/iproute2/rt_scopes \
114         etc/iproute2/rt_tables \
115         $RPM_BUILD_ROOT%{_sysconfdir}
116
117 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
118 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
119 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
120
121 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
122 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
130 %attr(755,root,root) %{_sbindir}/*
131 %dir %{_sysconfdir}
132 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
133 %{_mandir}/man8/*
134
135 %files -n libnetlink-devel
136 %defattr(644,root,root,755)
137 %{_libdir}/lib*.a
138 %{_includedir}/*.h
This page took 0.263846 seconds and 4 git commands to generate.