]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- added iproute2-match-nfmark-in-u32.patch
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - remove -DCONFIG_CLS_U32_PERF=1 when llh will be fixed
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # don't required ATM.
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 %bcond_with     iec_complaint   # fix bitrate calculations
12 #
13 Summary:        Utility to control Networking behavior in.X kernels
14 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
16 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 %define sdate   041019
19 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
20 Version:        2.6.9
21 Release:        0.1
22 License:        GPL
23 Vendor:         Stephen Hemminger <shemminger@osdl.org>
24 Group:          Networking/Admin
25 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
26 # Source0-md5:  4b3f335b0139cb909c6a2ae8bf72e548
27 Patch0:         %{name}-build.patch
28 Patch1:         %{name}-arp.patch
29 # extensions
30 Patch10:        %{name}-2.2.4-wrr.patch
31 Patch11:        %{name}-2.2.4-esfq.patch
32 Patch13:        %{name}-rates-1024-fix.patch
33 Patch14:        %{name}-match-nfmark-in-u32.patch
34 URL:            http://developer.osdl.org/dev/iproute2/
35 BuildRequires:  bison
36 BuildRequires:  db-devel
37 %if %{with atm}
38 BuildRequires:  linux-atm-devel
39 %endif
40 BuildRequires:  linux-libc-headers >= 7:2.6.7.0-9
41 %if %{with doc}
42 BuildRequires:  psutils
43 BuildRequires:  sgml-tools
44 BuildRequires:  tetex-dvips
45 BuildRequires:  tetex-fonts-jknappen
46 BuildRequires:  tetex-format-latex
47 BuildRequires:  tetex-metafont
48 BuildRequires:  tetex-tex-babel
49 %endif
50 Obsoletes:      iproute
51 Obsoletes:      ifstat
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _sbindir        /sbin
55 %define         _sysconfdir     /etc/iproute2
56
57 %description
58 Linux maintains compatibility with the basic configuration
59 utilities of the network (ifconfig, route) but a new utility is
60 required to exploit the new characteristics and features of the
61 kernel. This package includes the new utilities.
62
63 %description -l es
64 Linux mantiene compatibilidad con los utilitarios estándares de
65 configuración de la red, pero se necesitan nuevos utilitarios para
66 usar los recursos y características del nuevo núcleo. Este paquete
67 incluye los nuevos utilitarios.
68
69 %description -l pl
70 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
71 aspektów dotycz±cych sieci.
72
73 %description -l pt_BR
74 O Linux mantém compatibilidade com os utilitários padrão de
75 configuração da rede, mas novos utilitários são necessários para fazer
76 uso das características e recursos da nova kernel. This package
77 includes the new utilities.
78
79 %package -n libnetlink-devel
80 Summary:        Library for the netlink interface
81 Summary(pl):    Biblioteka do interfejsu netlink
82 Group:          Development/Libraries
83
84 %description -n libnetlink-devel
85 This library provides an interface for kernel-user netlink interface.
86
87 %description -n libnetlink-devel -l pl
88 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
89 a przestrzeni± u¿ytkownika.
90
91 %prep
92 %setup -q
93 rm -rf include-glibc
94 %patch0 -p1
95 %patch1 -p1
96
97 %patch10 -p1
98 %patch11 -p1
99 %{?with_iec_complaint:%patch13 -p1}
100 %patch14 -p1
101
102 %build
103 rm -rf include/linux
104
105 %{__make} \
106         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
107         OPT="%{rpmcflags} -DCONFIG_CLS_U32_PERF=1" \
108         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
109
110 %{?with_doc:%{__make} -C doc}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
115
116 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
117 install etc/iproute2/rt_protos \
118         etc/iproute2/rt_realms \
119         etc/iproute2/rt_scopes \
120         etc/iproute2/rt_tables \
121         $RPM_BUILD_ROOT%{_sysconfdir}
122
123 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
124 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
125 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
126
127 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
128 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
136 %attr(755,root,root) %{_sbindir}/*
137 %dir %{_sysconfdir}
138 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
139 %{_mandir}/man8/*
140
141 %files -n libnetlink-devel
142 %defattr(644,root,root,755)
143 %{_libdir}/lib*.a
144 %{_includedir}/*.h
This page took 0.067233 seconds and 4 git commands to generate.