]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- enabled wrr - with new patch builds fine
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - fix iface_descr patch
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # don't required ATM.
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 #%bcond_with    iface_descr     # build with interface description support
12 #
13 Summary:        Utility to control Networking behavior in.X kernels
14 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl.UTF-8):      Narzędzie do kontrolowania Sieci w kernelach
16 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 %define sdate   070313
19 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
20 Version:        2.6.20
21 Release:        0.1     
22 License:        GPL
23 Vendor:         Stephen Hemminger <shemminger@osdl.org>
24 Group:          Networking/Admin
25 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
26 # Source0-md5:  7bc5883aadf740761fa2dd70b661e8cc
27 #Patch0:                %{name}-build.patch
28 Patch1:         %{name}-arp.patch
29 Patch2:         %{name}-lex.patch
30 Patch3:         %{name}-iptables.patch
31 Patch4:         %{name}-iptables64.patch
32 Patch5:         %{name}-LDFLAGS.patch
33 # extensions
34 Patch10:        %{name}-2.2.4-wrr.patch
35 Patch11:        esfq-%{name}.patch
36 Patch12:        001-net-dev-iface-descr-0.1.diff
37 URL:            http://linux-net.osdl.org/index.php/Iproute2
38 BuildRequires:  bison
39 BuildRequires:  db-devel
40 BuildRequires:  flex
41 %if %{with atm}
42 BuildRequires:  linux-atm-devel
43 %endif
44 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
45 %if %{with doc}
46 BuildRequires:  psutils
47 BuildRequires:  sgml-tools
48 BuildRequires:  tetex-dvips
49 BuildRequires:  tetex-fonts-jknappen
50 BuildRequires:  tetex-format-latex
51 BuildRequires:  tetex-metafont
52 BuildRequires:  tetex-tex-babel
53 %endif
54 Obsoletes:      iproute
55 Obsoletes:      ifstat
56 BuildRoot:      %{tmpdir}/iproute-%{version}-root-%(id -u -n)
57
58 %define         _sbindir        /sbin
59 %define         _sysconfdir     /etc/iproute2
60
61 %description
62 Linux maintains compatibility with the basic configuration utilities
63 of the network (ifconfig, route) but a new utility is required to
64 exploit the new characteristics and features of the kernel. This
65 package includes the new utilities.
66
67 %description -l es.UTF-8
68 Linux mantiene compatibilidad con los utilitarios estándares de
69 configuración de la red, pero se necesitan nuevos utilitarios para
70 usar los recursos y características del nuevo núcleo. Este paquete
71 incluye los nuevos utilitarios.
72
73 %description -l pl.UTF-8
74 Ten pakiet zawiera programy pozwalające na kontrolę routingu i innych
75 aspektów dotyczących sieci.
76
77 %description -l pt_BR.UTF-8
78 O Linux mantém compatibilidade com os utilitários padrão de
79 configuração da rede, mas novos utilitários são necessários para fazer
80 uso das características e recursos da nova kernel. This package
81 includes the new utilities.
82
83 %package -n libnetlink-devel
84 Summary:        Library for the netlink interface
85 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
86 Group:          Development/Libraries
87
88 %description -n libnetlink-devel
89 This library provides an interface for kernel-user netlink interface.
90
91 %description -n libnetlink-devel -l pl.UTF-8
92 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
93 a przestrzenią użytkownika.
94
95 %prep
96 %setup -q -n iproute-%{version}-%{sdate}
97 #rm -rf include-glibc include/linux
98 #%patch0 -p1
99 %patch1 -p1
100 #%patch2 -p1
101 %if "%{_lib}" == "lib64"
102 %patch4 -p1
103 %else
104 %patch3 -p1
105 %endif
106 %patch5 -p1
107
108 # extensions:
109 %patch10 -p1
110 %patch11 -p1
111 #%{?with_iface_descr:%patch12 -p1}
112
113 %build
114 %{__make} \
115 %if %{with uClibc}
116         CC="%{_target_cpu}-uclibc-gcc" \
117         LD="%{_target_cpu}-uclibc-gcc" \
118 %else
119         CC="%{__cc}" \
120         LD="%{__cc}" \
121 %endif
122         HOSTCC="%{__cc}" \
123         OPT="%{rpmcflags}" \
124         LDFLAGS="%{rpmldflags}" \
125         %{!?with_tc:SUBDIRS="lib ip misc"}
126
127 %{?with_doc:%{__make} -C doc}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
132
133 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
134 install etc/iproute2/rt_protos \
135         etc/iproute2/rt_realms \
136         etc/iproute2/rt_scopes \
137         etc/iproute2/rt_tables \
138         $RPM_BUILD_ROOT%{_sysconfdir}
139
140 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
141 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
142 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
143
144 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
145 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
146 %{?with_tc:install tc/*.so $RPM_BUILD_ROOT%{_libdir}/tc}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %files
152 %defattr(644,root,root,755)
153 %doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
154 %doc ChangeLog %{?with_doc:doc/*.ps}
155 %attr(755,root,root) %{_sbindir}/*
156 %dir %{_sysconfdir}
157 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
158 %{_mandir}/man8/*
159 %{?with_tc:%dir %{_libdir}/tc}
160 %{?with_tc:%attr(755,root,root) %{_libdir}/tc/*.so}
161
162 %files -n libnetlink-devel
163 %defattr(644,root,root,755)
164 %{_libdir}/lib*.a
165 %{_includedir}/*.h
This page took 0.049752 seconds and 4 git commands to generate.