]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- rm -rf include-glibc to be sure
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_with     uClibc          # do some hacks to build with uClibc
9 %bcond_with     iec_complaint   # fix bitrate calculations
10 #
11 Summary:        Utility to control Networking behavior in.X kernels
12 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
13 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
14 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
15 Name:           iproute2
16 %define sdate   040608
17 Version:        2.6.7
18 Release:        0.1
19 License:        GPL
20 Vendor:         Stephen Hemminger <shemminger@osdl.org>
21 Group:          Networking/Admin
22 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-ss%{sdate}.tar.gz
23 # Source0-md5:  28196897deb1a45295cd606bd911a33d
24 Patch0:         %{name}-build.patch
25 Patch1:         %{name}-db.patch
26 Patch2:         %{name}-arp.patch
27 Patch3:         %{name}-diffserv-config.patch
28 Patch4:         %{name}-ipaddress.patch
29 # extensions
30 Patch10:        %{name}-2.2.4-wrr.patch
31 Patch11:        %{name}-2.2.4-esfq.patch
32 Patch12:        %{name}-hfsc.patch
33 Patch13:        %{name}-rates-1024-fix.patch
34 URL:            http://developer.osdl.org/dev/iproute2/
35 BuildRequires:  bison
36 BuildRequires:  linux-libc-headers >= 7:2.6.6.0-2
37 %if %{with doc}
38 BuildRequires:  psutils
39 BuildRequires:  sgml-tools
40 BuildRequires:  tetex-dvips
41 BuildRequires:  tetex-latex
42 BuildRequires:  tetex-tex-babel
43 %endif
44 Obsoletes:      iproute
45 Conflicts:      ifstat
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _sbindir        /sbin
49 %define         _sysconfdir     /etc/iproute2
50
51 %description
52 Linux maintains compatibility with the basic configuration
53 utilities of the network (ifconfig, route) but a new utility is
54 required to exploit the new characteristics and features of the
55 kernel. This package includes the new utilities.
56
57 %description -l es
58 Linux mantiene compatibilidad con los utilitarios estándares de
59 configuración de la red, pero se necesitan nuevos utilitarios para
60 usar los recursos y características del nuevo núcleo. Este paquete
61 incluye los nuevos utilitarios.
62
63 %description -l pl
64 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
65 aspektów dotycz±cych sieci.
66
67 %description -l pt_BR
68 O Linux mantém compatibilidade com os utilitários padrão de
69 configuração da rede, mas novos utilitários são necessários para fazer
70 uso das características e recursos da nova kernel. This package
71 includes the new utilities.
72
73 %package -n libnetlink-devel
74 Summary:        Library for the netlink interface
75 Summary(pl):    Biblioteka do interfejsu netlink
76 Group:          Development/Libraries
77
78 %description -n libnetlink-devel
79 This library provides an interface for kernel-user netlink interface.
80
81 %description -n libnetlink-devel -l pl
82 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
83 a przestrzeni± u¿ytkownika.
84
85 %prep
86 %setup -q
87 rm -rf include-glibc
88 %patch0 -p1
89 %patch2 -p1
90 %patch3 -p1
91 %patch4 -p1
92
93 %patch10 -p1
94 %patch11 -p1
95 %patch12 -p1
96 %{?with_iec_complaint:%patch13 -p1}
97
98 %build
99 %{__make} \
100         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
101         OPT="%{rpmcflags}" \
102         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
103
104 %{?with_doc:%{__make} -C doc}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
109
110 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
111 install etc/iproute2/rt_protos \
112         etc/iproute2/rt_realms \
113         etc/iproute2/rt_scopes \
114         etc/iproute2/rt_tables \
115         $RPM_BUILD_ROOT%{_sysconfdir}
116
117 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
118 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
119 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
120
121 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
122 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
130 %attr(755,root,root) %{_sbindir}/*
131 %dir %{_sysconfdir}
132 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
133 %{_mandir}/man8/*
134
135 %files -n libnetlink-devel
136 %defattr(644,root,root,755)
137 %{_libdir}/lib*.a
138 %{_includedir}/*.h
This page took 0.051149 seconds and 4 git commands to generate.