]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- updated to 040823
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - remove -DCONFIG_CLS_U32_PERF=1 when llh will be fixed
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_with     uClibc          # do some hacks to build with uClibc
10 %bcond_with     iec_complaint   # fix bitrate calculations
11 #
12 Summary:        Utility to control Networking behavior in.X kernels
13 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
14 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
15 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
16 Name:           iproute2
17 %define sdate   040823
18 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
19 Version:        2.6.8
20 Release:        3
21 License:        GPL
22 Vendor:         Stephen Hemminger <shemminger@osdl.org>
23 Group:          Networking/Admin
24 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-2.6.8-%{sdate}.tar.gz
25 # Source0-md5:  dab25877d70f132dcfeaba373805d867
26 Patch0:         %{name}-build.patch
27 Patch2:         %{name}-arp.patch
28 Patch4:         %{name}-ipaddress.patch
29 # extensions
30 Patch10:        %{name}-2.2.4-wrr.patch
31 Patch11:        %{name}-2.2.4-esfq.patch
32 Patch13:        %{name}-rates-1024-fix.patch
33 URL:            http://developer.osdl.org/dev/iproute2/
34 BuildRequires:  bison
35 BuildRequires:  db-devel
36 BuildRequires:  linux-atm-devel
37 BuildRequires:  linux-libc-headers >= 7:2.6.7.0-9
38 %if %{with doc}
39 BuildRequires:  psutils
40 BuildRequires:  sgml-tools
41 BuildRequires:  tetex-dvips
42 BuildRequires:  tetex-fonts-jknappen
43 BuildRequires:  tetex-format-latex
44 BuildRequires:  tetex-metafont
45 BuildRequires:  tetex-tex-babel
46 %endif
47 Obsoletes:      iproute
48 Obsoletes:      ifstat
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _sbindir        /sbin
52 %define         _sysconfdir     /etc/iproute2
53
54 %description
55 Linux maintains compatibility with the basic configuration
56 utilities of the network (ifconfig, route) but a new utility is
57 required to exploit the new characteristics and features of the
58 kernel. This package includes the new utilities.
59
60 %description -l es
61 Linux mantiene compatibilidad con los utilitarios estándares de
62 configuración de la red, pero se necesitan nuevos utilitarios para
63 usar los recursos y características del nuevo núcleo. Este paquete
64 incluye los nuevos utilitarios.
65
66 %description -l pl
67 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
68 aspektów dotycz±cych sieci.
69
70 %description -l pt_BR
71 O Linux mantém compatibilidade com os utilitários padrão de
72 configuração da rede, mas novos utilitários são necessários para fazer
73 uso das características e recursos da nova kernel. This package
74 includes the new utilities.
75
76 %package -n libnetlink-devel
77 Summary:        Library for the netlink interface
78 Summary(pl):    Biblioteka do interfejsu netlink
79 Group:          Development/Libraries
80
81 %description -n libnetlink-devel
82 This library provides an interface for kernel-user netlink interface.
83
84 %description -n libnetlink-devel -l pl
85 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
86 a przestrzeni± u¿ytkownika.
87
88 %prep
89 %setup -q
90 rm -rf include-glibc
91 %patch0 -p1
92 %patch2 -p1
93 %patch4 -p1
94
95 %patch10 -p1
96 %patch11 -p1
97 %{?with_iec_complaint:%patch13 -p1}
98
99 %build
100 rm -rf include/linux
101
102 %{__make} \
103         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
104         OPT="%{rpmcflags} -DCONFIG_CLS_U32_PERF=1" \
105         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
106
107 %{?with_doc:%{__make} -C doc}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
112
113 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
114 install etc/iproute2/rt_protos \
115         etc/iproute2/rt_realms \
116         etc/iproute2/rt_scopes \
117         etc/iproute2/rt_tables \
118         $RPM_BUILD_ROOT%{_sysconfdir}
119
120 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
121 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
122 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
123
124 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
125 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
133 %attr(755,root,root) %{_sbindir}/*
134 %dir %{_sysconfdir}
135 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
136 %{_mandir}/man8/*
137
138 %files -n libnetlink-devel
139 %defattr(644,root,root,755)
140 %{_libdir}/lib*.a
141 %{_includedir}/*.h
This page took 0.044107 seconds and 4 git commands to generate.