]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- uClibc finished.
[packages/iproute2.git] / iproute2.spec
1 #
2 # Conditional build
3 %bcond_without  doc             # don't build documentation
4 %bcond_without  tc              # don't build tc program (it breaks static linkage)
5 %bcond_with     uClibc          # do some hacks to build with uClibc
6 %bcond_with     iec_complaint   # fix bitrate calculations
7 #
8 Summary:        Utility to control Networking behavior in 2.2.X kernels
9 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
10 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
11 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
12 Name:           iproute2
13 %define         mainver         2.4.7
14 %define         snapshot        ss020116
15 Version:        %{mainver}.%{snapshot}
16 Release:        17
17 License:        GPL
18 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
19 Group:          Networking/Admin
20 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
21 # Source0-md5:  2c7e5f3a10e703745ecdc613f7a7d187
22 Source1:        %{name}-owl-man.tar.bz2
23 # Source1-md5:  cd4425df972a4ab001db31a5eb1c5da5
24 Patch0:         %{name}-llh.patch
25 Patch1:         %{name}-Makefile.patch
26 Patch2:         %{name}-diffserv-config.patch
27 Patch3:         %{name}-netlink.patch
28 Patch4:         %{name}-ipaddress.patch
29 Patch5:         %{name}-iprule.patch
30 # extensions
31 Patch10:        %{name}-htb3.6_tc.patch
32 Patch11:        %{name}-2.2.4-wrr.patch
33 Patch12:        %{name}-2.2.4-esfq.patch
34 Patch13:        %{name}-hfsc.patch
35 Patch14:        %{name}-rates-1024-fix.patch
36 BuildRequires:  bison
37 BuildRequires:  linux-libc-headers >= 7:2.6.5.1-4
38 %if %{with doc}
39 BuildRequires:  psutils
40 BuildRequires:  sgml-tools
41 BuildRequires:  tetex-dvips
42 BuildRequires:  tetex-latex
43 BuildRequires:  tetex-tex-babel
44 %endif
45 Obsoletes:      iproute
46 Conflicts:      ifstat
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _sbindir        /sbin
50 %define         _sysconfdir     /etc/iproute2
51
52 %description
53 Linux 2.2 maintains compatibility with the basic configuration
54 utilities of the network (ifconfig, route) but a new utility is
55 required to exploit the new characteristics and features of the
56 kernel. This package includes the new utilities.
57
58 %description -l es
59 Linux mantiene compatibilidad con los utilitarios estándares de
60 configuración de la red, pero se necesitan nuevos utilitarios para
61 usar los recursos y características del nuevo núcleo. Este paquete
62 incluye los nuevos utilitarios.
63
64 %description -l pl
65 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
66 aspektów dotycz±cych sieci.
67
68 %description -l pt_BR
69 O Linux mantém compatibilidade com os utilitários padrão de
70 configuração da rede, mas novos utilitários são necessários para fazer
71 uso das características e recursos da nova kernel. This package
72 includes the new utilities.
73
74 %package -n libnetlink-devel
75 Summary:        Library for the netlink interface
76 Summary(pl):    Biblioteka do interfejsu netlink
77 Group:          Development/Libraries
78
79 %description -n libnetlink-devel
80 This library provides an interface for kernel-user netlink interface.
81
82 %description -n libnetlink-devel -l pl
83 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
84 a przestrzeni± u¿ytkownika.
85
86 %prep
87 %setup -q -n %{name} -a1
88 rm -rf include-glibc
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92 %patch3 -p1
93 %patch4 -p1
94 %patch5 -p1
95
96 %patch10 -p1
97 %patch11 -p1
98 %patch12 -p1
99 %patch13 -p1
100 %{?with_iec_complaint:%patch14 -p1}
101
102 %build
103 %{__make} \
104         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
105         OPT="%{rpmcflags}" \
106         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
107
108 %{?with_doc:%{__make} -C doc}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
113
114 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
115 install etc/iproute2/rt_protos \
116         etc/iproute2/rt_realms \
117         etc/iproute2/rt_scopes \
118         etc/iproute2/rt_tables \
119         $RPM_BUILD_ROOT%{_sysconfdir}
120 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
121 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
122 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
130 %attr(755,root,root) %{_sbindir}/*
131 %dir %{_sysconfdir}
132 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
133 %{_mandir}/man8/*
134
135 %files -n libnetlink-devel
136 %defattr(644,root,root,755)
137 %{_libdir}/lib*.a
138 %{_includedir}/*.h
This page took 0.033268 seconds and 3 git commands to generate.