]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- BR: db-devel
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #
5 # Conditional build
6 %bcond_without  doc             # don't build documentation
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_with     uClibc          # do some hacks to build with uClibc
9 %bcond_with     iec_complaint   # fix bitrate calculations
10 #
11 Summary:        Utility to control Networking behavior in.X kernels
12 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
13 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
14 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
15 Name:           iproute2
16 %define sdate   040730
17 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
18 Version:        2.6.8
19 Release:        2
20 License:        GPL
21 Vendor:         Stephen Hemminger <shemminger@osdl.org>
22 Group:          Networking/Admin
23 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-2.6.8-ss%{sdate}.tar.gz
24 # Source0-md5:  0d8c23f6c3a42bb680c3bdf9f580987a
25 Patch0:         %{name}-build.patch
26 Patch2:         %{name}-arp.patch
27 Patch4:         %{name}-ipaddress.patch
28 # extensions
29 Patch10:        %{name}-2.2.4-wrr.patch
30 Patch11:        %{name}-2.2.4-esfq.patch
31 Patch13:        %{name}-rates-1024-fix.patch
32 URL:            http://developer.osdl.org/dev/iproute2/
33 BuildRequires:  bison
34 BuildRequires:  db-devel
35 BuildRequires:  linux-libc-headers >= 7:2.6.7.0-9
36 %if %{with doc}
37 BuildRequires:  psutils
38 BuildRequires:  sgml-tools
39 BuildRequires:  tetex-dvips
40 BuildRequires:  tetex-fonts-jknappen
41 BuildRequires:  tetex-format-latex
42 BuildRequires:  tetex-metafont
43 BuildRequires:  tetex-tex-babel
44 %endif
45 Obsoletes:      iproute
46 Obsoletes:      ifstat
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _sbindir        /sbin
50 %define         _sysconfdir     /etc/iproute2
51
52 %description
53 Linux maintains compatibility with the basic configuration
54 utilities of the network (ifconfig, route) but a new utility is
55 required to exploit the new characteristics and features of the
56 kernel. This package includes the new utilities.
57
58 %description -l es
59 Linux mantiene compatibilidad con los utilitarios estándares de
60 configuración de la red, pero se necesitan nuevos utilitarios para
61 usar los recursos y características del nuevo núcleo. Este paquete
62 incluye los nuevos utilitarios.
63
64 %description -l pl
65 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
66 aspektów dotycz±cych sieci.
67
68 %description -l pt_BR
69 O Linux mantém compatibilidade com os utilitários padrão de
70 configuração da rede, mas novos utilitários são necessários para fazer
71 uso das características e recursos da nova kernel. This package
72 includes the new utilities.
73
74 %package -n libnetlink-devel
75 Summary:        Library for the netlink interface
76 Summary(pl):    Biblioteka do interfejsu netlink
77 Group:          Development/Libraries
78
79 %description -n libnetlink-devel
80 This library provides an interface for kernel-user netlink interface.
81
82 %description -n libnetlink-devel -l pl
83 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
84 a przestrzeni± u¿ytkownika.
85
86 %prep
87 %setup -q
88 rm -rf include-glibc
89 %patch0 -p1
90 %patch2 -p1
91 %patch4 -p1
92
93 %patch10 -p1
94 %patch11 -p1
95 %{?with_iec_complaint:%patch13 -p1}
96
97 %build
98 %{__make} \
99         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
100         OPT="%{rpmcflags}" \
101         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
102
103 %{?with_doc:%{__make} -C doc}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
108
109 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
110 install etc/iproute2/rt_protos \
111         etc/iproute2/rt_realms \
112         etc/iproute2/rt_scopes \
113         etc/iproute2/rt_tables \
114         $RPM_BUILD_ROOT%{_sysconfdir}
115
116 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
117 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
118 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
119
120 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
121 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
129 %attr(755,root,root) %{_sbindir}/*
130 %dir %{_sysconfdir}
131 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
132 %{_mandir}/man8/*
133
134 %files -n libnetlink-devel
135 %defattr(644,root,root,755)
136 %{_libdir}/lib*.a
137 %{_includedir}/*.h
This page took 0.045592 seconds and 3 git commands to generate.