]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- we don't need db-devel just for ip; bcond it
[packages/iproute2.git] / iproute2.spec
1 # conditional build
2 # --without tetex       # with tetex-2 there shuld be BR tetex-tex-babel
3 # --without tc (don't build tc program, it break static linkage)
4 # --without dist_kernel
5
6 %define         _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
7 %define mainver         2.4.7
8 %define snapshot        ss020116
9 Summary:        Utility to control Networking behavior in 2.2.X kernels
10 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
11 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
12 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
13 Name:           iproute2
14 Version:        %{mainver}.%{snapshot}
15 %define _rel    10
16 Release:        %{_rel}@%{_kernel_ver_str}
17 License:        GPL
18 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
19 Group:          Networking/Admin
20 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
21 Source1:        %{name}-owl-man.tar.bz2
22 Patch0:         %{name}-make.patch
23 Patch1:         %{name}-uClibc.patch
24 Patch2:         %{name}-fix-2_2.patch
25 Patch3:         %{name}-label.patch
26 Patch4:         %{name}-latest.patch
27 Patch5:         %{name}-htb2_tc.patch
28 Patch6:         wrr-iproute2-2.2.4.patch
29 Patch7:         htb3.6_tc.patch
30 Patch8:         %{name}-no_libresolv.patch
31 %{!?_without_tc:BuildRequires:  db-devel}
32 BuildRequires:  bison
33 %{!?_without_tetex:BuildRequires:       latex2html}
34 %{!?_without_tetex:BuildRequires:       psutils}
35 %{!?_without_tetex:BuildRequires:       sgml-tools}
36 %{!?_without_tetex:BuildRequires:       tetex-dvips}
37 %{!?_without_tetex:BuildRequires:       tetex-latex}
38 Obsoletes:      iproute
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _sbindir        /sbin
42 %define         _sysconfdir     /etc/iproute2
43
44 %description
45 Linux 2.2 maintains compatibility with the basic configuration
46 utilities of the network (ifconfig, route) but a new utility is
47 required to exploit the new characteristics and features of the
48 kernel. This package includes the new utilities.
49
50 %description -l es
51 Linux mantiene compatibilidad con los utilitarios estándares de
52 configuración de la red, pero se necesitan nuevos utilitarios para
53 usar los recursos y características del nuevo núcleo. Este paquete
54 incluye los nuevos utilitarios.
55
56 %description -l pl
57 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
58 aspektów dotycz±cych sieci.
59
60 %description -l pt_BR
61 O Linux mantém compatibilidade com os utilitários padrão de
62 configuração da rede, mas novos utilitários são necessários para fazer
63 uso das características e recursos da nova kernel. This package
64 includes the new utilities.
65
66 %package -n libnetlink-devel
67 Summary:        Library for the netlink interface
68 Summary(pl):    Biblioteka do interfejsu netlink
69 Group:          Development/Libraries
70
71 %description -n libnetlink-devel
72 This library provides an interface for kernel-user netlink interface.
73
74 %description -n libnetlink-devel -l pl
75 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
76 a przestrzeni± u¿ytkownika.
77
78 %prep
79 %setup -q -n %{name} -a1
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83 #%%patch3 -p1
84 #%%patch4 -p1
85 %if %{_kernel24}
86 %patch7 -p1
87 %else
88 %patch5 -p1
89 %endif
90 %patch6 -p1
91 %patch8 -p1
92
93 %build
94 WRRDEF=""
95 grep -q tc_wrr_class_weight /usr/include/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"
96
97 %{__make} \
98         CC="%{__cc}" \
99         OPT="%{rpmcflags} ${WRRDEF}" \
100         KERNEL_INCLUDE="%{_kernelsrcdir}/include" \
101         %{?_without_tc:SUBDIRS="lib ip" LDFLAGS="%{rpmldflags}"}
102 %{!?_without_tetex:%{__make} -C doc}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
107
108 install ip/{ip,rtmon,routel} %{!?_without_tc:tc/tc} $RPM_BUILD_ROOT%{_sbindir}
109 install etc/iproute2/rt_protos \
110         etc/iproute2/rt_realms \
111         etc/iproute2/rt_scopes \
112         etc/iproute2/rt_tables \
113         $RPM_BUILD_ROOT%{_sysconfdir}
114 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
115 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
116 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README README.iproute2+tc RELNOTES
124 %{!?_without_tetex:%doc doc/*.ps}
125 %attr(755,root,root) %{_sbindir}/*
126 %dir %{_sysconfdir}
127 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
128 %{_mandir}/man8/*
129
130 %files -n libnetlink-devel
131 %defattr(644,root,root,755)
132 %{_libdir}/*
133 %{_includedir}/*
This page took 0.035071 seconds and 3 git commands to generate.