]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- you can't disable rpm macros with shell syntax, just turn bcond off
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 # - fix build @ uClibc
4 # - fix iface_descr patch
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # don't required ATM.
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 %bcond_with     iface_descr     # build with interface description support
12
13 Summary:    Advanced IP routing and network device configuration tools
14 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl.UTF-8):      Narzędzie do kontrolowania Sieci w kernelach
16 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
19 Version:        2.6.35
20 Release:        3
21 License:        GPL
22 Group:          Networking/Admin
23 Source0:        http://devresources.linux-foundation.org/dev/iproute2/download/%{name}-%{version}.tar.bz2
24 # Source0-md5:  b0f281b3124bf04669e18f5fe16d4934
25 Source1:        libnetlink.3
26 Patch0:         %{name}-build.patch
27 Patch1:         %{name}-arp.patch
28 Patch3:         %{name}-iptables.patch
29 Patch4:         %{name}-iptables64.patch
30 Patch5:         %{name}-LDFLAGS.patch
31 # extensions
32 Patch10:        %{name}-2.2.4-wrr.patch
33 Patch11:        esfq-%{name}.patch
34 Patch12:        001-net-dev-iface-descr-0.1.diff
35 Patch13:        %{name}-q_atm_c.patch
36 Patch14:        %{name}-q_srr.v0.4.patch
37 Patch15:        %{name}-ip_route_get.patch
38 URL:            http://linux-net.osdl.org/index.php/Iproute2
39 BuildRequires:  bison
40 BuildRequires:  db-devel
41 BuildRequires:  flex
42 BuildRequires:  iptables-devel >= 0:1.4.3
43 %if %{with atm}
44 BuildRequires:  linux-atm-devel
45 %endif
46 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
47 %if %{with doc}
48 BuildRequires:  psutils
49 BuildRequires:  sgml-tools
50 %if "%{pld_release}" != "th"
51 BuildRequires:  tetex-dvips
52 BuildRequires:  tetex-fonts-jknappen
53 BuildRequires:  tetex-format-latex
54 BuildRequires:  tetex-metafont
55 BuildRequires:  tetex-tex-babel
56 %else
57 BuildRequires:  texlive-dvips
58 BuildRequires:  texlive-fonts-cmsuper
59 BuildRequires:  texlive-fonts-jknappen
60 BuildRequires:  texlive-latex
61 BuildRequires:  texlive-tex-babel
62 %endif
63 %endif
64 Obsoletes:      ifstat
65 Obsoletes:      iproute
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sbindir        /sbin
69 %define         _sysconfdir     /etc/iproute2
70
71 %description
72 The iproute package contains networking utilities (ip and rtmon, for
73 example) which are designed to use the advanced networking
74 capabilities of the Linux 2.4.x and 2.6.x kernel.
75
76 %description -l es.UTF-8
77 Linux mantiene compatibilidad con los utilitarios estándares de
78 configuración de la red, pero se necesitan nuevos utilitarios para
79 usar los recursos y características del nuevo núcleo. Este paquete
80 incluye los nuevos utilitarios.
81
82 %description -l pl.UTF-8
83 Ten pakiet zawiera programy pozwalające na kontrolę routingu i innych
84 aspektów dotyczących sieci.
85
86 %description -l pt_BR.UTF-8
87 O Linux mantém compatibilidade com os utilitários padrão de
88 configuração da rede, mas novos utilitários são necessários para fazer
89 uso das características e recursos da nova kernel. This package
90 includes the new utilities.
91
92 %package -n libnetlink-devel
93 Summary:        Library for the netlink interface
94 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
95 Group:          Development/Libraries
96
97 %description -n libnetlink-devel
98 This library provides an interface for kernel-user netlink interface.
99
100 %description -n libnetlink-devel -l pl.UTF-8
101 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
102 a przestrzenią użytkownika.
103
104 %prep
105 %setup -q
106 #rm -rf include/linux
107 %patch0 -p1
108 %patch1 -p1
109
110 %if "%{_lib}" == "lib64"
111 %patch4 -p1
112 %else
113 %patch3 -p1
114 %endif
115 %patch5 -p1
116
117 # extensions:
118 %patch10 -p1
119 %patch11 -p1
120 %{?with_iface_descr:%patch12 -p1}
121 %patch13 -p0
122 %patch14 -p1
123 %patch15 -p1
124
125 %build
126 %{__make} \
127 %if %{with uClibc}
128         CC="%{_target_cpu}-uclibc-gcc" \
129         LD="%{_target_cpu}-uclibc-gcc" \
130 %else
131         CC="%{__cc}" \
132         LD="%{__cc}" \
133 %endif
134         HOSTCC="%{__cc}" \
135         OPT="%{rpmcflags}" \
136         LDFLAGS="%{rpmldflags} -Wl,-export-dynamic" \
137         %{!?with_tc:SUBDIRS="lib ip misc"}
138
139 %{?with_doc:%{__make} -C doc}
140
141 # make sure we don't produce broken ip binary
142 ./ip/ip link add type vlan help 2>&1 | grep -q "VLANID :=" || exit 1
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man{3,8},%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
147
148 install -p ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
149 cp -a etc/iproute2/rt_protos \
150         etc/iproute2/rt_realms \
151         etc/iproute2/rt_scopes \
152         etc/iproute2/rt_tables \
153         $RPM_BUILD_ROOT%{_sysconfdir}
154
155 cp -a man/man8/*        $RPM_BUILD_ROOT%{_mandir}/man8
156 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
157 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
158 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man3
159
160 cp -a lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
161 cp -a include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
162 %{?with_tc:install -p tc/*.so $RPM_BUILD_ROOT%{_libdir}/tc}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %files
168 %defattr(644,root,root,755)
169 %doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
170 %doc ChangeLog %{?with_doc:doc/*.ps}
171 %attr(755,root,root) %{_sbindir}/ifstat
172 %attr(755,root,root) %{_sbindir}/ip
173 %attr(755,root,root) %{_sbindir}/lnstat
174 %attr(755,root,root) %{_sbindir}/nstat
175 %attr(755,root,root) %{_sbindir}/routel
176 %attr(755,root,root) %{_sbindir}/rtacct
177 %attr(755,root,root) %{_sbindir}/rtmon
178 %attr(755,root,root) %{_sbindir}/ss
179 %attr(755,root,root) %{_sbindir}/tc
180 %dir %{_sysconfdir}
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_protos
182 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_realms
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_scopes
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_tables
185 %{_mandir}/man8/*
186 %{?with_tc:%dir %{_libdir}/tc}
187 %{?with_tc:%attr(755,root,root) %{_libdir}/tc/*.so}
188
189 %files -n libnetlink-devel
190 %defattr(644,root,root,755)
191 %{_libdir}/libnetlink.a
192 %{_includedir}/libnetlink.h
193 %{_mandir}/man3/libnetlink.3*
This page took 0.035032 seconds and 3 git commands to generate.