]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- updated to 4.19.0
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 # - fix build @ uClibc
4 # - fix iface_descr patch
5 #
6 # Conditional build
7 %bcond_without  tc              # don't build tc program (it breaks static linkage)
8 %bcond_without  atm             # disable ATM support for tc
9 %bcond_with     uClibc          # do some hacks to build with uClibc
10 %bcond_with     iface_descr     # build with interface description support
11
12 Summary:        Advanced IP routing and network device configuration tools
13 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
14 Summary(pl.UTF-8):      Narzędzie do konfigurowania sieci
15 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
16 Name:           iproute2
17 Version:        4.19.0
18 Release:        1
19 License:        GPL v2+
20 Group:          Networking/Admin
21 Source0:        https://www.kernel.org/pub/linux/utils/net/iproute2/%{name}-%{version}.tar.xz
22 # Source0-md5:  67eeebacaac4515cab73dfd2fc796af3
23 Source1:        %{name}.tmpfiles
24 Patch0:         %{name}-link.patch
25 Patch3:         %{name}-LDFLAGS.patch
26
27 Patch5:         %{name}-build.patch
28 Patch6:         %{name}-print_cache_route_entries.patch
29 # extensions
30 Patch10:        %{name}-2.2.4-wrr.patch
31 Patch11:        esfq-%{name}.patch
32 Patch12:        001-net-dev-iface-descr-0.1.diff
33 Patch13:        %{name}-q_atm_c.patch
34 Patch14:        %{name}-q_srr.v0.4.patch
35 Patch15:        %{name}-ip_route_get.patch
36 URL:            http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
37 BuildRequires:  bison
38 BuildRequires:  db-devel
39 # libelf
40 BuildRequires:  elfutils-devel
41 BuildRequires:  flex
42 BuildRequires:  iptables-devel >= 0:1.4.5
43 BuildRequires:  libmnl-devel
44 BuildRequires:  libselinux-devel
45 %if %{with atm}
46 BuildRequires:  linux-atm-devel
47 %endif
48 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpmbuild(macros) >= 1.673
51 BuildRequires:  tar >= 1:1.22
52 BuildRequires:  xz
53 Requires:       iptables-libs >= 0:1.4.5
54 Obsoletes:      ifstat
55 Obsoletes:      iproute
56 Obsoletes:      iproute2-doc < 4.14.1
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _sbindir        /sbin
60 %define         _sysconfdir     /etc/iproute2
61
62 %description
63 The iproute package contains networking utilities (ip, tc and rtmon,
64 for example) which are designed to use the advanced networking
65 capabilities of the Linux 2.4.x and 2.6.x kernel.
66
67 %description -l es.UTF-8
68 Linux mantiene compatibilidad con los utilitarios estándares de
69 configuración de la red, pero se necesitan nuevos utilitarios para
70 usar los recursos y características del nuevo núcleo. Este paquete
71 incluye los nuevos utilitarios.
72
73 %description -l pl.UTF-8
74 Ten pakiet zawiera programy (m.in. ip, tc, rtmon) pozwalające na
75 kontrolę routingu i innych aspektów dotyczących sieci z wykorzystaniem
76 zaawansowanych możliwości jąder Linuksa 2.4.x i 2.6.x.
77
78 %description -l pt_BR.UTF-8
79 O Linux mantém compatibilidade com os utilitários padrão de
80 configuração da rede, mas novos utilitários são necessários para fazer
81 uso das características e recursos da nova kernel. This package
82 includes the new utilities.
83
84 %package devel
85 Summary:        Header file for tc plugins development
86 Summary(pl.UTF-8):      Plik nagłówkowy do tworzenia wtyczek programu tc
87 Group:          Development/Libraries
88 # doesn't require base
89
90 %description devel
91 Header file for tc plugins development.
92
93 %description devel -l pl.UTF-8
94 Plik nagłówkowy do tworzenia wtyczek programu tc.
95
96 %package -n libnetlink-devel
97 Summary:        Library for the netlink interface
98 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
99 Group:          Development/Libraries
100
101 %description -n libnetlink-devel
102 This library provides an interface for kernel-user netlink interface.
103
104 %description -n libnetlink-devel -l pl.UTF-8
105 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
106 a przestrzenią użytkownika.
107
108 %package -n bash-completion-iproute2
109 Summary:        Bash completion for iproute2 commands
110 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów poleceń iproute2
111 Group:          Applications/Shells
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       bash-completion >= 2.0
114
115 %description -n bash-completion-iproute2
116 Bash completion for iproute2 commands (currently only tc).
117
118 %description -n bash-completion-iproute2 -l pl.UTF-8
119 Bashowe dopełnianie parametrów poleceń iproute2 (obecnie tylko tc).
120
121 %prep
122 %setup -q
123
124 # conflict with atm-vbr patched linux-libc-headers
125 %{__rm} include/uapi/linux/atm.h
126 #%{__rm} -r include/linux
127
128 %patch0 -p1
129 %patch3 -p1
130
131 %patch5 -p1
132 %patch6 -p1
133 # extensions:
134 %patch10 -p1
135 %patch11 -p1
136 %{?with_iface_descr:%patch12 -p1}
137 %patch13 -p0
138 %patch14 -p1
139 %patch15 -p1
140
141 %build
142 %{__make} \
143 %if %{with uClibc}
144         CC="%{_target_cpu}-uclibc-gcc" \
145         LD="%{_target_cpu}-uclibc-gcc" \
146 %else
147         CC="%{__cc}" \
148         LD="%{__cc}" \
149 %endif
150         HOSTCC="%{__cc}" \
151         CCOPTS="%{rpmcflags} %{rpmcppflags} -Wno-unused-result -DXT_LIB_DIR=\\\"%{_libdir}/xtables\\\"" \
152         LDFLAGS="%{rpmldflags} -Wl,-export-dynamic" \
153         LIBDIR=%{_libdir} \
154         %{!?with_tc:SUBDIRS="lib ip misc"} \
155         V=1
156
157 # make sure we don't produce broken ip binary
158 ./ip/ip link add type vlan help 2>&1 | grep -q "VLANID :=" || exit 1
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162 install -d $RPM_BUILD_ROOT{%{_includedir},/var/run/netns,%{systemdtmpfilesdir}}
163
164 %{__make} install \
165         LIBDIR=%{_libdir} \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 # omitted by make install
169 install -Dp man/man7/tc-hfsc.7 $RPM_BUILD_ROOT%{_mandir}/man7/tc-hfsc.7
170
171 # arpd is not packaged here
172 %{__rm} $RPM_BUILD_ROOT%{_sbindir}/arpd $RPM_BUILD_ROOT%{_mandir}/man8/arpd.8
173
174 cp -p lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
175 cp -p include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
176
177 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
178
179 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/iproute2
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %doc README README.decnet README.iproute2+tc README.distribution README.lnstat examples
187 %attr(755,root,root) %{_sbindir}/bridge
188 %attr(755,root,root) %{_sbindir}/ctstat
189 %attr(755,root,root) %{_sbindir}/devlink
190 %attr(755,root,root) %{_sbindir}/genl
191 %attr(755,root,root) %{_sbindir}/ifcfg
192 %attr(755,root,root) %{_sbindir}/ifstat
193 %attr(755,root,root) %{_sbindir}/ip
194 %attr(755,root,root) %{_sbindir}/lnstat
195 %attr(755,root,root) %{_sbindir}/nstat
196 %attr(755,root,root) %{_sbindir}/rdma
197 %attr(755,root,root) %{_sbindir}/routef
198 %attr(755,root,root) %{_sbindir}/routel
199 %attr(755,root,root) %{_sbindir}/rtacct
200 %attr(755,root,root) %{_sbindir}/rtmon
201 %attr(755,root,root) %{_sbindir}/rtpr
202 %attr(755,root,root) %{_sbindir}/rtstat
203 %attr(755,root,root) %{_sbindir}/ss
204 %attr(755,root,root) %{_sbindir}/tipc
205 %dir %{_sysconfdir}
206 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bpf_pinning
207 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ematch_map
208 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/group
209 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nl_protos
210 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_dsfield
211 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_protos
212 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_realms
213 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_scopes
214 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_tables
215 %{_mandir}/man8/bridge.8*
216 %{_mandir}/man8/devlink-resource.8*
217 %{_mandir}/man8/genl.8*
218 %{_mandir}/man8/ifcfg.8*
219 %{_mandir}/man8/ip.8*
220 %{_mandir}/man8/ip-*.8*
221 %{_mandir}/man8/ctstat.8*
222 %{_mandir}/man8/devlink.8*
223 %{_mandir}/man8/devlink-dev.8*
224 %{_mandir}/man8/devlink-monitor.8*
225 %{_mandir}/man8/devlink-port.8*
226 %{_mandir}/man8/devlink-region.8*
227 %{_mandir}/man8/devlink-sb.8*
228 %{_mandir}/man8/ifstat.8*
229 %{_mandir}/man8/lnstat.8*
230 %{_mandir}/man8/nstat.8*
231 %{_mandir}/man8/rdma-dev.8*
232 %{_mandir}/man8/rdma-link.8*
233 %{_mandir}/man8/rdma-resource.8*
234 %{_mandir}/man8/rdma.8*
235 %{_mandir}/man8/routef.8*
236 %{_mandir}/man8/routel.8*
237 %{_mandir}/man8/rtacct.8*
238 %{_mandir}/man8/rtmon.8*
239 %{_mandir}/man8/rtpr.8*
240 %{_mandir}/man8/rtstat.8*
241 %{_mandir}/man8/ss.8*
242 %{_mandir}/man8/tipc.8*
243 %{_mandir}/man8/tipc-*.8*
244 %if %{with tc}
245 %attr(755,root,root) %{_sbindir}/tc
246 %dir %{_libdir}/tc
247 %attr(755,root,root) %{_libdir}/tc/*.so
248 %{_libdir}/tc/*.dist
249 %{_mandir}/man7/tc-hfsc.7*
250 %{_mandir}/man8/tc.8*
251 %{_mandir}/man8/tc-*.8*
252 %endif
253 %{systemdtmpfilesdir}/%{name}.conf
254 %dir %attr(750,root,root) /var/run/netns
255
256 %files devel
257 %defattr(644,root,root,755)
258 %{_includedir}/iproute2
259
260 %files -n libnetlink-devel
261 %defattr(644,root,root,755)
262 %{_libdir}/libnetlink.a
263 %{_includedir}/libnetlink.h
264 %{_mandir}/man3/libnetlink.3*
265
266 %files -n bash-completion-iproute2
267 %defattr(644,root,root,755)
268 %{bash_compdir}/tc
This page took 0.085996 seconds and 3 git commands to generate.