]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- updated to 2.6.10-ss050124 (cleanup/bugfix release).
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - remove -DCONFIG_CLS_U32_PERF=1 when llh will be fixed
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # don't required ATM.
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 %bcond_with     iec_complaint   # fix bitrate calculations
12 #
13 Summary:        Utility to control Networking behavior in.X kernels
14 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach
16 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 %define sdate   050124
19 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
20 Version:        2.6.10
21 Release:        0.1
22 License:        GPL
23 Vendor:         Stephen Hemminger <shemminger@osdl.org>
24 Group:          Networking/Admin
25 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-ss%{sdate}.tar.gz
26 # Source0-md5:  7ae2bab0858766d61d7e92670cc2e622
27 Patch0:         %{name}-build.patch
28 Patch1:         %{name}-arp.patch
29 # extensions
30 Patch10:        %{name}-2.2.4-wrr.patch
31 Patch11:        %{name}-2.2.4-esfq.patch
32 Patch13:        %{name}-rates-1024-fix.patch
33 URL:            http://developer.osdl.org/dev/iproute2/
34 BuildRequires:  bison
35 BuildRequires:  db-devel
36 %if %{with atm}
37 BuildRequires:  linux-atm-devel
38 %endif
39 BuildRequires:  linux-libc-headers >= 7:2.6.10.0-2
40 %if %{with doc}
41 BuildRequires:  psutils
42 BuildRequires:  sgml-tools
43 BuildRequires:  tetex-dvips
44 BuildRequires:  tetex-fonts-jknappen
45 BuildRequires:  tetex-format-latex
46 BuildRequires:  tetex-metafont
47 BuildRequires:  tetex-tex-babel
48 %endif
49 Obsoletes:      iproute
50 Obsoletes:      ifstat
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _sbindir        /sbin
54 %define         _sysconfdir     /etc/iproute2
55
56 %description
57 Linux maintains compatibility with the basic configuration
58 utilities of the network (ifconfig, route) but a new utility is
59 required to exploit the new characteristics and features of the
60 kernel. This package includes the new utilities.
61
62 %description -l es
63 Linux mantiene compatibilidad con los utilitarios estándares de
64 configuración de la red, pero se necesitan nuevos utilitarios para
65 usar los recursos y características del nuevo núcleo. Este paquete
66 incluye los nuevos utilitarios.
67
68 %description -l pl
69 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
70 aspektów dotycz±cych sieci.
71
72 %description -l pt_BR
73 O Linux mantém compatibilidade com os utilitários padrão de
74 configuração da rede, mas novos utilitários são necessários para fazer
75 uso das características e recursos da nova kernel. This package
76 includes the new utilities.
77
78 %package -n libnetlink-devel
79 Summary:        Library for the netlink interface
80 Summary(pl):    Biblioteka do interfejsu netlink
81 Group:          Development/Libraries
82
83 %description -n libnetlink-devel
84 This library provides an interface for kernel-user netlink interface.
85
86 %description -n libnetlink-devel -l pl
87 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
88 a przestrzeni± u¿ytkownika.
89
90 %prep
91 %setup -q -n %{name}-%{sdate}
92 rm -rf include-glibc
93 %patch0 -p1
94 %patch1 -p1
95
96 %patch10 -p1
97 %patch11 -p1
98 %{?with_iec_complaint:%patch13 -p1}
99
100 %build
101 rm -rf include/linux
102
103 %{__make} \
104         %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
105         OPT="%{rpmcflags} -DCONFIG_CLS_U32_PERF=1" \
106         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
107
108 %{?with_doc:%{__make} -C doc}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
113
114 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
115 install etc/iproute2/rt_protos \
116         etc/iproute2/rt_realms \
117         etc/iproute2/rt_scopes \
118         etc/iproute2/rt_tables \
119         $RPM_BUILD_ROOT%{_sysconfdir}
120
121 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
122 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
123 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
124
125 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
126 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
134 %attr(755,root,root) %{_sbindir}/*
135 %dir %{_sysconfdir}
136 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
137 %{_mandir}/man8/*
138
139 %files -n libnetlink-devel
140 %defattr(644,root,root,755)
141 %{_libdir}/lib*.a
142 %{_includedir}/*.h
This page took 0.075843 seconds and 3 git commands to generate.