]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
869effd64c882e4fd7ecd1257707a78ae1c88560
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - fix iface_descr patch
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # don't required ATM.
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 #%bcond_with    iface_descr     # build with interface description support
12 #
13 Summary:        Utility to control Networking behavior in.X kernels
14 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl.UTF-8):      Narzędzie do kontrolowania Sieci w kernelach
16 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
19 Version:        2.6.28
20 Release:        2
21 License:        GPL
22 Group:          Networking/Admin
23 Source0:        http://devresources.linux-foundation.org/dev/iproute2/download/%{name}-%{version}.tar.bz2
24 # Source0-md5:  595f9b17320f69e8d30d2fa80f1bca14
25 Patch0:         %{name}-build.patch
26 Patch1:         %{name}-arp.patch
27 Patch3:         %{name}-iptables.patch
28 Patch4:         %{name}-iptables64.patch
29 Patch5:         %{name}-LDFLAGS.patch
30 # extensions
31 Patch10:        %{name}-2.2.4-wrr.patch
32 Patch11:        esfq-%{name}.patch
33 Patch12:        001-net-dev-iface-descr-0.1.diff
34 Patch13:        %{name}-q_atm_c.patch
35 Patch14:        %{name}-q_srr.v0.4.patch
36 URL:            http://linux-net.osdl.org/index.php/Iproute2
37 BuildRequires:  bison
38 BuildRequires:  db-devel
39 BuildRequires:  flex
40 %if %{with atm}
41 BuildRequires:  linux-atm-devel
42 %endif
43 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
44 %if %{with doc}
45 BuildRequires:  psutils
46 BuildRequires:  sgml-tools
47 BuildRequires:  tetex-dvips
48 BuildRequires:  tetex-fonts-jknappen
49 BuildRequires:  tetex-format-latex
50 BuildRequires:  tetex-metafont
51 BuildRequires:  tetex-tex-babel
52 %endif
53 Obsoletes:      iproute
54 Obsoletes:      ifstat
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _sbindir        /sbin
58 %define         _sysconfdir     /etc/iproute2
59
60 %description
61 Linux maintains compatibility with the basic configuration utilities
62 of the network (ifconfig, route) but a new utility is required to
63 exploit the new characteristics and features of the kernel. This
64 package includes the new utilities.
65
66 %description -l es.UTF-8
67 Linux mantiene compatibilidad con los utilitarios estándares de
68 configuración de la red, pero se necesitan nuevos utilitarios para
69 usar los recursos y características del nuevo núcleo. Este paquete
70 incluye los nuevos utilitarios.
71
72 %description -l pl.UTF-8
73 Ten pakiet zawiera programy pozwalające na kontrolę routingu i innych
74 aspektów dotyczących sieci.
75
76 %description -l pt_BR.UTF-8
77 O Linux mantém compatibilidade com os utilitários padrão de
78 configuração da rede, mas novos utilitários são necessários para fazer
79 uso das características e recursos da nova kernel. This package
80 includes the new utilities.
81
82 %package -n libnetlink-devel
83 Summary:        Library for the netlink interface
84 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
85 Group:          Development/Libraries
86
87 %description -n libnetlink-devel
88 This library provides an interface for kernel-user netlink interface.
89
90 %description -n libnetlink-devel -l pl.UTF-8
91 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
92 a przestrzenią użytkownika.
93
94 %prep
95 %setup -q
96 #rm -rf include/linux
97 %patch0 -p1
98 %patch1 -p1
99
100 %if "%{_lib}" == "lib64"
101 %patch4 -p1
102 %else
103 %patch3 -p1
104 %endif
105 %patch5 -p1
106
107 # extensions:
108 %patch10 -p1
109 %patch11 -p1
110 #%{?with_iface_descr:%patch12 -p1}
111 %patch13 -p0
112 %patch14 -p1
113
114 %build
115 %{__make} \
116 %if %{with uClibc}
117         CC="%{_target_cpu}-uclibc-gcc" \
118         LD="%{_target_cpu}-uclibc-gcc" \
119 %else
120         CC="%{__cc}" \
121         LD="%{__cc}" \
122 %endif
123         HOSTCC="%{__cc}" \
124         OPT="%{rpmcflags}" \
125         LDFLAGS="%{rpmldflags} -Wl,-export-dynamic" \
126         %{!?with_tc:SUBDIRS="lib ip misc"}
127
128 %{?with_doc:%{__make} -C doc}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
133
134 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
135 install etc/iproute2/rt_protos \
136         etc/iproute2/rt_realms \
137         etc/iproute2/rt_scopes \
138         etc/iproute2/rt_tables \
139         $RPM_BUILD_ROOT%{_sysconfdir}
140
141 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
142 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
143 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
144
145 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
146 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
147 %{?with_tc:install tc/*.so $RPM_BUILD_ROOT%{_libdir}/tc}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %defattr(644,root,root,755)
154 %doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
155 %doc ChangeLog %{?with_doc:doc/*.ps}
156 %attr(755,root,root) %{_sbindir}/*
157 %dir %{_sysconfdir}
158 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
159 %{_mandir}/man8/*
160 %{?with_tc:%dir %{_libdir}/tc}
161 %{?with_tc:%attr(755,root,root) %{_libdir}/tc/*.so}
162
163 %files -n libnetlink-devel
164 %defattr(644,root,root,755)
165 %{_libdir}/lib*.a
166 %{_includedir}/*.h
This page took 0.03955 seconds and 3 git commands to generate.