]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- added temporary workaround for kernel 2.6.0 - FOR TESTING cvs up iproute2.spec!
[packages/iproute2.git] / iproute2.spec
1 #
2 # Conditional build
3 # _without_tetex        - don't build documentation
4 # _without_tc           - don't build tc program (it breaks static linkage)
5 # _without_tc_esfq      - build tc without esfq support (requires patched headers)
6 #
7 %define         _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
8 %define mainver         2.4.7
9 %define snapshot        ss020116
10 Summary:        Utility to control Networking behavior in 2.2.X kernels
11 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
12 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
13 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
14 Name:           iproute2
15 Version:        %{mainver}.%{snapshot}
16 %define _rel    11
17 Release:        %{_rel}@%{_kernel_ver_str}
18 License:        GPL
19 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
20 Group:          Networking/Admin
21 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
22 # Source0-md5:  2c7e5f3a10e703745ecdc613f7a7d187
23 Source1:        %{name}-owl-man.tar.bz2
24 # Source1-md5:  cd4425df972a4ab001db31a5eb1c5da5
25 Patch0:         %{name}-make.patch
26 Patch1:         %{name}-uClibc.patch
27 Patch2:         %{name}-fix-2_2.patch
28 Patch3:         %{name}-label.patch
29 Patch4:         %{name}-latest.patch
30 Patch5:         %{name}-htb2_tc.patch
31 Patch6:         wrr-iproute2-2.2.4.patch
32 Patch7:         htb3.6_tc.patch
33 Patch8:         %{name}-no_libresolv.patch
34 Patch9:         %{name}-2.2.4-now-ss001007-esfq.diff
35 Patch10:        %{name}-stats.patch
36 Patch11:        %{name}-disable_arpd.patch
37 Patch100:       %{name}-2.6.0-t7-test.patch
38
39 BuildRequires:  bison
40 %{!?_without_tetex:BuildRequires:       latex2html}
41 %{!?_without_tetex:BuildRequires:       psutils}
42 %{!?_without_tetex:BuildRequires:       sgml-tools}
43 %{!?_without_tetex:BuildRequires:       tetex-dvips}
44 %{!?_without_tetex:BuildRequires:       tetex-latex}
45 %{!?_without_tetex:BuildRequires:       tetex-tex-babel}
46 Obsoletes:      iproute
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _sbindir        /sbin
50 %define         _sysconfdir     /etc/iproute2
51
52 %description
53 Linux 2.2 maintains compatibility with the basic configuration
54 utilities of the network (ifconfig, route) but a new utility is
55 required to exploit the new characteristics and features of the
56 kernel. This package includes the new utilities.
57
58 %description -l es
59 Linux mantiene compatibilidad con los utilitarios estándares de
60 configuración de la red, pero se necesitan nuevos utilitarios para
61 usar los recursos y características del nuevo núcleo. Este paquete
62 incluye los nuevos utilitarios.
63
64 %description -l pl
65 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
66 aspektów dotycz±cych sieci.
67
68 %description -l pt_BR
69 O Linux mantém compatibilidade com os utilitários padrão de
70 configuração da rede, mas novos utilitários são necessários para fazer
71 uso das características e recursos da nova kernel. This package
72 includes the new utilities.
73
74 %package -n libnetlink-devel
75 Summary:        Library for the netlink interface
76 Summary(pl):    Biblioteka do interfejsu netlink
77 Group:          Development/Libraries
78
79 %description -n libnetlink-devel
80 This library provides an interface for kernel-user netlink interface.
81
82 %description -n libnetlink-devel -l pl
83 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
84 a przestrzeni± u¿ytkownika.
85
86 %prep
87 %setup -q -n %{name} -a1
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 #%%patch3 -p1
92 #%%patch4 -p1
93 %if %{_kernel24}
94 %patch7 -p1
95 %patch10 -p1
96 %else
97 %patch5 -p1
98 %endif
99 %patch6 -p1
100 %patch8 -p1
101 %{!?_without_tc_esfq:%patch9 -p1}
102 %patch11 -p1
103
104 %patch100 -p1
105
106 %build
107 WRRDEF=""
108 grep -q tc_wrr_class_weight %{_kernelsrcdir}/include/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"
109
110 %{__make} \
111         CC="%{__cc}" \
112         OPT="%{rpmcflags} ${WRRDEF}" \
113         KERNEL_INCLUDE="%{_kernelsrcdir}/include" \
114         LDFLAGS="%{rpmldflags}" \
115         %{?_without_tc:SUBDIRS="lib ip misc"}
116 %{!?_without_tetex:%{__make} -C doc}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
121
122 install ip/{ip,rtmon,routel} %{!?_without_tc:tc/tc} misc/{rtacct,rtstat} $RPM_BUILD_ROOT%{_sbindir}
123 install etc/iproute2/rt_protos \
124         etc/iproute2/rt_realms \
125         etc/iproute2/rt_scopes \
126         etc/iproute2/rt_tables \
127         $RPM_BUILD_ROOT%{_sysconfdir}
128 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
129 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
130 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc README README.iproute2+tc RELNOTES %{!?_without_tetex:doc/*.ps}
138 %attr(755,root,root) %{_sbindir}/*
139 %dir %{_sysconfdir}
140 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
141 %{_mandir}/man8/*
142
143 %files -n libnetlink-devel
144 %defattr(644,root,root,755)
145 %{_libdir}/lib*.a
146 %{_includedir}/*.h
This page took 0.115843 seconds and 3 git commands to generate.