]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- up to 3.1.0
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 # - fix build @ uClibc
4 # - fix iface_descr patch
5 #
6 # Conditional build
7 %bcond_without  doc             # don't build documentation
8 %bcond_without  tc              # don't build tc program (it breaks static linkage)
9 %bcond_without  atm             # disable ATM support for tc
10 %bcond_with     uClibc          # do some hacks to build with uClibc
11 %bcond_with     iface_descr     # build with interface description support
12
13 Summary:        Advanced IP routing and network device configuration tools
14 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
15 Summary(pl.UTF-8):      Narzędzie do konfigurowania sieci
16 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
17 Name:           iproute2
18 Version:        3.1.0
19 Release:        1
20 License:        GPL v2+
21 Group:          Networking/Admin
22 Source0:        http://kernel.org/pub/linux/utils/networking/iproute2/%{name}-%{version}.tar.xz
23 # Source0-md5:  810cdc0ddc2409a7af7089588c6c9a68
24 Source1:        libnetlink.3
25 Patch0:         %{name}-build.patch
26 Patch1:         %{name}-arp.patch
27 Patch3:         %{name}-iptables.patch
28 Patch4:         %{name}-iptables64.patch
29 Patch5:         %{name}-LDFLAGS.patch
30 # extensions
31 Patch10:        %{name}-2.2.4-wrr.patch
32 Patch11:        esfq-%{name}.patch
33 Patch12:        001-net-dev-iface-descr-0.1.diff
34 Patch13:        %{name}-q_atm_c.patch
35 Patch14:        %{name}-q_srr.v0.4.patch
36 Patch15:        %{name}-ip_route_get.patch
37 URL:            http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
38 BuildRequires:  bison
39 BuildRequires:  db-devel
40 BuildRequires:  flex
41 BuildRequires:  iptables-devel >= 0:1.4.3
42 %if %{with atm}
43 BuildRequires:  linux-atm-devel
44 %endif
45 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
46 %if %{with doc}
47 BuildRequires:  psutils
48 BuildRequires:  sgml-tools
49 %if "%{pld_release}" != "th"
50 BuildRequires:  tetex-dvips
51 BuildRequires:  tetex-fonts-jknappen
52 BuildRequires:  tetex-format-latex
53 BuildRequires:  tetex-metafont
54 BuildRequires:  tetex-tex-babel
55 %else
56 BuildRequires:  texlive-dvips
57 BuildRequires:  texlive-fonts-cmsuper
58 BuildRequires:  texlive-fonts-jknappen
59 BuildRequires:  texlive-latex
60 BuildRequires:  texlive-tex-babel
61 %endif
62 %endif
63 Obsoletes:      ifstat
64 Obsoletes:      iproute
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _sbindir        /sbin
68 %define         _sysconfdir     /etc/iproute2
69
70 %description
71 The iproute package contains networking utilities (ip, tc and rtmon,
72 for example) which are designed to use the advanced networking
73 capabilities of the Linux 2.4.x and 2.6.x kernel.
74
75 %description -l es.UTF-8
76 Linux mantiene compatibilidad con los utilitarios estándares de
77 configuración de la red, pero se necesitan nuevos utilitarios para
78 usar los recursos y características del nuevo núcleo. Este paquete
79 incluye los nuevos utilitarios.
80
81 %description -l pl.UTF-8
82 Ten pakiet zawiera programy (m.in. ip, tc, rtmon) pozwalające na
83 kontrolę routingu i innych aspektów dotyczących sieci z wykorzystaniem
84 zaawansowanych możliwości jąder Linuksa 2.4.x i 2.6.x.
85
86 %description -l pt_BR.UTF-8
87 O Linux mantém compatibilidade com os utilitários padrão de
88 configuração da rede, mas novos utilitários são necessários para fazer
89 uso das características e recursos da nova kernel. This package
90 includes the new utilities.
91
92 %package -n libnetlink-devel
93 Summary:        Library for the netlink interface
94 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
95 Group:          Development/Libraries
96
97 %description -n libnetlink-devel
98 This library provides an interface for kernel-user netlink interface.
99
100 %description -n libnetlink-devel -l pl.UTF-8
101 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
102 a przestrzenią użytkownika.
103
104 %package doc
105 Summary:        ip and tc documentation with examples
106 Summary(pl.UTF-8):      Dokumentacja do ip i tc z przykładami
107 License:        GPL v2+
108 Group:          Applications/System
109
110 %description doc
111 The iproute documentation contains howtos and examples of settings.
112
113 %description doc -l pl.UTF-8
114 Dokumentacja do iproute zawiera "howto" oraz przykłady ustawień.
115
116 %prep
117 %setup -q
118 #rm -rf include/linux
119 %patch0 -p1
120 %patch1 -p1
121
122 %if "%{_lib}" == "lib64"
123 %patch4 -p1
124 %else
125 %patch3 -p1
126 %endif
127 %patch5 -p1
128
129 # extensions:
130 %patch10 -p1
131 %patch11 -p1
132 %{?with_iface_descr:%patch12 -p1}
133 %patch13 -p0
134 %patch14 -p1
135 %patch15 -p1
136
137 %build
138 %{__make} \
139 %if %{with uClibc}
140         CC="%{_target_cpu}-uclibc-gcc" \
141         LD="%{_target_cpu}-uclibc-gcc" \
142 %else
143         CC="%{__cc}" \
144         LD="%{__cc}" \
145 %endif
146         HOSTCC="%{__cc}" \
147         OPT="%{rpmcflags} %{rpmcppflags}" \
148         LDFLAGS="%{rpmldflags} -Wl,-export-dynamic" \
149         LIBDIR=%{_libdir} \
150         %{!?with_tc:SUBDIRS="lib ip misc"}
151
152 %{?with_doc:%{__make} -C doc}
153
154 # make sure we don't produce broken ip binary
155 ./ip/ip link add type vlan help 2>&1 | grep -q "VLANID :=" || exit 1
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man{3,8},%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
160
161 install -p ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
162 cp -a etc/iproute2/rt_protos \
163         etc/iproute2/rt_realms \
164         etc/iproute2/rt_scopes \
165         etc/iproute2/rt_tables \
166         $RPM_BUILD_ROOT%{_sysconfdir}
167
168 cp -a man/man8/*        $RPM_BUILD_ROOT%{_mandir}/man8
169 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
170 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
171 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man3
172
173 cp -a lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
174 cp -a include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
175 %{?with_tc:install -p tc/*.so $RPM_BUILD_ROOT%{_libdir}/tc}
176
177 %if %{with doc}
178 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
179 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
180 %endif
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %files
186 %defattr(644,root,root,755)
187 %doc README README.decnet README.iproute2+tc README.distribution README.lnstat
188 %attr(755,root,root) %{_sbindir}/ifstat
189 %attr(755,root,root) %{_sbindir}/ip
190 %attr(755,root,root) %{_sbindir}/lnstat
191 %attr(755,root,root) %{_sbindir}/nstat
192 %attr(755,root,root) %{_sbindir}/routel
193 %attr(755,root,root) %{_sbindir}/rtacct
194 %attr(755,root,root) %{_sbindir}/rtmon
195 %attr(755,root,root) %{_sbindir}/ss
196 %dir %{_sysconfdir}
197 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_protos
198 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_realms
199 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_scopes
200 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rt_tables
201 %{_mandir}/man8/arpd.8*
202 %{_mandir}/man8/ip.8*
203 %{_mandir}/man8/lnstat.8*
204 %{_mandir}/man8/routel.8*
205 %{_mandir}/man8/rtacct.8*
206 %{_mandir}/man8/rtmon.8*
207 %{_mandir}/man8/ss.8*
208 %if %{with tc}
209 %attr(755,root,root) %{_sbindir}/tc
210 %dir %{_libdir}/tc
211 %attr(755,root,root) %{_libdir}/tc/*.so
212 %{_mandir}/man8/tc.8*
213 %{_mandir}/man8/tc-*.8*
214 %endif
215
216 %files -n libnetlink-devel
217 %defattr(644,root,root,755)
218 %{_libdir}/libnetlink.a
219 %{_includedir}/libnetlink.h
220 %{_mandir}/man3/libnetlink.3*
221
222 %if %{with doc}
223 %files doc
224 %defattr(644,root,root,755)
225 %doc RELNOTES doc/*.ps
226 %{_examplesdir}/%{name}-%{version}
227 %endif
This page took 0.099434 seconds and 3 git commands to generate.