]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- up to kernel 2.6.20
[packages/iproute2.git] / iproute2.spec
1 #
2 # TODO:
3 #       - fix build @ uClibc
4 #       - add newer wrr patch - none now available for 2.6.20
5 #       - fix iface_descr patch
6 #
7 # Conditional build
8 %bcond_without  doc             # don't build documentation
9 %bcond_without  tc              # don't build tc program (it breaks static linkage)
10 %bcond_without  atm             # don't required ATM.
11 %bcond_with     uClibc          # do some hacks to build with uClibc
12 #%bcond_with    iface_descr     # build with interface description support
13 #
14 Summary:        Utility to control Networking behavior in.X kernels
15 Summary(es.UTF-8):      Herramientas para encaminamiento avanzado y configuración de interfaces de red
16 Summary(pl.UTF-8):      Narzędzie do kontrolowania Sieci w kernelach
17 Summary(pt_BR.UTF-8):   Ferramentas para roteamento avançado e configuração de interfaces de rede
18 Name:           iproute2
19 %define sdate   070313
20 # do not use ,,2.6.X'' as version here, put whole number like 2.6.8
21 Version:        2.6.20
22 Release:        1       
23 License:        GPL
24 Vendor:         Stephen Hemminger <shemminger@osdl.org>
25 Group:          Networking/Admin
26 Source0:        http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
27 # Source0-md5:  7bc5883aadf740761fa2dd70b661e8cc
28 #Patch0:                %{name}-build.patch
29 Patch1:         %{name}-arp.patch
30 Patch2:         %{name}-lex.patch
31 Patch3:         %{name}-iptables.patch
32 Patch4:         %{name}-iptables64.patch
33 Patch5:         %{name}-LDFLAGS.patch
34 # extensions
35 Patch10:        %{name}-2.2.4-wrr.patch
36 Patch11:        esfq-%{name}.patch
37 Patch12:        001-net-dev-iface-descr-0.1.diff
38 URL:            http://linux-net.osdl.org/index.php/Iproute2
39 BuildRequires:  bison
40 BuildRequires:  db-devel
41 BuildRequires:  flex
42 %if %{with atm}
43 BuildRequires:  linux-atm-devel
44 %endif
45 BuildRequires:  linux-libc-headers >= 7:2.6.12.0-15
46 %if %{with doc}
47 BuildRequires:  psutils
48 BuildRequires:  sgml-tools
49 BuildRequires:  tetex-dvips
50 BuildRequires:  tetex-fonts-jknappen
51 BuildRequires:  tetex-format-latex
52 BuildRequires:  tetex-metafont
53 BuildRequires:  tetex-tex-babel
54 %endif
55 Obsoletes:      iproute
56 Obsoletes:      ifstat
57 BuildRoot:      %{tmpdir}/iproute-%{version}-root-%(id -u -n)
58
59 %define         _sbindir        /sbin
60 %define         _sysconfdir     /etc/iproute2
61
62 %description
63 Linux maintains compatibility with the basic configuration utilities
64 of the network (ifconfig, route) but a new utility is required to
65 exploit the new characteristics and features of the kernel. This
66 package includes the new utilities.
67
68 %description -l es.UTF-8
69 Linux mantiene compatibilidad con los utilitarios estándares de
70 configuración de la red, pero se necesitan nuevos utilitarios para
71 usar los recursos y características del nuevo núcleo. Este paquete
72 incluye los nuevos utilitarios.
73
74 %description -l pl.UTF-8
75 Ten pakiet zawiera programy pozwalające na kontrolę routingu i innych
76 aspektów dotyczących sieci.
77
78 %description -l pt_BR.UTF-8
79 O Linux mantém compatibilidade com os utilitários padrão de
80 configuração da rede, mas novos utilitários são necessários para fazer
81 uso das características e recursos da nova kernel. This package
82 includes the new utilities.
83
84 %package -n libnetlink-devel
85 Summary:        Library for the netlink interface
86 Summary(pl.UTF-8):      Biblioteka do interfejsu netlink
87 Group:          Development/Libraries
88
89 %description -n libnetlink-devel
90 This library provides an interface for kernel-user netlink interface.
91
92 %description -n libnetlink-devel -l pl.UTF-8
93 Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
94 a przestrzenią użytkownika.
95
96 %prep
97 %setup -q -n iproute-%{version}-%{sdate}
98 #rm -rf include-glibc include/linux
99 #%patch0 -p1
100 %patch1 -p1
101 #%patch2 -p1
102 %if "%{_lib}" == "lib64"
103 %patch4 -p1
104 %else
105 %patch3 -p1
106 %endif
107 %patch5 -p1
108
109 # extensions:
110 #%patch10 -p1
111 %patch11 -p1
112 #%{?with_iface_descr:%patch12 -p1}
113
114 %build
115 %{__make} \
116 %if %{with uClibc}
117         CC="%{_target_cpu}-uclibc-gcc" \
118         LD="%{_target_cpu}-uclibc-gcc" \
119 %else
120         CC="%{__cc}" \
121         LD="%{__cc}" \
122 %endif
123         HOSTCC="%{__cc}" \
124         OPT="%{rpmcflags}" \
125         LDFLAGS="%{rpmldflags}" \
126         %{!?with_tc:SUBDIRS="lib ip misc"}
127
128 %{?with_doc:%{__make} -C doc}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
133
134 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
135 install etc/iproute2/rt_protos \
136         etc/iproute2/rt_realms \
137         etc/iproute2/rt_scopes \
138         etc/iproute2/rt_tables \
139         $RPM_BUILD_ROOT%{_sysconfdir}
140
141 install man/man8/*      $RPM_BUILD_ROOT%{_mandir}/man8
142 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
143 echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
144
145 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
146 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
147 %{?with_tc:install tc/*.so $RPM_BUILD_ROOT%{_libdir}/tc}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %defattr(644,root,root,755)
154 %doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
155 %doc ChangeLog %{?with_doc:doc/*.ps}
156 %attr(755,root,root) %{_sbindir}/*
157 %dir %{_sysconfdir}
158 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
159 %{_mandir}/man8/*
160 %{?with_tc:%dir %{_libdir}/tc}
161 %{?with_tc:%attr(755,root,root) %{_libdir}/tc/*.so}
162
163 %files -n libnetlink-devel
164 %defattr(644,root,root,755)
165 %{_libdir}/lib*.a
166 %{_includedir}/*.h
This page took 0.038219 seconds and 3 git commands to generate.