]> git.pld-linux.org Git - packages/iproute2.git/blob - iproute2.spec
- cosmetics.
[packages/iproute2.git] / iproute2.spec
1 #
2 # Conditional build
3 %bcond_without  doc     # don't build documentation
4 %bcond_without  tc      # don't build tc program (it breaks static linkage)
5 %bcond_without  tc_esfq # build tc without esfq support (requires patched headers)
6 %bcond_without  tc_wrr  # build tc without wrr support
7 %bcond_with     uClibc  # do some hacks to build with uClibc
8 #
9 Summary:        Utility to control Networking behavior in 2.2.X kernels
10 Summary(es):    Herramientas para encaminamiento avanzado y configuración de interfaces de red
11 Summary(pl):    Narzêdzie do kontrolowania Sieci w kernelach 2.2
12 Summary(pt_BR): Ferramentas para roteamento avançado e configuração de interfaces de rede
13 Name:           iproute2
14 %define mainver 2.4.7
15 %define snapshot ss020116
16 Version:        %{mainver}.%{snapshot}
17 Release:        16
18 License:        GPL
19 Vendor:         Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
20 Group:          Networking/Admin
21 Source0:        ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
22 # Source0-md5:  2c7e5f3a10e703745ecdc613f7a7d187
23 Source1:        %{name}-owl-man.tar.bz2
24 # Source1-md5:  cd4425df972a4ab001db31a5eb1c5da5
25 Patch0:         %{name}-make.patch
26 Patch1:         %{name}-no_libresolv.patch
27 Patch2:         %{name}-disable_arpd.patch
28 Patch3:         %{name}-uspace.patch
29 Patch4:         %{name}-diffserv-config.patch
30 Patch5:         %{name}-netlink.patch
31 Patch6:         %{name}-kernellast.patch
32 # uClibc hacks
33 Patch7:         %{name}-uClibc.patch
34 Patch8:         htb3.6_tc.patch
35 Patch9:         %{name}-stats.patch
36 # extensions
37 Patch10:        wrr-iproute2-2.2.4.patch
38 Patch11:        %{name}-2.2.4-now-ss001007-esfq.diff
39 Patch12:        %{name}-kernel_headers.patch
40 Patch13:        %{name}-ipaddress.patch
41 Patch14:        %{name}-a-flush-hack.patch
42 BuildRequires:  bison
43 %if %{with doc}
44 BuildRequires:  psutils
45 BuildRequires:  sgml-tools
46 BuildRequires:  tetex-dvips
47 BuildRequires:  tetex-latex
48 BuildRequires:  tetex-tex-babel
49 %endif
50 Obsoletes:      iproute
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _sbindir        /sbin
54 %define         _sysconfdir     /etc/iproute2
55
56 %description
57 Linux 2.2 maintains compatibility with the basic configuration
58 utilities of the network (ifconfig, route) but a new utility is
59 required to exploit the new characteristics and features of the
60 kernel. This package includes the new utilities.
61
62 %description -l es
63 Linux mantiene compatibilidad con los utilitarios estándares de
64 configuración de la red, pero se necesitan nuevos utilitarios para
65 usar los recursos y características del nuevo núcleo. Este paquete
66 incluye los nuevos utilitarios.
67
68 %description -l pl
69 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
70 aspektów dotycz±cych sieci.
71
72 %description -l pt_BR
73 O Linux mantém compatibilidade com os utilitários padrão de
74 configuração da rede, mas novos utilitários são necessários para fazer
75 uso das características e recursos da nova kernel. This package
76 includes the new utilities.
77
78 %package -n libnetlink-devel
79 Summary:        Library for the netlink interface
80 Summary(pl):    Biblioteka do interfejsu netlink
81 Group:          Development/Libraries
82
83 %description -n libnetlink-devel
84 This library provides an interface for kernel-user netlink interface.
85
86 %description -n libnetlink-devel -l pl
87 Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
88 a przestrzeni± u¿ytkownika.
89
90 %prep
91 %setup -q -n %{name} -a1
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96 %patch4 -p1
97 %patch5 -p1
98 %patch6 -p1
99 %{?with_uClibc:%patch7 -p1}
100 %patch8 -p1
101 %patch9 -p1
102 %{?with_tc_wrr:%patch10 -p1}
103 %{?with_tc_esfq:%patch11 -p1}
104 %patch12 -p1
105 %patch13 -p1
106 %patch14 -p1
107
108 %build
109 WRRDEF=""
110 %{?with_tc_wrr:grep -q tc_wrr_class_weight kernel-headers/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"}
111
112 %{__make} \
113         CC="%{__cc}" \
114         OPT="%{rpmcflags} ${WRRDEF}" \
115         KERNEL_INCLUDE="`pwd`/kernel-headers" \
116         %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
117
118 %{?with_doc:%{__make} -C doc}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
123
124 install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat} $RPM_BUILD_ROOT%{_sbindir}
125 install etc/iproute2/rt_protos \
126         etc/iproute2/rt_realms \
127         etc/iproute2/rt_scopes \
128         etc/iproute2/rt_tables \
129         $RPM_BUILD_ROOT%{_sysconfdir}
130 install man/*   $RPM_BUILD_ROOT%{_mandir}/man8
131 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
132 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
140 %attr(755,root,root) %{_sbindir}/*
141 %dir %{_sysconfdir}
142 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
143 %{_mandir}/man8/*
144
145 %files -n libnetlink-devel
146 %defattr(644,root,root,755)
147 %{_libdir}/lib*.a
148 %{_includedir}/*.h
This page took 0.050333 seconds and 3 git commands to generate.