]> git.pld-linux.org Git - packages/icewm.git/blob - icewm.spec
- ugly hack to rpm upgrade reverse switch lackness,
[packages/icewm.git] / icewm.spec
1 #
2 # TODO:
3 # - make a PLD-theme - default :]
4 # - bigger menu-file
5 #
6 Summary:        IceWM X11 Window Manager
7 Summary(pl):    IceWM - mened¿er okienek X11
8 Name:           icewm
9 Version:        1.0.9
10 Release:        7
11 License:        LGPL
12 Group:          X11/Window Managers
13 Source0:        ftp://download.sourceforge.net/pub/sourceforge/icewm/%{name}-%{version}-2.tar.bz2
14 Source1:        IceWM.desktop
15 Source2:        %{name}.directory
16 Source3:        ftp://download.sourceforge.net/pub/sourceforge/icewm/iceicons-0.6.tar.gz
17 Source4:        IceWM.RunWM
18 Source5:        IceWM.wm_style
19 Source6:        %{name}-menu
20 Patch0:         %{name}-DESTDIR.patch
21 URL:            http://www.icewm.org/
22 BuildRequires:  XFree86-devel
23 BuildRequires:  gnome-libs-devel
24 BuildRequires:  imlib-devel
25 BuildRequires:  libstdc++-devel
26 Requires(pre):  fileutils
27 Requires(pre):  sh-utils
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _prefix         /usr/X11R6
31 %define         _sysconfdir     /etc/X11/icewm
32 %define         _wmstyledir     /etc/sysconfig/wmstyle
33 %define         _wmpropsdir     %{_datadir}/wm-properties
34
35 %description
36 Window Manager for X Window System. Can emulate the look of
37 Windows'95, OS/2 Warp 3,4, Motif. Tries to take the best features of
38 the above systems. Features multiple workspaces, opaque move/resize,
39 task bar, window list, mailbox status, digital clock. Fast and small.
40
41 %description -l pl
42 Mened¿er okienek pod X11. Mo¿e emulowaæ wygl±d Windows'95, OS/2 Warp
43 3,4, MWM. Mened¿er ten próbuje wybraæ najlepsze cechy dostêpne w
44 powy¿szych ¶rodowiskach, jak: wiele jednocze¶nie obecnych przestrzeni
45 roboczych, paski narzêdziowe, status skrzynki z poczt±, cyfrowy zegar.
46 Jest przy tym ma³y i szybki.
47
48 %package themes-base
49 Summary:        Pack of themes for IceWM
50 Summary(pl):    Zestaw tematów dla IceWM
51 Group:          Themes
52 Requires:       icewm
53
54 %description themes-base
55 Standard pack of themes delivered with IceWM. All of them made by
56 Marko Macek: gtk2, metal2, motif, nice, warp3, warp4, win95.
57
58 %description themes-base -l pl
59 Standardowy zestaw tematów dla IceWMa, dostarczany wraz z nim.
60 Wszystkie stworzone przez Marko Macek: gtk2, metal2, motif, nice,
61 warp3, warp4, win95.
62
63 %prep -q
64 %setup -q
65 %patch0 -p1
66
67 cd lib/icons
68 tar -zxf %{SOURCE3}
69 cd ../..
70
71 %build
72 export LDFLAGS
73 %configure \
74         --prefix=%{_prefix} \
75         --with-cfgdir=%{_sysconfdir} \
76         --with-docdir=%{_docdir} \
77         --enable-i18n \
78         --enable-guievents \
79         --enable-xfreetype \
80         --with-gnome-menus \
81         --with-imlib
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_wmstyledir},%{_pixmapsdir}/icewm} \
87         $RPM_BUILD_ROOT{%{_applnkdir}/Settings/IceWM,%{_wmpropsdir}}
88
89 %{__make} install DESTDIR=$RPM_BUILD_ROOT
90
91 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
92 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Settings/IceWM/.directory
93 install %{SOURCE4} $RPM_BUILD_ROOT%{_wmstyledir}/IceWM.sh
94 install %{SOURCE5} $RPM_BUILD_ROOT%{_wmstyledir}/IceWM.names
95 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/menu
96 install lib/keys $RPM_BUILD_ROOT%{_sysconfdir}/keys
97 install lib/preferences $RPM_BUILD_ROOT%{_sysconfdir}/preferences
98 install lib/toolbar $RPM_BUILD_ROOT%{_sysconfdir}/toolbar
99 install lib/winoptions $RPM_BUILD_ROOT%{_sysconfdir}/winoptions
100
101 mv -f $RPM_BUILD_ROOT%{_libdir}/X11/icewm/icons/* $RPM_BUILD_ROOT%{_pixmapsdir}/icewm
102 rm -rf $RPM_BUILD_ROOT%{_libdir}/X11/icewm/icons
103 ln -s %{_pixmapsdir}/icewm $RPM_BUILD_ROOT%{_libdir}/X11/icewm/icons
104
105 gzip -9nf BUGS CHANGES FAQ PLATFORMS README* TODO icewm.lsm
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %pre
113 test -h %{_libdir}/X11/icewm/icons || rm -rf %{_libdir}/X11/icewm/icons
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc *.gz doc/*.*ml
118 %attr(755,root,root) %{_bindir}/*
119 %dir %{_sysconfdir}
120 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
121 %dir %{_applnkdir}/Settings/IceWM
122 %{_applnkdir}/Settings/IceWM/.directory
123 %{_wmpropsdir}/*
124 %{_pixmapsdir}/icewm
125 %dir %{_libdir}/X11/icewm
126 %{_libdir}/X11/icewm/icons
127 %{_libdir}/X11/icewm/ledclock
128 %{_libdir}/X11/icewm/mailbox
129 %{_libdir}/X11/icewm/taskbar
130 %dir %{_libdir}/X11/icewm/themes
131 %{_libdir}/X11/icewm/themes/Infadel2
132 %attr(755,root,root) %{_wmstyledir}/IceWM.sh
133 %attr(644,root,root) %{_wmstyledir}/IceWM.names
134
135 %files themes-base
136 %defattr(644,root,root,755)
137 %{_libdir}/X11/icewm/themes/gtk2
138 %{_libdir}/X11/icewm/themes/metal2
139 %{_libdir}/X11/icewm/themes/motif
140 %{_libdir}/X11/icewm/themes/nice
141 %{_libdir}/X11/icewm/themes/warp3
142 %{_libdir}/X11/icewm/themes/warp4
143 %{_libdir}/X11/icewm/themes/win95
This page took 0.204852 seconds and 4 git commands to generate.