]> git.pld-linux.org Git - packages/icedtea8.git/blob - icedtea6.spec
79666080d0c4857184dcc34ab5eb0d702f35b3ed
[packages/icedtea8.git] / icedtea6.spec
1 # TODO:
2 # - install .ttf fonts (same as in sun-java-base-jre-X11 package) or configure
3 #   it to use system fonts (is it possible?).
4
5 %bcond_with bootstrap   # don't use an installed icedtea6, use ecj instead
6 %bcond_without nss      # don't use NSS
7
8 %if %{with bootstrap}
9 %define         use_jdk java-gcj-compat
10 %else
11 %define         use_jdk icedtea6
12 %endif
13
14 # class data version seen with file(1) that this jvm is able to load
15 %define         _classdataversion 50.0
16 # JDK/JRE version, as returned with `java -version`, '_' replaced with '.'
17 %define         _jdkversion 1.6.0.24
18
19 Summary:        OpenJDK and GNU Classpath code
20 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath
21 Name:           icedtea6
22 Version:        1.11.4
23 Release:        1
24 License:        GPL v2
25 Group:          Development/Languages/Java
26 Source0:        http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
27 # Source0-md5:  a5a3a5aeaba0ddf4c9fdf8e899bf77c2
28 # following sources should match those in Makefile.am
29 Source1:        http://download.java.net/openjdk/jdk6/promoted/b24/openjdk-6-src-b24-14_nov_2011.tar.gz
30 # Source1-md5:  0eabdd360169144336e50081b8d01001
31 Source2:        http://icedtea.classpath.org/download/drops/jdk6-jaxws2_1_6-2011_06_13.zip
32 # Source2-md5:  8fd91b09b643a19a912b8a75e7a7a9d5
33 Source3:        http://icedtea.classpath.org/download/drops/jdk6-jaf-b20.zip
34 # Source3-md5:  bc95c133620bd68c161cac9891592901
35 Source4:        http://icedtea.classpath.org/download/drops/jaxp144_03.zip
36 # Source4-md5:  9eea471ad474040265c688858fcf09aa
37 Patch0:         %{name}-i486.patch
38 Patch1:         %{name}-libpath.patch
39 URL:            http://icedtea.classpath.org/wiki/Main_Page
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  ant-nodeps
42 BuildRequires:  ant
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  bash
46 BuildRequires:  cups-devel
47 BuildRequires:  /usr/bin/jar
48 BuildRequires:  freetype-devel >= 2.3
49 BuildRequires:  gawk
50 %{?with_bootstrap:BuildRequires:        gcc-java >= 6:4.3}
51 BuildRequires:  giflib-devel
52 BuildRequires:  glib2-devel
53 BuildRequires:  glibc-misc
54 BuildRequires:  gtk+2-devel
55 BuildRequires:  java-rhino
56 BuildRequires:  java-xalan
57 %{?with_bootstrap:BuildRequires:        java-xerces}
58 %buildrequires_jdk
59 BuildRequires:  libffi-devel
60 # for /usr/share/java/ecj.jar:
61 BuildRequires:  libgcj
62 BuildRequires:  libjpeg-devel
63 BuildRequires:  libpng-devel
64 BuildRequires:  libstdc++-static
65 BuildRequires:  lsb-release
66 %{?with_nss:BuildRequires:      nss-devel}
67 BuildRequires:  pkgconfig
68 BuildRequires:  rpmbuild(macros) >= 1.557
69 BuildRequires:  unzip
70 BuildRequires:  util-linux
71 BuildRequires:  xorg-lib-libX11-devel
72 BuildRequires:  xorg-lib-libXinerama-devel
73 BuildRequires:  xorg-lib-libXp-devel
74 BuildRequires:  xorg-lib-libXrender-devel
75 BuildRequires:  xorg-lib-libXt-devel
76 BuildRequires:  xorg-lib-libXtst-devel
77 BuildRequires:  xorg-proto-printproto-devel
78 BuildRequires:  xorg-proto-xproto-devel
79 BuildRequires:  zip
80 BuildRequires:  zlib-devel
81 Requires:       %{name}-appletviewer = %{version}-%{release}
82 Requires:       %{name}-jdk = %{version}-%{release}
83 Suggests:       %{name}-jre-X11
84 Suggests:       icedtea-web
85 Obsoletes:      java5-sun
86 Obsoletes:      java5-sun-jre
87 Obsoletes:      java5-sun-jre-jdbc
88 Obsoletes:      java5-sun-jre-X11
89 Obsoletes:      java5-sun-tools
90 Obsoletes:      java-gcj-compat
91 Obsoletes:      java-gcj-compat-devel
92 Obsoletes:      java-sun
93 Obsoletes:      java-sun-demos
94 Obsoletes:      java-sun-jre
95 Obsoletes:      java-sun-jre-alsa
96 Obsoletes:      java-sun-jre-jdbc
97 Obsoletes:      java-sun-jre-X11
98 Obsoletes:      java-sun-tools
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         dstreldir       %{name}-%{version}
102 %define         dstdir          %{_jvmdir}/%{dstreldir}
103 %define         jrereldir       %{dstreldir}/jre
104 %define         jredir          %{_jvmdir}/%{jrereldir}
105 %define         jvmjardir       %{_jvmjardir}/%{name}-%{version}
106
107 %ifarch x86_64 amd64
108 %define         jre_arch        amd64
109 %else
110 %define         jre_arch        i386
111 %endif
112
113 # to break artificial subpackage dependency loops
114 %define         _noautoreq      'libmawt.so' 'java(ClassDataVersion)'
115
116 %description
117 The IcedTea project provides a harness to build the source code from
118 http://openjdk.java.net/ using Free Software build tools and provides
119 replacements libraries for the binary plugs with code from the GNU
120 Classpath project.
121
122 This is a meta-package which provides, by its dependencies, all the
123 IcedTea6 components including the OpenJDK, Java 6 developement kit and
124 runtime environment.
125
126 %description -l pl.UTF-8
127 Projekt IcedTea daje możliwość kompilacji kodu źródłowego z
128 http://openjdk.java.net/ przy użyciu wolnodostępnych narzędzi oraz
129 dostarcza zamienniki biblioteczne binarnych wtyczek pochodzące z
130 projektu GNU Classpath.
131
132 To jest meta-pakiet, który, za pośrednictwem zależności, dostarcza
133 wszystkie komponenty IcedTea6, w tym środowisko programistyczne
134 (OpenJDK) i uruchomieniowe (JRE).
135
136 %package jdk
137 Summary:        OpenJDK and GNU Classpath code - software development kit
138 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko programistyczne
139 Group:          Development/Languages/Java
140 Requires:       %{name}-jar = %{version}-%{release}
141 Requires:       %{name}-jdk-base = %{version}-%{release}
142 Requires:       %{name}-jre = %{version}-%{release}
143 Provides:       j2sdk = %{_jdkversion}
144 Provides:       jdk = %{_jdkversion}
145 Obsoletes:      blackdown-java-sdk
146 Obsoletes:      ibm-java
147 Obsoletes:      java-blackdown
148 Obsoletes:      java-gcj-compat-devel
149 Obsoletes:      java-sun
150 Obsoletes:      java5-sun
151 Obsoletes:      jdk
152 Obsoletes:      kaffe
153
154 %description jdk
155 This package symlinks OpenJDK development tools provided by
156 %{name}-jdk-base to system-wide directories like %{_bindir}, making
157 IcedTea6 default JDK.
158
159 %description jdk -l pl.UTF-8
160 Ten pakiet tworzy symboliczne dowiązania do narzędzi programistycznych
161 OpenJDK, dostarczanych przez pakiet %{name}-jdk-base, w standardowych
162 systemowych ścieżkach takich jak %{_bindir}, sprawiając tym samym, że
163 IcedTea6 staje się domyślnym JDK w systemie.
164
165 %package jdk-base
166 Summary:        OpenJDK and GNU Classpath code - software development kit
167 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko programistyczne
168 Group:          Development/Languages/Java
169 Requires:       %{name}-jre-base = %{version}-%{release}
170 Requires:       jpackage-utils >= 0:1.6.6-14
171 Provides:       jdk(%{name})
172
173 %description jdk-base
174 OpenJDK development tools built using free software only.
175
176 %description jdk-base -l pl.UTF-8
177 OpenJDK skompilowane wyłącznie przy użyciu wolnego oprogramowania.
178
179 %package jre
180 Summary:        OpenJDK and GNU Classpath code - runtime environment
181 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko uruchomieniowe
182 Group:          Development/Languages/Java
183 Requires:       %{name}-jre-base = %{version}-%{release}
184 Provides:       java
185 Provides:       java(ClassDataVersion) = %{_classdataversion}
186 Provides:       java(jaas) = %{version}
187 Provides:       java(jaf) = 1.1.1
188 Provides:       java(jaxp) = 1.3
189 Provides:       java(jaxp_parser_impl)
190 Provides:       java(jce) = %{version}
191 Provides:       java(jdbc-stdext) = %{version}
192 Provides:       java(jdbc-stdext) = 3.0
193 Provides:       java(jmx) = 1.4
194 Provides:       java(jndi) = %{version}
195 Provides:       java(jsse) = %{version}
196 Provides:       java1.4
197 Provides:       jre = %{_jdkversion}
198 Obsoletes:      java(jaas)
199 Obsoletes:      java(jaf)
200 Obsoletes:      java(jaxp)
201 Obsoletes:      java(jce)
202 Obsoletes:      java(jdbc-stdext)
203 Obsoletes:      java(jdbc-stdext)
204 Obsoletes:      java(jmx)
205 Obsoletes:      java(jndi)
206 Obsoletes:      java(jsse)
207 Obsoletes:      java-gcj-compat
208 Obsoletes:      java-sun-jre
209 Obsoletes:      java5-sun-jre
210 Obsoletes:      jre
211
212 %description jre
213 This package symlinks OpenJDK runtime environment tools provided by
214 %{name}-jre-base to system-wide directories like %{_bindir}, making
215 IcedTea6 default JRE.
216
217 %description jre -l pl.UTF-8
218 Ten pakiet tworzy symboliczne dowiązania do środowiska
219 uruchomieniowego OpenJDK, dostarczanych przez pakiet %{name}-jre-base,
220 w standardowych systemowych ścieżkach takich jak %{_bindir},
221 sprawiając tym samym, że IcedTea6 staje się domyślnym JRE w systemie.
222
223 %package jre-X11
224 Summary:        IcedTea6 OpenJDK - runtime environment - X11 support
225 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa X11
226 Group:          Development/Languages/Java
227 Requires:       %{name}-jre = %{version}-%{release}
228 Requires:       %{name}-jre-base-X11 = %{version}-%{release}
229 Provides:       jre-X11 = %{_jdkversion}
230
231 %description jre-X11
232 X11 support for OpenJDK runtime environment built using free software
233 only.
234
235 %description jre-X11 -l pl.UTF-8
236 Biblioteki X11 dla środowiska OpenJDK zbudowany wyłocznie przy uzyciu
237 wolnego oprogramowania.
238
239 %package jre-base
240 Summary:        OpenJDK and GNU Classpath code - runtime environment
241 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko uruchomieniowe
242 Group:          Development/Languages/Java
243 Requires:       jpackage-utils >= 0:1.6.6-14
244 Provides:       jre(%{name})
245
246 %description jre-base
247 OpenJDK runtime environment built using free software only.
248
249 %description jre-base -l pl.UTF-8
250 Środowisko uruchomieniowe OpenJDK zbudowany wyłącznie przy użyciu
251 wolnego oprogramowania.
252
253 %package jre-base-X11
254 Summary:        IcedTea6 OpenJDK - runtime environment - X11 support
255 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa X11
256 Group:          Development/Languages/Java
257 Requires:       %{name}-jre-base = %{version}-%{release}
258 Requires:       %{name}-jre-base-freetype = %{version}-%{release}
259
260 %description jre-base-X11
261 X11 support for OpenJDK runtime environment built using free software
262 only.
263
264 %description jre-base-X11 -l pl.UTF-8
265 Biblioteki X11 dla środowiska OpenJDK zbudowany wyłocznie przy uzyciu
266 wolnego oprogramowania.
267
268 %package jre-base-alsa
269 Summary:        IcedTea6 OpenJDK - runtime environment - ALSA support
270 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa ALSA
271 Group:          Development/Languages/Java
272 Requires:       %{name}-jre-base = %{version}-%{release}
273
274 %description jre-base-alsa
275 ALSA sound support for OpenJDK runtime environment build using free
276 software only.
277
278 %description jre-base-alsa -l pl.UTF-8
279 Biblioteki ALSA rozszerzające środowisko OpenJDK o obsługę dźwięku
280 zbudowane przy uzyciu wyłącznie wolnego oprogramowania.
281
282 %package jre-base-freetype
283 Summary:        IcedTea6 OpenJDK - runtime environment - font support
284 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa fontów
285 Group:          Development/Languages/Java
286 Requires:       %{name}-jre-base = %{version}-%{release}
287
288 %description jre-base-freetype
289 Font handling library for OpenJDK runtime environment built using free
290 software only.
291
292 %description jre-base-freetype -l pl.UTF-8
293 Biblioteki obsługi czcionek dla OpenJDK zbudowane wyłącznie przy
294 użyciu wolnego oprogramowania.
295
296 %package jar
297 Summary:        OpenJDK and GNU Classpath code - JAR tool
298 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - narzędzie JAR
299 Group:          Development/Languages/Java
300 Requires:       %{name}-jdk-base = %{version}-%{release}
301 Provides:       jar
302 Obsoletes:      fastjar
303 Obsoletes:      jar
304
305 %description jar
306 JAR tool from OpenJDK built using free software only.
307
308 JAR is an archiver used to merge Java classes into a single library.
309
310 %description jar -l pl.UTF-8
311 Narzędzie jar z OpenJDK zbudowane przy uzyciu wyłącznie wolnego
312 oprogramowania.
313
314 JAR jest narzędziem pozwalającym wykonywać podstawowe operacje na
315 archiwach javy .jar takie jak na przykład tworzenie lub rozpakowywanie
316 archiwów.
317
318 %package appletviewer
319 Summary:        OpenJDK and GNU Classpath code - appletviewer tool
320 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - narzędzie appletviewer
321 Group:          Development/Languages/Java
322 Requires:       %{name}-jdk-base = %{version}-%{release}
323 Requires:       %{name}-jre-X11 = %{version}-%{release}
324 Obsoletes:      java-sun-appletviewer
325
326 %description appletviewer
327 Appletviewer from OpenJDK build using free software only.
328
329 %description appletviewer -l pl.UTF-8
330 Appletviewer pozwala uruchamiać aplety javy niezależnie od
331 przeglądarki www. Ten appletviewer pochodzi z zestawu narzędzi OpenJDK
332 i został zbudowany wyłącznie przy użyciu wolnego oprogramowania.
333
334 %package jdk-sources
335 Summary:        OpenJDK and GNU Classpath code - sources
336 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - kod źródłowy
337 Group:          Documentation
338
339 %description jdk-sources
340 Source code for the OpenJDK development kit and Java standard library.
341
342 %description jdk-sources -l pl.UTF-8
343 Kod źródłowy narzędzi programistycznych OpenJDK oraz standardowej
344 biblioteki Javy.
345
346 %package examples
347 Summary:        OpenJDK and GNU Classpath code - examples
348 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - przykłady
349 Group:          Documentation
350
351 %description examples
352 Code examples for OpenJDK.
353
354 %description examples -l pl.UTF-8
355 Przykłady dla OpenJDK.
356
357 %prep
358 %setup -q
359 %patch0 -p1
360
361 # patches to applied to the extracted sources
362 install -d pld-patches
363 cp -p %{PATCH1} pld-patches
364
365 # let the build system extract the sources where it wants them
366 install -d drops
367 ln -s %{SOURCE1} .
368 ln -s %{SOURCE2} drops
369 ln -s %{SOURCE3} drops
370 ln -s %{SOURCE4} drops
371
372 %build
373 # Make sure we have /proc mounted - otherwise idlc will fail later.
374 if [ ! -f /proc/self/stat ]; then
375         echo "You need to have /proc mounted in order to build this package!"
376         exit 1
377 fi
378
379 export JAVA_HOME=%{java_home}
380 export PATH="$JAVA_HOME/bin:$PATH"
381
382 %{__aclocal}
383 %{__autoconf}
384 %{__automake}
385
386 %configure \
387         WGET=%{_bindir}/wget \
388 %if %{with bootstrap}
389         --with-gcj-home=%{java_home} \
390         --with-ecj-jar=%{_javadir}/ecj.jar \
391 %else
392         --with-jdk-home=%{java_home} \
393 %endif
394         %{!?with_nss:--disable-nss} \
395         --with-xalan2-jar=%{_javadir}/xalan.jar \
396         --with-xalan2-serializer-jar=%{_javadir}/serializer.jar \
397         --with-rhino=%{_javadir}/js.jar
398
399 %{__make} extract extract-ecj \
400         DISTRIBUTION_PATCHES="$(echo pld-patches/*.patch)"
401
402 %if %{with bootstrap}
403 # Cannot do that as patch, as the sources are prepared by make
404 %{__sed} -i -e's/CORBA_BUILD_ARGUMENTS = \\/CORBA_BUILD_ARGUMENTS = JVMLIB="" \\/' openjdk-ecj/make/corba-rules.gmk
405 %endif
406 # if dpkg-architecure is installed (like on carme) it will break the build
407 # unless we disable using it somehow. As patching is difficult here:
408 %{__sed} -i -e's/dpkg-architecture/dpkg-architecture__/' openjdk*/*/make/common/shared/Platform.gmk
409
410 %{__make} -j1 \
411         DISABLE_HOTSPOT_OS_VERSION_CHECK=ok \
412         DISTRIBUTION_PATCHES="$(echo pld-patches/*.patch)" \
413         PRINTF=/bin/printf
414
415 %install
416 rm -rf $RPM_BUILD_ROOT
417 install -d $RPM_BUILD_ROOT{%{_bindir},%{dstdir},%{_mandir}/ja} \
418         $RPM_BUILD_ROOT{%{jvmjardir},%{_examplesdir}/%{name}-%{version},%{_javasrcdir}} \
419         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
420
421 # install the 'JDK image', it contains the JRE too
422 cp -a openjdk.build/j2sdk-image/* $RPM_BUILD_ROOT%{dstdir}
423
424 # convenience symlinks without version number
425 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}
426 ln -s %{jrereldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}-jre
427
428 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/java
429
430 # move JDK sources and demo to /usr/src
431 mv $RPM_BUILD_ROOT%{dstdir}/demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
432 mv $RPM_BUILD_ROOT%{dstdir}/sample $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
433 mv $RPM_BUILD_ROOT%{dstdir}/src.zip $RPM_BUILD_ROOT%{_javasrcdir}/%{name}-jdk.zip
434
435 # move manual pages to its place
436 mv $RPM_BUILD_ROOT%{dstdir}/man/ja_JP.eucJP/man1 $RPM_BUILD_ROOT%{_mandir}/ja/man1
437 rmdir $RPM_BUILD_ROOT%{dstdir}/man/ja_JP.eucJP
438 rm $RPM_BUILD_ROOT%{dstdir}/man/ja
439 mv $RPM_BUILD_ROOT%{dstdir}/man/man1 $RPM_BUILD_ROOT%{_mandir}/man1
440 rmdir $RPM_BUILD_ROOT%{dstdir}/man
441
442 # replace duplicates with symlinks, link to %{_bindir}
443 for path in $RPM_BUILD_ROOT%{dstdir}/bin/*; do
444         filename=$(basename $path)
445         if diff -q "$path" "$RPM_BUILD_ROOT%{jredir}/bin/$filename" > /dev/null; then
446                 ln -sf "../jre/bin/$filename" "$path"
447                 ln -sf "%{jredir}/bin/$filename" $RPM_BUILD_ROOT%{_bindir}
448         else
449                 ln -sf "%{dstdir}/bin/$filename" $RPM_BUILD_ROOT%{_bindir}
450         fi
451 done
452 ln -sf ../jre/lib/jexec $RPM_BUILD_ROOT%{dstdir}/lib/jexec
453
454 # keep configuration in /etc (not all *.properties go there)
455 for config in management security content-types.properties \
456                 logging.properties net.properties sound.properties; do
457
458         mv $RPM_BUILD_ROOT%{jredir}/lib/$config $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/$config
459         ln -s %{_sysconfdir}/%{name}/$config $RPM_BUILD_ROOT%{jredir}/lib/$config
460 done
461
462 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jsse.jar
463 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jcert.jar
464 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jnet.jar
465 ln -sf %{jredir}/lib/jce.jar $RPM_BUILD_ROOT%{jvmjardir}/jce.jar
466 for f in jndi jndi-ldap jndi-cos jndi-rmi jaas jdbc-stdext jdbc-stdext-3.0 \
467         sasl jaxp_parser_impl jaxp_transform_impl jaxp jmx activation xml-commons-apis \
468         jndi-dns jndi-rmi; do
469         ln -sf %{jredir}/lib/rt.jar $RPM_BUILD_ROOT%{jvmjardir}/$f.jar
470 done
471
472 # some apps (like opera) looks for it in different place
473 ln -s server/libjvm.so $RPM_BUILD_ROOT%{jredir}/lib/%{jre_arch}/libjvm.so
474
475 %{__rm} $RPM_BUILD_ROOT%{dstdir}/{,jre/}{ASSEMBLY_EXCEPTION,LICENSE,THIRD_PARTY_README}
476
477 %clean
478 rm -rf $RPM_BUILD_ROOT
479
480 %files
481 %defattr(644,root,root,755)
482 %doc AUTHORS ChangeLog HACKING NEWS README THANKYOU
483
484 %files jdk
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{_bindir}/apt
487 %attr(755,root,root) %{_bindir}/extcheck
488 %attr(755,root,root) %{_bindir}/idlj
489 %attr(755,root,root) %{_bindir}/jarsigner
490 %attr(755,root,root) %{_bindir}/java-rmi.cgi
491 %attr(755,root,root) %{_bindir}/javac
492 %attr(755,root,root) %{_bindir}/javadoc
493 %attr(755,root,root) %{_bindir}/javah
494 %attr(755,root,root) %{_bindir}/javap
495 %attr(755,root,root) %{_bindir}/jconsole
496 %attr(755,root,root) %{_bindir}/jdb
497 %attr(755,root,root) %{_bindir}/jhat
498 %attr(755,root,root) %{_bindir}/jinfo
499 %attr(755,root,root) %{_bindir}/jmap
500 %attr(755,root,root) %{_bindir}/jps
501 %attr(755,root,root) %{_bindir}/jrunscript
502 %attr(755,root,root) %{_bindir}/jsadebugd
503 %attr(755,root,root) %{_bindir}/jstack
504 %attr(755,root,root) %{_bindir}/jstat
505 %attr(755,root,root) %{_bindir}/jstatd
506 %attr(755,root,root) %{_bindir}/native2ascii
507 %attr(755,root,root) %{_bindir}/rmic
508 %attr(755,root,root) %{_bindir}/schemagen
509 %attr(755,root,root) %{_bindir}/serialver
510 %attr(755,root,root) %{_bindir}/wsgen
511 %attr(755,root,root) %{_bindir}/wsimport
512 %attr(755,root,root) %{_bindir}/xjc
513 %{_jvmdir}/java
514 %{_mandir}/man1/apt.1*
515 %{_mandir}/man1/extcheck.1*
516 %{_mandir}/man1/idlj.1*
517 %{_mandir}/man1/jarsigner.1*
518 %{_mandir}/man1/javac.1*
519 %{_mandir}/man1/javadoc.1*
520 %{_mandir}/man1/javah.1*
521 %{_mandir}/man1/javap.1*
522 %{_mandir}/man1/jconsole.1*
523 %{_mandir}/man1/jdb.1*
524 %{_mandir}/man1/jhat.1*
525 %{_mandir}/man1/jinfo.1*
526 %{_mandir}/man1/jmap.1*
527 %{_mandir}/man1/jps.1*
528 %{_mandir}/man1/jrunscript.1*
529 %{_mandir}/man1/jsadebugd.1*
530 %{_mandir}/man1/jstack.1*
531 %{_mandir}/man1/jstat.1*
532 %{_mandir}/man1/jstatd.1*
533 %{_mandir}/man1/native2ascii.1*
534 %{_mandir}/man1/schemagen.1*
535 %{_mandir}/man1/serialver.1*
536 %{_mandir}/man1/rmic.1*
537 %{_mandir}/man1/wsgen.1*
538 %{_mandir}/man1/wsimport.1*
539 %{_mandir}/man1/xjc.1*
540 %lang(ja) %{_mandir}/ja/man1/apt.1*
541 %lang(ja) %{_mandir}/ja/man1/extcheck.1*
542 %lang(ja) %{_mandir}/ja/man1/idlj.1*
543 %lang(ja) %{_mandir}/ja/man1/jarsigner.1*
544 %lang(ja) %{_mandir}/ja/man1/javac.1*
545 %lang(ja) %{_mandir}/ja/man1/javadoc.1*
546 %lang(ja) %{_mandir}/ja/man1/javah.1*
547 %lang(ja) %{_mandir}/ja/man1/javap.1*
548 %lang(ja) %{_mandir}/ja/man1/jconsole.1*
549 %lang(ja) %{_mandir}/ja/man1/jdb.1*
550 %lang(ja) %{_mandir}/ja/man1/jhat.1*
551 %lang(ja) %{_mandir}/ja/man1/jinfo.1*
552 %lang(ja) %{_mandir}/ja/man1/jmap.1*
553 %lang(ja) %{_mandir}/ja/man1/jps.1*
554 %lang(ja) %{_mandir}/ja/man1/jrunscript.1*
555 %lang(ja) %{_mandir}/ja/man1/jsadebugd.1*
556 %lang(ja) %{_mandir}/ja/man1/jstack.1*
557 %lang(ja) %{_mandir}/ja/man1/jstat.1*
558 %lang(ja) %{_mandir}/ja/man1/jstatd.1*
559 %lang(ja) %{_mandir}/ja/man1/native2ascii.1*
560 %lang(ja) %{_mandir}/ja/man1/schemagen.1*
561 %lang(ja) %{_mandir}/ja/man1/serialver.1*
562 %lang(ja) %{_mandir}/ja/man1/rmic.1*
563 %lang(ja) %{_mandir}/ja/man1/wsgen.1*
564 %lang(ja) %{_mandir}/ja/man1/wsimport.1*
565 %lang(ja) %{_mandir}/ja/man1/xjc.1*
566
567 %files jdk-base
568 %defattr(644,root,root,755)
569 %doc openjdk.build/j2sdk-image/THIRD_PARTY_README
570 %doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
571 %dir %{dstdir}
572 %{_jvmdir}/%{name}
573 %attr(755,root,root) %{dstdir}/bin/appletviewer
574 %attr(755,root,root) %{dstdir}/bin/apt
575 %attr(755,root,root) %{dstdir}/bin/extcheck
576 %attr(755,root,root) %{dstdir}/bin/idlj
577 %attr(755,root,root) %{dstdir}/bin/jar
578 %attr(755,root,root) %{dstdir}/bin/jarsigner
579 %attr(755,root,root) %{dstdir}/bin/java-rmi.cgi
580 %attr(755,root,root) %{dstdir}/bin/javac
581 %attr(755,root,root) %{dstdir}/bin/javadoc
582 %attr(755,root,root) %{dstdir}/bin/javah
583 %attr(755,root,root) %{dstdir}/bin/javap
584 %attr(755,root,root) %{dstdir}/bin/jconsole
585 %attr(755,root,root) %{dstdir}/bin/jdb
586 %attr(755,root,root) %{dstdir}/bin/jhat
587 %attr(755,root,root) %{dstdir}/bin/jinfo
588 %attr(755,root,root) %{dstdir}/bin/jmap
589 %attr(755,root,root) %{dstdir}/bin/jps
590 %attr(755,root,root) %{dstdir}/bin/jrunscript
591 %attr(755,root,root) %{dstdir}/bin/jsadebugd
592 %attr(755,root,root) %{dstdir}/bin/jstack
593 %attr(755,root,root) %{dstdir}/bin/jstat
594 %attr(755,root,root) %{dstdir}/bin/jstatd
595 %attr(755,root,root) %{dstdir}/bin/native2ascii
596 %attr(755,root,root) %{dstdir}/bin/rmic
597 %attr(755,root,root) %{dstdir}/bin/schemagen
598 %attr(755,root,root) %{dstdir}/bin/serialver
599 %attr(755,root,root) %{dstdir}/bin/servertool
600 %attr(755,root,root) %{dstdir}/bin/wsgen
601 %attr(755,root,root) %{dstdir}/bin/wsimport
602 %attr(755,root,root) %{dstdir}/bin/xjc
603 %{dstdir}/include
604 %dir %{dstdir}/lib
605 %{dstdir}/lib/ct.sym
606 %{dstdir}/lib/dt.jar
607 %{dstdir}/lib/ir.idl
608 %{dstdir}/lib/jconsole.jar
609 %attr(755,root,root) %{dstdir}/lib/jexec
610 %{dstdir}/lib/orb.idl
611 %ifnarch i486
612 %{dstdir}/lib/sa-jdi.jar
613 %endif
614 %{dstdir}/lib/tools.jar
615
616 %files jre
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/java
619 %attr(755,root,root) %{_bindir}/keytool
620 %attr(755,root,root) %{_bindir}/orbd
621 %attr(755,root,root) %{_bindir}/pack200
622 %attr(755,root,root) %{_bindir}/rmid
623 %attr(755,root,root) %{_bindir}/rmiregistry
624 %attr(755,root,root) %{_bindir}/servertool
625 %attr(755,root,root) %{_bindir}/tnameserv
626 %attr(755,root,root) %{_bindir}/unpack200
627 %{_mandir}/man1/java.1*
628 %{_mandir}/man1/keytool.1*
629 %{_mandir}/man1/orbd.1*
630 %{_mandir}/man1/pack200.1*
631 %{_mandir}/man1/rmid.1*
632 %{_mandir}/man1/rmiregistry.1*
633 %{_mandir}/man1/servertool.1*
634 %{_mandir}/man1/tnameserv.1*
635 %{_mandir}/man1/unpack200.1*
636 %lang(ja) %{_mandir}/ja/man1/java.1*
637 %ifnarch x86_64
638 %endif
639 %lang(ja) %{_mandir}/ja/man1/keytool.1*
640 %lang(ja) %{_mandir}/ja/man1/orbd.1*
641 %lang(ja) %{_mandir}/ja/man1/pack200.1*
642 %lang(ja) %{_mandir}/ja/man1/rmid.1*
643 %lang(ja) %{_mandir}/ja/man1/rmiregistry.1*
644 %lang(ja) %{_mandir}/ja/man1/servertool.1*
645 %lang(ja) %{_mandir}/ja/man1/tnameserv.1*
646 %lang(ja) %{_mandir}/ja/man1/unpack200.1*
647
648 %files jre-base
649 %defattr(644,root,root,755)
650 %doc openjdk.build/j2sdk-image/THIRD_PARTY_README
651 %doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
652 %dir %{_sysconfdir}/%{name}
653 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
654 %dir %{dstdir}
655 %dir %{jredir}
656 %{_jvmdir}/%{name}-jre
657 %dir %{jredir}/bin
658 %dir %{dstdir}/bin
659 %attr(755,root,root) %{jredir}/bin/java
660 %attr(755,root,root) %{dstdir}/bin/java
661 %attr(755,root,root) %{jredir}/bin/keytool
662 %attr(755,root,root) %{dstdir}/bin/keytool
663 %attr(755,root,root) %{jredir}/bin/orbd
664 %attr(755,root,root) %{dstdir}/bin/orbd
665 %attr(755,root,root) %{jredir}/bin/pack200
666 %attr(755,root,root) %{dstdir}/bin/pack200
667 %attr(755,root,root) %{jredir}/bin/rmid
668 %attr(755,root,root) %{dstdir}/bin/rmid
669 %attr(755,root,root) %{jredir}/bin/rmiregistry
670 %attr(755,root,root) %{dstdir}/bin/rmiregistry
671 %attr(755,root,root) %{jredir}/bin/servertool
672 %attr(755,root,root) %{dstdir}/bin/servertool
673 %attr(755,root,root) %{jredir}/bin/tnameserv
674 %attr(755,root,root) %{dstdir}/bin/tnameserv
675 %attr(755,root,root) %{jredir}/bin/unpack200
676 %attr(755,root,root) %{dstdir}/bin/unpack200
677 %dir %{jredir}/lib
678 %dir %{jredir}/lib/applet
679 %{jredir}/lib/cmm
680 %{jredir}/lib/ext
681 %dir %{jredir}/lib/%{jre_arch}
682 %ifnarch x86_64 i486
683 %dir %{jredir}/lib/%{jre_arch}/client
684 %{jredir}/lib/%{jre_arch}/client/Xusage.txt
685 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/client/*.so
686 %endif
687 %dir %{jredir}/lib/%{jre_arch}/headless
688 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/headless/*.so
689 %dir %{jredir}/lib/%{jre_arch}/jli
690 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/jli/*.so
691 %dir %{jredir}/lib/%{jre_arch}/native_threads
692 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/native_threads/*.so
693 %dir %{jredir}/lib/%{jre_arch}/server
694 %{jredir}/lib/%{jre_arch}/server/Xusage.txt
695 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/server/*.so
696 %{jredir}/lib/%{jre_arch}/jvm.cfg
697 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libattach.so
698 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libawt.so
699 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libdt_socket.so
700 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libhprof.so
701 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libinstrument.so
702 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2gss.so
703 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pcsc.so
704 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pkcs11.so
705 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjaas_unix.so
706 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava.so
707 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava_crw_demo.so
708 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
709 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjdwp.so
710 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjpeg.so
711 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsig.so
712 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsound.so
713 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjvm.so
714 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/liblcms.so
715 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libmanagement.so
716 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libmlib_image.so
717 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnet.so
718 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnio.so
719 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnpt.so
720 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/librmi.so
721 %ifnarch i486
722 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsaproc.so
723 %endif
724 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libunpack.so
725 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libverify.so
726 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libzip.so
727 %{jredir}/lib/im
728 %{jredir}/lib/images
729 %{jredir}/lib/management
730 %{jredir}/lib/security
731 %{jredir}/lib/zi
732 #
733 %if %{with webstart}
734 %{jredir}/lib/about.jar
735 %{jredir}/lib/about.jnlp
736 %endif
737 %{jredir}/lib/calendars.properties
738 %{jredir}/lib/charsets.jar
739 %{jredir}/lib/classlist
740 %{jredir}/lib/content-types.properties
741 %{jredir}/lib/currency.data
742 %{jredir}/lib/flavormap.properties
743 %{jredir}/lib/fontconfig.*
744 %{jredir}/lib/jce.jar
745 %attr(755, root, root) %{jredir}/lib/jexec
746 %{jredir}/lib/jsse.jar
747 %{jredir}/lib/jvm.hprof.txt
748 %{jredir}/lib/logging.properties
749 %{jredir}/lib/management-agent.jar
750 %{jredir}/lib/meta-index
751 %{jredir}/lib/net.properties
752 %{jredir}/lib/psfont.properties.ja
753 %{jredir}/lib/psfontj2d.properties
754 %{jredir}/lib/resources.jar
755 %{jredir}/lib/rhino.jar
756 %{jredir}/lib/rt.jar
757 %{jredir}/lib/sound.properties
758 %{jredir}/lib/tz.properties
759 %{jvmjardir}
760
761 %files jre-X11
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_bindir}/policytool
764 %{_mandir}/man1/policytool.1*
765 %lang(ja) %{_mandir}/ja/man1/policytool.1*
766
767 %files jre-base-X11
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{jredir}/bin/policytool
770 %attr(755,root,root) %{dstdir}/bin/policytool
771 %dir %{jredir}/lib/%{jre_arch}/xawt
772 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/xawt/*.so
773 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsplashscreen.so
774
775 %files jre-base-alsa
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsoundalsa.so
778
779 %files jre-base-freetype
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libfontmanager.so
782
783 %files jar
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_bindir}/jar
786 %{_mandir}/man1/jar.1*
787 %lang(ja) %{_mandir}/ja/man1/jar.1*
788
789 %files appletviewer
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_bindir}/appletviewer
792 %{_mandir}/man1/appletviewer.1*
793 %lang(ja) %{_mandir}/ja/man1/appletviewer.1*
794
795 %files jdk-sources
796 %defattr(644,root,root,755)
797 %{_javasrcdir}/%{name}-jdk.zip
798
799 %files examples
800 %defattr(644,root,root,755)
801 %{_examplesdir}/%{name}-%{version}
This page took 0.085823 seconds and 2 git commands to generate.