]> git.pld-linux.org Git - packages/ice.git/blob - ice.spec
- slice2<binding> to -devel
[packages/ice.git] / ice.spec
1 # TODO
2 # - get stuff from fc spec
3 # - cc/cflags
4 # - language bindings
5 #
6 # Conditional build:
7 %bcond_without  java            # Java bindings
8 %bcond_without  dotnet          # .NET bindings
9 %bcond_without  python          # Python bindings
10 %bcond_without  ruby            # Ruby bindings
11 %bcond_without  php                     # PHP bindings
12 %bcond_without  gui                     # IceGrid GUI
13
14 Summary:        The Ice base runtime and services
15 Name:           ice
16 Version:        3.4.0
17 Release:        0.2
18 License:        GPL v2 with exceptions (see ICE_LICENSE)
19 Group:          Applications
20 Source0:        http://www.zeroc.com/download/Ice/3.4/Ice-%{version}.tar.gz
21 # Source0-md5:  998b10627ade020cb00f5beb73efc0e0
22 # Extracted from http://zeroc.com/download/Ice/3.4/ice-3.4.0-1.src.rpm
23 Source1:        Ice-rpmbuild-%{version}.tar.gz
24 # Source1-md5:  869cc60645e7e2b4115584a5ab17d1e9
25 Source2:        %{name}gridgui
26 Source3:        IceGridAdmin.desktop
27 URL:            http://www.zeroc.com/
28 Patch0:         %{name}-build.patch
29 Patch1:         dont-build-demo-test.patch
30 Patch2:         java-build.patch
31 %{?with_python:BuildRequires:   rpm-pythonprov}
32 %{?with_ruby:BuildRequires:     ruby >= 1:1.8.6}
33 Patch3:         jgoodies.patch
34 BuildRequires:  db-cxx-devel
35 %{?with_java:BuildRequires:     db-java-devel}
36 %{?with_java:BuildRequires:     java-jgoodies-forms}
37 %{?with_java:BuildRequires:     java-jgoodies-looks}
38 BuildRequires:  mcpp-devel
39 %{?with_php:BuildRequires:      php-devel >= 3:5.0.0}
40 BuildRequires:  rpmbuild(macros) >= 1.519
41 # drop these O/P if not needed
42 Provides:       Ice
43 Obsoletes:      Ice
44 # Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
45 ExcludeArch:    ppc64 sparc64
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 # Some file suffixes we need to grab the right stuff for the file lists
49 %define         soversion       34
50
51 %description
52 Ice is a modern alternative to object middleware such as CORBA or
53 COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
54 infrastructure for demanding technical applications. It features an
55 object-oriented specification language, easy to use C++, C#, Java,
56 Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
57 protocol, asynchronous method invocation and dispatch, dynamic
58 transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
59 firewall solution, and much more.
60
61 %package servers
62 Summary:        Ice services to run through /etc/rc.d/init.d
63 Group:          Development/Tools
64 Requires(post): /sbin/chkconfig
65 Requires(pre):  shadow-utils
66 Requires(preun):        /sbin/chkconfig
67 Requires(preun):        /sbin/service
68 Requires:       %{name} = %{version}-%{release}
69
70 %description servers
71 Ice services to run through /etc/rc.d/init.d
72
73 %package devel
74 Summary:        Tools for developing Ice applications in C++
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 # drop these O/P if not needed
78 Provides:       Ice-devel
79 Obsoletes:      Ice-devel
80
81 %description devel
82 Tools for developing Ice applications in C++.
83
84 %package java
85 Summary:        The Ice runtime for Java
86 Group:          Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       db4-java
89 Requires:       java >= 1.5.0
90
91 %description java
92 The Ice runtime for Java
93
94 %package java-devel
95 Summary:        Tools for developing Ice applications in Java
96 Group:          Development/Tools
97 Requires:       ice-java = %{version}-%{release}
98
99 %description java-devel
100 Tools for developing Ice applications in Java.
101
102 %package csharp
103 Summary:        IceGrid Admin Tool
104 Summary:        The Ice runtime for C#
105 Group:          Development/Tools
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       ice-java = %{version}-%{release}
110 Requires:       java
111 Requires:       jgoodies-forms
112 Requires:       jgoodies-looks
113 Requires:       jpackage-utils
114 Requires:       mono-core >= 1.2.2
115 Provides:       ice-dotnet = %{version}-%{release}
116 Obsoletes:      ice-dotnet < %{version}-%{release}
117
118 %description csharp
119 The Ice runtime for C#
120
121 %package csharp-devel
122 Summary:        Tools for developing Ice applications in C#
123 Group:          Development/Tools
124 Requires:       ice-csharp = %{version}-%{release}
125 Requires:       pkgconfig
126
127 %description csharp-devel
128 Tools for developing Ice applications in C#.
129
130 %package ruby
131 Summary:        The Ice runtime for Ruby applications
132 Group:          Development/Tools
133 BuildRequires:  ruby-modules
134 Requires:       %{name} = %{version}-%{release}
135 %{?ruby_mod_ver_requires_eq}
136
137 %description ruby
138 The Ice runtime for Ruby applications.
139
140 %package ruby-devel
141 Summary:        Tools for developing Ice applications in Ruby
142 Group:          Development/Tools
143 Requires:       ice-ruby = %{version}-%{release}
144
145 %description ruby-devel
146 Tools for developing Ice applications in Ruby.
147
148 %package python
149 Summary:        The Ice runtime for Python applications
150 Group:          Development/Tools
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       python >= 2.3.4
153
154 %description python
155 The Ice runtime for Python applications.
156
157 %package python-devel
158 Summary:        Tools for developing Ice applications in Python
159 Group:          Development/Tools
160 Requires:       ice-python = %{version}-%{release}
161
162 %description python-devel
163 Tools for developing Ice applications in Python.
164
165 %package php
166 Summary:        The Ice runtime for PHP applications
167 Group:          Libraries
168 Requires:       %{name} = %{version}-%{release}
169 %{?requires_php_extension}
170
171 %description php
172 The Ice runtime for PHP applications.
173
174 %package php-devel
175 Summary:        Tools for developing Ice applications in PHP
176 Group:          Development/Tools
177 Requires:       ice-php = %{version}-%{release}
178
179 %description php-devel
180 Tools for developing Ice applications in PHP.
181
182 %prep
183 %setup -q -n Ice-%{version} -a 1
184 %patch0 -p0
185 %patch1 -p1
186 %patch2 -p1
187 %patch3 -p1
188
189 %build
190
191 # Compile the main Ice runtime
192 # TODO: CC/CXX passing as make param breaks build system
193 %{__make} -C cpp \
194         CFLAGS="%{rpmcflags} -fPIC" \
195         CXXFLAGS="%{rpmcxxflags} -fPIC" \
196         embedded_runpath_prefix=""
197
198 %if %{with java}
199 # Set the CLASSPATH correctly for the Java compile
200 export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
201
202 # Rebuild the Java ImportKey class
203 cd cpp/src/ca
204 rm *.class
205 javac ImportKey.java
206 cd -
207
208 %{__make} -C java \
209         CFLAGS="%{rpmcflags} -fPIC" \
210         CXXFLAGS="%{rpmcxxflags} -fPIC" \
211         embedded_runpath_prefix=""
212
213 # Create the IceGrid icon
214 cd java/resources/icons
215 convert icegrid.ico temp.png
216 mv temp-8.png icegrid.png
217 rm temp*.png
218 cd -
219 %endif
220
221 %if %{with dotnet}
222 %{__make} -C cs \
223         CFLAGS="%{rpmcflags} -fPIC" \
224         CXXFLAGS="%{rpmcxxflags} -fPIC" \
225         embedded_runpath_prefix=""
226 %endif
227
228 %if %{with python}
229 %{__make} -C py \
230         CFLAGS="%{rpmcflags} -fPIC" \
231         CXXFLAGS="%{rpmcxxflags} -fPIC" \
232         embedded_runpath_prefix=""
233 %endif
234
235 %if %{with ruby}
236 %{__make} -C rb \
237         CFLAGS="%{rpmcflags} -fPIC" \
238         CXXFLAGS="%{rpmcxxflags} -fPIC" \
239         embedded_runpath_prefix=""
240 %endif
241
242 %if %{with php}
243 %{__make} -C php \
244         PHP_HOME=%{_prefix} \
245         CFLAGS="%{rpmcflags} -fPIC" \
246         CXXFLAGS="%{rpmcxxflags} -fPIC" \
247         embedded_runpath_prefix=""
248 %endif
249
250 %install
251 rm -rf $RPM_BUILD_ROOT
252 install -d $RPM_BUILD_ROOT{%{_docdir}/Ice-%{version},%{_datadir}/Ice}
253
254 %{__make} install \
255         prefix=$RPM_BUILD_ROOT \
256         GACINSTALL=yes \
257         GAC_ROOT=$RPM_BUILD_ROOT%{_libdir} \
258         embedded_runpath_prefix=""
259
260 %if %{with java}
261 %{__make} -C java install \
262         prefix=$RPM_BUILD_ROOT \
263         GACINSTALL=yes \
264         GAC_ROOT=$RPM_BUILD_ROOT%{_libdir} \
265         embedded_runpath_prefix=""
266 # Move Java stuff where it should be
267 install -d $RPM_BUILD_ROOT%{_javadir}
268 mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant-ice-%{version}.jar
269 ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant-ice.jar
270 mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
271 ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
272 mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
273 ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
274 %endif
275
276 %if %{with gui}
277 # Install the IceGrid GUI
278 mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
279 install -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
280 cp -a java/resources/icons/icegrid.png \
281         $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
282 install -d $RPM_BUILD_ROOT%{_bindir}
283 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
284 install -d $RPM_BUILD_ROOT%{_desktopdir}
285 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
286 %endif
287
288 # Move other rpm-specific files into the right place (README, service stuff)
289 cp -a Ice-rpmbuild-%{version}/ice.ini $RPM_BUILD_ROOT/ice.ini
290
291 # Install the servers
292 install -d $RPM_BUILD_ROOT%{_sysconfdir}
293 cp -a Ice-rpmbuild-%{version}/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
294 install -d $RPM_BUILD_ROOT%{_initrddir}
295 for i in icegridregistry icegridnode glacier2router; do
296         cp -a Ice-rpmbuild-%{version}/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
297 done
298 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
299
300 # "make install" assumes it's going into a directory under /opt.
301 # Move things to where they should be in an RPM setting (adapted from
302 # the original ZeroC srpm).
303 install -d $RPM_BUILD_ROOT%{_bindir}
304 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
305 install -d $RPM_BUILD_ROOT%{_includedir}
306 mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
307 install -d $RPM_BUILD_ROOT%{_libdir}
308 # There are a couple of files that end up installed in /lib, not %{_libdir},
309 # so we try this move too.
310 mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
311 mv $RPM_BUILD_ROOT/lib/* $RPM_BUILD_ROOT%{_libdir} || true
312 mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
313
314 # Copy the man pages into the correct directory
315 install -d $RPM_BUILD_ROOT%{_mandir}/man1
316 #cp -a $RPM_BUILD_DIR/Ice-3.3.0-man-pages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
317
318 # Fix the encoding and line-endings of all the IceGridAdmin documentation files
319 cd $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/IceGridAdmin
320 chmod a-x *
321 for f in *.js *.css; do
322         dos2unix $f
323 done
324 for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
325         iconv -f ISO88591 -t UTF8 $f -o $f.tmp
326         mv $f.tmp $f
327 done
328 cd -
329
330 %if %{with dotnet}
331 # .NET spec files (for csharp-devel) -- convert the paths
332 for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
333         sed -i -e "s#/lib/#%{_libdir}/#" $RPM_BUILD_ROOT%{_libdir}/pkgconfig/$f.pc
334         sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT%{_libdir}/pkgconfig/$f.pc
335         mv $RPM_BUILD_ROOT%{_bindir}/$f.xml $RPM_BUILD_ROOT%{_libdir}/mono/gac/$f/%{version}.*/
336 done
337 %endif
338
339 %if %{with python}
340 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
341 install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
342 mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
343 rm -f $RPM_BUILD_ROOT/python/IcePy.so*
344 mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
345 cp -a Ice-rpmbuild-%{version}/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
346 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
347 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
348 %py_postclean
349 %endif
350
351 %if %{with ruby}
352 %{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
353 install -d $RPM_BUILD_ROOT%{ruby_sitearchdir}
354 mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_sitearchdir}/IceRuby.so
355 rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
356 mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_sitearchdir}
357 %endif
358
359 %if %{with php}
360 # Put the PHP stuff into the right place
361 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
362 mv $RPM_BUILD_ROOT/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
363 mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
364 mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
365 %endif
366
367 mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
368 mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
369 # Somehow, some files under "slice" end up with executable permissions -- ??
370 find $RPM_BUILD_ROOT%{_datadir}/Ice -name "*.ice" | xargs chmod a-x
371
372 # Move the ImportKey.class file -- it'll be in %{_libdir} because of the moves earlier
373 mv $RPM_BUILD_ROOT%{_libdir}/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
374
375 # Move the license files into the documentation directory
376 mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
377 mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
378 # Copy in the other files too
379 cp CHANGES RELEASE_NOTES  $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %post   -p /sbin/ldconfig
385 %postun -p /sbin/ldconfig
386
387 %post php
388 %php_webserver_restart
389
390 %postun php
391 if [ "$1" = 0 ]; then
392         %php_webserver_restart
393 fi
394
395 %files
396 %defattr(644,root,root,755)
397 %attr(755,root,root) %{_bindir}/dumpdb
398 %attr(755,root,root) %{_bindir}/glacier2router
399 %attr(755,root,root) %{_bindir}/icebox
400 %attr(755,root,root) %{_bindir}/iceboxadmin
401 %attr(755,root,root) %{_bindir}/iceca
402 %attr(755,root,root) %{_bindir}/icegridadmin
403 %attr(755,root,root) %{_bindir}/icegridnode
404 %attr(755,root,root) %{_bindir}/icegridregistry
405 %attr(755,root,root) %{_bindir}/icepatch2calc
406 %attr(755,root,root) %{_bindir}/icepatch2client
407 %attr(755,root,root) %{_bindir}/icepatch2server
408 %attr(755,root,root) %{_bindir}/icestormadmin
409 %attr(755,root,root) %{_bindir}/icestormmigrate
410 %attr(755,root,root) %{_bindir}/transformdb
411 %attr(755,root,root) %{_bindir}/slice2html
412 %attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
413 %attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
414 %attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
415 %attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
416 %attr(755,root,root) %{_libdir}/libIce.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
418 %attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
420 %attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
422 %attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
423 %attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
424 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
425 %attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
426 %attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
427 %attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
428 %attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
429 %attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
430 %attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
431 %attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
432 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
433 %attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
434 %attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
435 %attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
436 %attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
437 %attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
438 %attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
439 %attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
440 %attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
441 %attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
442 %{_datadir}/Ice
443
444 # XXX gui
445 %attr(755,root,root) %{_bindir}/icegridgui
446 %{_desktopdir}/IceGridAdmin.desktop
447 %{_iconsdir}/hicolor/*/apps/icegrid.png
448
449 # XXX doc
450 %doc %{_docdir}/Ice-%{version}
451
452 %files devel
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_bindir}/slice2cpp
455 %attr(755,root,root) %{_bindir}/slice2freeze
456 %attr(755,root,root) %{_libdir}/libFreeze.so
457 %attr(755,root,root) %{_libdir}/libGlacier2.so
458 %attr(755,root,root) %{_libdir}/libIce.so
459 %attr(755,root,root) %{_libdir}/libIceBox.so
460 %attr(755,root,root) %{_libdir}/libIceDB.so
461 %attr(755,root,root) %{_libdir}/libIceGrid.so
462 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
463 %attr(755,root,root) %{_libdir}/libIcePatch2.so
464 %attr(755,root,root) %{_libdir}/libIceSSL.so
465 %attr(755,root,root) %{_libdir}/libIceStorm.so
466 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
467 %attr(755,root,root) %{_libdir}/libIceStormService.so
468 %attr(755,root,root) %{_libdir}/libIceUtil.so
469 %attr(755,root,root) %{_libdir}/libIceXML.so
470 %attr(755,root,root) %{_libdir}/libSlice.so
471 %{_includedir}/Freeze
472 %{_includedir}/Glacier2
473 %{_includedir}/Ice
474 %{_includedir}/IceBox
475 %{_includedir}/IceGrid
476 %{_includedir}/IcePatch2
477 %{_includedir}/IceSSL
478 %{_includedir}/IceStorm
479 %{_includedir}/IceUtil
480 %{_includedir}/IceXML
481 %{_includedir}/Slice
482
483 # these pkgconfig files are for csharp, but we do not have separate -devel for csharp
484 %{_pkgconfigdir}/Glacier2.pc
485 %{_pkgconfigdir}/Ice.pc
486 %{_pkgconfigdir}/IceBox.pc
487 %{_pkgconfigdir}/IceGrid.pc
488 %{_pkgconfigdir}/IcePatch2.pc
489 %{_pkgconfigdir}/IceStorm.pc
490
491
492 # as we do not have -devel for each binding, these are in main -devel
493 # -csharp
494 %attr(755,root,root) %{_bindir}/slice2cs
495 # -java
496 %attr(755,root,root) %{_bindir}/slice2freezej
497 %attr(755,root,root) %{_bindir}/slice2java
498 # -php
499 %attr(755,root,root) %{_bindir}/slice2php
500 # -python
501 %attr(755,root,root) %{_bindir}/slice2py
502 # -ruby
503 %attr(755,root,root) %{_bindir}/slice2rb
504
505 %files servers
506 %defattr(644,root,root,755)
507 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
508 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
509 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
510 %attr(754,root,root) /etc/rc.d/init.d/glacier2router
511 %attr(754,root,root) /etc/rc.d/init.d/icegridnode
512 %attr(754,root,root) /etc/rc.d/init.d/icegridregistry
513
514 %files csharp
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_bindir}/iceboxnet.exe
517 %{_libdir}/mono/Glacier2
518 %{_libdir}/mono/Ice
519 %{_libdir}/mono/IceBox
520 %{_libdir}/mono/IceGrid
521 %{_libdir}/mono/IcePatch2
522 %{_libdir}/mono/IceStorm
523 %{_libdir}/mono/gac/Glacier2
524 %{_libdir}/mono/gac/Ice
525 %{_libdir}/mono/gac/IceBox
526 %{_libdir}/mono/gac/IceGrid
527 %{_libdir}/mono/gac/IcePatch2
528 %{_libdir}/mono/gac/IceStorm
529
530 %files python
531 %defattr(644,root,root,755)
532 %{py_sitedir}/ice.pth
533 %dir %{py_sitedir}/Ice
534 %dir %{py_sitedir}/Ice/IceBox
535 %dir %{py_sitedir}/Ice/IceGrid
536 %dir %{py_sitedir}/Ice/IcePatch2
537 %dir %{py_sitedir}/Ice/IceStorm
538 %{py_sitedir}/Ice/*.py[co]
539 %{py_sitedir}/Ice/IceBox/*.py[co]
540 %{py_sitedir}/Ice/IceGrid/*.py[co]
541 %{py_sitedir}/Ice/IcePatch2/*.py[co]
542 %{py_sitedir}/Ice/IceStorm/*.py[co]
543 %attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
544
545 %files ruby
546 %defattr(644,root,root,755)
547 %{ruby_sitearchdir}/Glacier2.rb
548 %{ruby_sitearchdir}/Glacier2
549 %{ruby_sitearchdir}/Ice.rb
550 %{ruby_sitearchdir}/Ice
551 %{ruby_sitearchdir}/IceBox.rb
552 %{ruby_sitearchdir}/IceBox
553 %{ruby_sitearchdir}/IceGrid.rb
554 %{ruby_sitearchdir}/IceGrid
555 %{ruby_sitearchdir}/IcePatch2.rb
556 %{ruby_sitearchdir}/IcePatch2
557 %{ruby_sitearchdir}/IceStorm.rb
558 %{ruby_sitearchdir}/IceStorm/IceStorm.rb
559 %attr(755,root,root) %{ruby_sitearchdir}/IceRuby.so
560
561 %files java
562 %defattr(644,root,root,755)
563 %{_javadir}/Freeze-%{version}.jar
564 %{_javadir}/Freeze.jar
565 %{_javadir}/Ice-%{version}.jar
566 %{_javadir}/Ice.jar
567 %{_javadir}/ant-ice-%{version}.jar
568 %{_javadir}/ant-ice.jar
569
570 %files php
571 %defattr(644,root,root,755)
572 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
573 %attr(755,root,root) %{php_extensiondir}/IcePHP.so
574 %{php_data_dir}/Glacier2.php
575 %{php_data_dir}/Glacier2
576 %{php_data_dir}/Ice.php
577 %{php_data_dir}/Ice
578 %{php_data_dir}/IceBox.php
579 %{php_data_dir}/IceBox
580 %{php_data_dir}/IceGrid.php
581 %{php_data_dir}/IceGrid
582 %{php_data_dir}/IcePatch2.php
583 %{php_data_dir}/IcePatch2
584 %{php_data_dir}/IceStorm.php
585 %{php_data_dir}/IceStorm
This page took 0.067749 seconds and 4 git commands to generate.