]> git.pld-linux.org Git - packages/ice.git/blob - ice.spec
- instal ant task jar into ant directory
[packages/ice.git] / ice.spec
1 # TODO
2 # - finish (pldize) -servers package
3 #
4 # Conditional build:
5 %bcond_without  java            # Java bindings
6 %bcond_without  dotnet          # .NET bindings
7 %bcond_without  python          # Python bindings
8 %bcond_without  ruby            # Ruby bindings
9 %bcond_without  php                     # PHP bindings
10 %bcond_without  gui                     # IceGrid GUI
11
12 %if "%{pld_release}" == "ti"
13 %bcond_without  java_sun        # build with gcj
14 %else
15 %bcond_with     java_sun        # build with java-sun
16 %endif
17
18 %if %{without java}
19 %undefine       with_gui
20 %endif
21
22 %{?with_java:%include   /usr/lib/rpm/macros.java}
23 Summary:        The Ice base runtime and services
24 Name:           ice
25 Version:        3.4.0
26 Release:        0.6
27 License:        GPL v2 with exceptions (see ICE_LICENSE)
28 Group:          Applications
29 URL:            http://www.zeroc.com/
30 Source0:        http://www.zeroc.com/download/Ice/3.4/Ice-%{version}.tar.gz
31 # Source0-md5:  998b10627ade020cb00f5beb73efc0e0
32 # Extracted from http://zeroc.com/download/Ice/3.4/ice-3.4.0-1.src.rpm
33 Source1:        Ice-rpmbuild-%{version}.tar.gz
34 # Source1-md5:  869cc60645e7e2b4115584a5ab17d1e9
35 # Man pages courtesy of Francisco Moya's Debian packages
36 Source2:        Ice-3.3.0-man-pages.tbz2
37 # Source2-md5:  c6c17ee1be2e6b615af5b40edae88b75
38 Source3:        %{name}gridgui
39 Source4:        IceGridAdmin.desktop
40 Patch0:         %{name}-build.patch
41 Patch1:         dont-build-demo-test.patch
42 Patch2:         java-build.patch
43 Patch3:         jgoodies.patch
44 %{?with_gui:BuildRequires: ImageMagick}
45 BuildRequires:  db-cxx-devel
46 %if %{with java}
47 BuildRequires:  ant-nodeps
48 BuildRequires:  db-java-devel
49 %{!?with_java_sun:BuildRequires:        java-gcj-compat-devel}
50 BuildRequires:  java-jgoodies-forms
51 BuildRequires:  java-jgoodies-looks
52 %{?with_java_sun:BuildRequires: java-sun}
53 BuildRequires:  jpackage-utils
54 BuildRequires:  rpm >= 4.4.9-56
55 %endif
56 # It is not possible to %%include conditionally, so BR: rpm-javaprov always
57 BuildRequires:  rpm-javaprov
58 BuildRequires:  mcpp-devel
59 %{?with_php:BuildRequires:      php-devel >= 3:5.0.0}
60 %{?with_python:BuildRequires:   rpm-pythonprov}
61 BuildRequires:  rpmbuild(macros) >= 1.533
62 %{?with_ruby:BuildRequires:     ruby >= 1:1.8.6}
63 # Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
64 ExcludeArch:    ppc64 sparc64
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 # Some file suffixes we need to grab the right stuff for the file lists
68 %define         soversion       34
69
70 %description
71 Ice is a modern alternative to object middleware such as CORBA or
72 COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
73 infrastructure for demanding technical applications. It features an
74 object-oriented specification language, easy to use C++, C#, Java,
75 Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
76 protocol, asynchronous method invocation and dispatch, dynamic
77 transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
78 firewall solution, and much more.
79
80 %package devel
81 Summary:        Tools for developing Ice applications in C++
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84
85 %description devel
86 Tools for developing Ice applications in C++.
87
88 %package servers
89 Summary:        Ice services to run through /etc/rc.d/init.d
90 Group:          Development/Tools
91 Requires(post,preun):   /sbin/chkconfig
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       rc-scripts
94
95 %description servers
96 Ice services to run through /etc/rc.d/init.d
97
98 %package -n icegrid-gui
99 Summary:        IceGrid Admin Tool
100 Group:          Development/Tools
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       java-%{name} = %{version}-%{release}
103 Requires:       java-jgoodies-forms
104 Requires:       java-jgoodies-looks
105 Requires:       jpackage-utils
106
107 %description -n icegrid-gui
108 Graphical administration tool for IceGrid
109
110 %package -n java-%{name}
111 Summary:        The Ice runtime for Java
112 Group:          Libraries/Java
113 Requires:       %{name} = %{version}-%{release}
114 Requires:       db-java
115 Requires:       jpackage-utils
116
117 %description -n java-%{name}
118 The Ice runtime for Java
119
120 %package -n csharp-%{name}
121 Summary:        The Ice runtime for C#
122 Group:          Libraries
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       mono >= 1.2.2
125
126 %description -n csharp-%{name}
127 The Ice runtime for C#
128
129 %package -n ruby-%{name}
130 Summary:        The Ice runtime for Ruby applications
131 Group:          Development/Languages
132 Requires:       %{name} = %{version}-%{release}
133 %{?ruby_mod_ver_requires_eq}
134
135 %description -n ruby-%{name}
136 The Ice runtime for Ruby applications.
137
138 %package -n python-%{name}
139 Summary:        The Ice runtime for Python applications
140 Group:          Development/Languages/Python
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       python >= 1:2.3.4
143
144 %description -n python-%{name}
145 The Ice runtime for Python applications.
146
147 %package -n php-%{name}
148 Summary:        The Ice runtime for PHP applications
149 Group:          Development/Languages/PHP
150 Requires:       %{name} = %{version}-%{release}
151 %{?requires_php_extension}
152
153 %description -n php-%{name}
154 The Ice runtime for PHP applications.
155
156 %prep
157 %setup -q -n Ice-%{version} -a1 -a2
158 %patch0 -p0
159 %patch1 -p1
160 %patch2 -p1
161 %patch3 -p1
162
163 # no longer included in 3.4
164 rm -f *man-pages/slice2docbook.1
165
166 # Fix the encoding and line-endings of all the IceGridAdmin documentation files
167 cd java/resources/IceGridAdmin
168 %undos *.js *.css
169 for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
170         iconv -f ISO88591 -t UTF8 $f -o $f.tmp
171         mv $f.tmp $f
172 done
173 cd -
174
175 %if %{with java}
176 # we nuke it only when we build new class later, as ice build system expects the file being around
177 rm cpp/src/ca/ImportKey.class
178 %endif
179
180 # update path to our install
181 sed -i -e 's,/usr/share/Ice-%{version},%{_datadir}/Ice,' cpp/src/ca/iceca Ice-rpmbuild-%{version}/icegridregistry.conf
182
183 # force our CC/CXX as build system compares for exactly "c++" to setup other rules
184 sed -i -e 's,c++,%{__cxx},g' cpp/config/Make.rules.Linux
185
186 %build
187 # Compile the main Ice runtime
188 # TODO: CC/CXX passing as make param breaks build system
189
190 %if %{with java}
191 # Rebuild the Java ImportKey class - need it early for main cpp build
192 javac cpp/src/ca/ImportKey.java
193 %endif
194
195 %{__make} -C cpp \
196         CC="%{__cc}" \
197         CXX="%{__cxx}" \
198         CFLAGS="%{rpmcflags} -fPIC" \
199         CXXFLAGS="%{rpmcxxflags} -fPIC" \
200         embedded_runpath_prefix=""
201
202 %if %{with gui}
203 # Create the IceGrid icon
204 convert java/resources/icons/icegrid.ico temp.png
205 mv temp-8.png java/resources/icons/icegrid.png
206 rm temp*.png
207 %endif
208
209 %if %{with java}
210
211 # Set the CLASSPATH correctly for the Java compile
212 export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
213
214 %{__make} -C java \
215         CC="%{__cc}" \
216         CXX="%{__cxx}" \
217         CFLAGS="%{rpmcflags} -fPIC" \
218         CXXFLAGS="%{rpmcxxflags} -fPIC" \
219         embedded_runpath_prefix=""
220 %endif
221
222 %if %{with dotnet}
223 %{__make} -C cs \
224         CC="%{__cc}" \
225         CXX="%{__cxx}" \
226         CFLAGS="%{rpmcflags} -fPIC" \
227         CXXFLAGS="%{rpmcxxflags} -fPIC" \
228         embedded_runpath_prefix=""
229 %endif
230
231 %if %{with python}
232 %{__make} -C py \
233         CC="%{__cc}" \
234         CXX="%{__cxx}" \
235         CFLAGS="%{rpmcflags} -fPIC" \
236         CXXFLAGS="%{rpmcxxflags} -fPIC" \
237         embedded_runpath_prefix=""
238 %endif
239
240 %if %{with ruby}
241 %{__make} -C rb \
242         CC="%{__cc}" \
243         CXX="%{__cxx}" \
244         CFLAGS="%{rpmcflags} -fPIC" \
245         CXXFLAGS="%{rpmcxxflags} -fPIC" \
246         embedded_runpath_prefix=""
247 %endif
248
249 %if %{with php}
250 %{__make} -C php \
251         CC="%{__cc}" \
252         CXX="%{__cxx}" \
253         PHP_HOME=%{_prefix} \
254         CFLAGS="%{rpmcflags} -fPIC" \
255         CXXFLAGS="%{rpmcxxflags} -fPIC" \
256         embedded_runpath_prefix=""
257 %endif
258
259 %install
260 rm -rf $RPM_BUILD_ROOT
261 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_docdir}/Ice-%{version},%{_datadir}/Ice}
262
263 %{__make} -C cpp install \
264         prefix=$RPM_BUILD_ROOT
265
266 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
267 mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
268 mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
269 # Move the ImportKey.class file
270 mv $RPM_BUILD_ROOT/lib/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
271
272 mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
273
274 # Copy the man pages into the correct directory
275 install -d $RPM_BUILD_ROOT%{_mandir}/man1
276 cp -a *man-pages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
277
278 %if %{with java}
279 %{__make} -C java install \
280         prefix=$RPM_BUILD_ROOT
281
282 # Move Java stuff where it should be
283 install -d $RPM_BUILD_ROOT%{_javadir}
284 mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
285 ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
286 mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
287 ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
288
289 # Register ant target
290 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ant.d,%{_javadir}/ant}
291 mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice-%{version}.jar
292 ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice.jar
293 echo 'ice ant/ant-ice' > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ice
294 %endif
295
296 %if %{with gui}
297 # Install the IceGrid GUI
298 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
299 mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
300 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
301 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
302 cp -a java/resources/icons/icegrid.png $RPM_BUILD_ROOT%{_pixmapsdir}
303 mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
304 %endif
305
306 %if %{with dotnet}
307 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
308 %{__make} -C cs install \
309         prefix=$RPM_BUILD_ROOT \
310         GACINSTALL=yes \
311         GAC_ROOT=$RPM_BUILD_ROOT%{_libdir} \
312
313 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
314 # .NET spec files (for csharp-devel) -- convert the paths
315 for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
316         sed -i -e "s#/lib/#%{_libdir}/#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
317         sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
318         mv $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/$f.pc
319         mv $RPM_BUILD_ROOT%{_bindir}/$f.xml $RPM_BUILD_ROOT%{_libdir}/mono/gac/$f/%{version}.*/
320 done
321 %endif
322
323 %if %{with python}
324 %{__make} -C py install \
325         prefix=$RPM_BUILD_ROOT
326 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
327 install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
328 mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
329 rm -f $RPM_BUILD_ROOT/python/IcePy.so*
330 mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
331 cp -a Ice-rpmbuild-%{version}/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
332 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
333 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
334 %py_postclean
335 %endif
336
337 %if %{with ruby}
338 %{__make} -C rb install \
339         prefix=$RPM_BUILD_ROOT
340 %{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
341 install -d $RPM_BUILD_ROOT%{ruby_sitearchdir}
342 mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_sitearchdir}/IceRuby.so
343 rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
344 mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_sitearchdir}
345 %endif
346
347 %if %{with php}
348 %{__make} -C php install \
349         prefix=$RPM_BUILD_ROOT
350 # Put the PHP stuff into the right place
351 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
352 cp -a Ice-rpmbuild-%{version}/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
353 mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
354 mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
355 %endif
356
357 # move as last, bindings reinstall these if missing
358 mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
359
360 # Move the license files into the documentation directory
361 mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
362 mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
363 # Copy in the other files too
364 cp CHANGES RELEASE_NOTES  $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
365
366 # Install the servers
367 install -d $RPM_BUILD_ROOT%{_sysconfdir}
368 cp -a Ice-rpmbuild-%{version}/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
369 install -d $RPM_BUILD_ROOT%{_initrddir}
370 for i in icegridregistry icegridnode glacier2router; do
371         cp -a Ice-rpmbuild-%{version}/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
372 done
373 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
374
375 %clean
376 rm -rf $RPM_BUILD_ROOT
377
378 %post   -p /sbin/ldconfig
379 %postun -p /sbin/ldconfig
380
381 %post -n php-%{name}
382 %php_webserver_restart
383
384 %postun -n php-%{name}
385 if [ "$1" = 0 ]; then
386         %php_webserver_restart
387 fi
388
389 %files
390 %defattr(644,root,root,755)
391 %doc %{_docdir}/Ice-%{version}
392 %attr(755,root,root) %{_bindir}/dumpdb
393 %attr(755,root,root) %{_bindir}/glacier2router
394 %attr(755,root,root) %{_bindir}/icebox
395 %attr(755,root,root) %{_bindir}/iceboxadmin
396 %attr(755,root,root) %{_bindir}/iceca
397 %attr(755,root,root) %{_bindir}/icegridadmin
398 %attr(755,root,root) %{_bindir}/icegridnode
399 %attr(755,root,root) %{_bindir}/icegridregistry
400 %attr(755,root,root) %{_bindir}/icepatch2calc
401 %attr(755,root,root) %{_bindir}/icepatch2client
402 %attr(755,root,root) %{_bindir}/icepatch2server
403 %attr(755,root,root) %{_bindir}/icestormadmin
404 %attr(755,root,root) %{_bindir}/icestormmigrate
405 %attr(755,root,root) %{_bindir}/slice2html
406 %attr(755,root,root) %{_bindir}/transformdb
407 %{_mandir}/man1/dumpdb.1*
408 %{_mandir}/man1/glacier2router.1*
409 %{_mandir}/man1/icebox.1*
410 %{_mandir}/man1/iceboxadmin.1*
411 %{_mandir}/man1/icegridadmin.1*
412 %{_mandir}/man1/icegridnode.1*
413 %{_mandir}/man1/icegridregistry.1*
414 %{_mandir}/man1/icepatch2calc.1*
415 %{_mandir}/man1/icepatch2client.1*
416 %{_mandir}/man1/icepatch2server.1*
417 %{_mandir}/man1/icestormadmin.1*
418 %{_mandir}/man1/slice2html.1*
419 %{_mandir}/man1/transformdb.1*
420 %attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
422 %attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
423 %attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
424 %attr(755,root,root) %{_libdir}/libIce.so.*.*.*
425 %attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
426 %attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
427 %attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
428 %attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
429 %attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
430 %attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
431 %attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
432 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
433 %attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
434 %attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
435 %attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
436 %attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
437 %attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
438 %attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
439 %attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
440 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
441 %attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
442 %attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
443 %attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
444 %attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
445 %attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
446 %attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
447 %attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
448 %attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
449 %attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
450 %{_datadir}/Ice
451
452 %if %{with gui}
453 # Exclude the stuff that's in IceGrid
454 %exclude %{_docdir}/Ice-%{version}/IceGridAdmin
455 %exclude %{_datadir}/Ice/IceGridGUI.jar
456
457 %files -n icegrid-gui
458 %defattr(644,root,root,755)
459 %doc %{_docdir}/Ice-%{version}/IceGridAdmin
460 %attr(755,root,root) %{_bindir}/icegridgui
461 %{_datadir}/Ice/IceGridGUI.jar
462 %{_mandir}/man1/icegridgui.1*
463 %{_desktopdir}/IceGridAdmin.desktop
464 %{_pixmapsdir}/icegrid.png
465 %endif
466
467 %files devel
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_bindir}/slice2cpp
470 %attr(755,root,root) %{_bindir}/slice2freeze
471 %attr(755,root,root) %{_libdir}/libFreeze.so
472 %attr(755,root,root) %{_libdir}/libGlacier2.so
473 %attr(755,root,root) %{_libdir}/libIce.so
474 %attr(755,root,root) %{_libdir}/libIceBox.so
475 %attr(755,root,root) %{_libdir}/libIceDB.so
476 %attr(755,root,root) %{_libdir}/libIceGrid.so
477 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
478 %attr(755,root,root) %{_libdir}/libIcePatch2.so
479 %attr(755,root,root) %{_libdir}/libIceSSL.so
480 %attr(755,root,root) %{_libdir}/libIceStorm.so
481 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
482 %attr(755,root,root) %{_libdir}/libIceStormService.so
483 %attr(755,root,root) %{_libdir}/libIceUtil.so
484 %attr(755,root,root) %{_libdir}/libIceXML.so
485 %attr(755,root,root) %{_libdir}/libSlice.so
486 %{_includedir}/Freeze
487 %{_includedir}/Glacier2
488 %{_includedir}/Ice
489 %{_includedir}/IceBox
490 %{_includedir}/IceGrid
491 %{_includedir}/IcePatch2
492 %{_includedir}/IceSSL
493 %{_includedir}/IceStorm
494 %{_includedir}/IceUtil
495 %{_includedir}/IceXML
496 %{_includedir}/Slice
497 %{_mandir}/man1/slice2cpp.1*
498 %{_mandir}/man1/slice2freeze.1*
499 %if %{with java}
500 %{_sysconfdir}/ant.d/ant
501 %{_javadir}/ant/ant-ice-%{version}.jar
502 %{_javadir}/ant/ant-ice.jar
503 %endif
504
505 %if %{with dotnet}
506 %{_pkgconfigdir}/Glacier2.pc
507 %{_pkgconfigdir}/Ice.pc
508 %{_pkgconfigdir}/IceBox.pc
509 %{_pkgconfigdir}/IceGrid.pc
510 %{_pkgconfigdir}/IcePatch2.pc
511 %{_pkgconfigdir}/IceStorm.pc
512 %endif
513
514 # as we do not have -devel for each binding, these are in main -devel
515 # -csharp
516 %attr(755,root,root) %{_bindir}/slice2cs
517 %{_mandir}/man1/slice2cs.1*
518 # -java
519 %attr(755,root,root) %{_bindir}/slice2freezej
520 %attr(755,root,root) %{_bindir}/slice2java
521 %{_mandir}/man1/slice2freezej.1*
522 %{_mandir}/man1/slice2java.1*
523 # -php
524 %attr(755,root,root) %{_bindir}/slice2php
525 # -python
526 %attr(755,root,root) %{_bindir}/slice2py
527 %{_mandir}/man1/slice2py.1*
528 # -ruby
529 %attr(755,root,root) %{_bindir}/slice2rb
530 %{_mandir}/man1/slice2rb.1*
531
532 %files servers
533 %defattr(644,root,root,755)
534 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
535 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
536 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
537 %attr(754,root,root) /etc/rc.d/init.d/glacier2router
538 %attr(754,root,root) /etc/rc.d/init.d/icegridnode
539 %attr(754,root,root) /etc/rc.d/init.d/icegridregistry
540
541 %if %{with dotnet}
542 %files -n csharp-%{name}
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_bindir}/iceboxnet.exe
545 %{_mandir}/man1/iceboxnet.exe.1*
546 %{_libdir}/mono/Glacier2
547 %{_libdir}/mono/Ice
548 %{_libdir}/mono/IceBox
549 %{_libdir}/mono/IceGrid
550 %{_libdir}/mono/IcePatch2
551 %{_libdir}/mono/IceStorm
552 %{_libdir}/mono/gac/Glacier2
553 %{_libdir}/mono/gac/Ice
554 %{_libdir}/mono/gac/IceBox
555 %{_libdir}/mono/gac/IceGrid
556 %{_libdir}/mono/gac/IcePatch2
557 %{_libdir}/mono/gac/IceStorm
558 %endif
559
560 %if %{with python}
561 %files -n python-%{name}
562 %defattr(644,root,root,755)
563 %{py_sitedir}/ice.pth
564 %dir %{py_sitedir}/Ice
565 %dir %{py_sitedir}/Ice/IceBox
566 %dir %{py_sitedir}/Ice/IceGrid
567 %dir %{py_sitedir}/Ice/IcePatch2
568 %dir %{py_sitedir}/Ice/IceStorm
569 %{py_sitedir}/Ice/*.py[co]
570 %{py_sitedir}/Ice/IceBox/*.py[co]
571 %{py_sitedir}/Ice/IceGrid/*.py[co]
572 %{py_sitedir}/Ice/IcePatch2/*.py[co]
573 %{py_sitedir}/Ice/IceStorm/*.py[co]
574 %attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
575 %endif
576
577 %if %{with ruby}
578 %files -n ruby-%{name}
579 %defattr(644,root,root,755)
580 %{ruby_sitearchdir}/Glacier2.rb
581 %{ruby_sitearchdir}/Glacier2
582 %{ruby_sitearchdir}/Ice.rb
583 %{ruby_sitearchdir}/Ice
584 %{ruby_sitearchdir}/IceBox.rb
585 %{ruby_sitearchdir}/IceBox
586 %{ruby_sitearchdir}/IceGrid.rb
587 %{ruby_sitearchdir}/IceGrid
588 %{ruby_sitearchdir}/IcePatch2.rb
589 %{ruby_sitearchdir}/IcePatch2
590 %{ruby_sitearchdir}/IceStorm.rb
591 %{ruby_sitearchdir}/IceStorm/IceStorm.rb
592 %attr(755,root,root) %{ruby_sitearchdir}/IceRuby.so
593 %endif
594
595 %if %{with java}
596 %files -n java-%{name}
597 %defattr(644,root,root,755)
598 %{_javadir}/Freeze-%{version}.jar
599 %{_javadir}/Freeze.jar
600 %{_javadir}/Ice-%{version}.jar
601 %{_javadir}/Ice.jar
602 %endif
603
604 %if %{with php}
605 %files -n php-%{name}
606 %defattr(644,root,root,755)
607 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
608 %attr(755,root,root) %{php_extensiondir}/IcePHP.so
609 %{php_data_dir}/Glacier2.php
610 %{php_data_dir}/Glacier2
611 %{php_data_dir}/Ice.php
612 %{php_data_dir}/Ice
613 %{php_data_dir}/IceBox.php
614 %{php_data_dir}/IceBox
615 %{php_data_dir}/IceGrid.php
616 %{php_data_dir}/IceGrid
617 %{php_data_dir}/IcePatch2.php
618 %{php_data_dir}/IcePatch2
619 %{php_data_dir}/IceStorm.php
620 %{php_data_dir}/IceStorm
621 %endif
This page took 0.08074 seconds and 4 git commands to generate.