]> git.pld-linux.org Git - packages/ice.git/blob - ice.spec
- move ImportKey.class earlier, more shebang fixes
[packages/ice.git] / ice.spec
1 # TODO
2 # - finish (pldize) -servers package
3 #
4 # Conditional build:
5 %bcond_without  java            # Java bindings
6 %bcond_without  dotnet          # .NET bindings
7 %bcond_without  python          # Python bindings
8 %bcond_without  ruby            # Ruby bindings
9 %bcond_without  php                     # PHP bindings
10 %bcond_without  gui                     # IceGrid GUI
11
12 %if "%{pld_release}" == "ti"
13 %bcond_without  java_sun        # build with gcj
14 %else
15 %bcond_with     java_sun        # build with java-sun
16 %endif
17
18 %if %{without java}
19 %undefine       with_gui
20 %endif
21
22 %{?with_java:%include   /usr/lib/rpm/macros.java}
23 Summary:        The Ice base runtime and services
24 Name:           ice
25 Version:        3.4.0
26 Release:        0.6
27 License:        GPL v2 with exceptions (see ICE_LICENSE)
28 Group:          Applications
29 URL:            http://www.zeroc.com/
30 Source0:        http://www.zeroc.com/download/Ice/3.4/Ice-%{version}.tar.gz
31 # Source0-md5:  998b10627ade020cb00f5beb73efc0e0
32 # Extracted from http://zeroc.com/download/Ice/3.4/ice-3.4.0-1.src.rpm
33 Source1:        Ice-rpmbuild-%{version}.tar.gz
34 # Source1-md5:  869cc60645e7e2b4115584a5ab17d1e9
35 # Man pages courtesy of Francisco Moya's Debian packages
36 Source2:        Ice-3.3.0-man-pages.tbz2
37 # Source2-md5:  c6c17ee1be2e6b615af5b40edae88b75
38 Source3:        %{name}gridgui
39 Source4:        IceGridAdmin.desktop
40 Patch0:         %{name}-build.patch
41 Patch1:         dont-build-demo-test.patch
42 Patch2:         java-build.patch
43 Patch3:         jgoodies.patch
44 %{?with_gui:BuildRequires: ImageMagick}
45 BuildRequires:  db-cxx-devel
46 %if %{with java}
47 BuildRequires:  ant-nodeps
48 BuildRequires:  db-java-devel
49 %{!?with_java_sun:BuildRequires:        java-gcj-compat-devel}
50 BuildRequires:  java-jgoodies-forms
51 BuildRequires:  java-jgoodies-looks
52 %{?with_java_sun:BuildRequires: java-sun}
53 BuildRequires:  jpackage-utils
54 BuildRequires:  rpm >= 4.4.9-56
55 BuildRequires:  rpm-javaprov
56 %endif
57 BuildRequires:  mcpp-devel
58 %{?with_php:BuildRequires:      php-devel >= 3:5.0.0}
59 %{?with_python:BuildRequires:   rpm-pythonprov}
60 BuildRequires:  rpmbuild(macros) >= 1.533
61 %{?with_ruby:BuildRequires:     ruby >= 1:1.8.6}
62 # Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
63 ExcludeArch:    ppc64 sparc64
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 # Some file suffixes we need to grab the right stuff for the file lists
67 %define         soversion       34
68
69 %description
70 Ice is a modern alternative to object middleware such as CORBA or
71 COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
72 infrastructure for demanding technical applications. It features an
73 object-oriented specification language, easy to use C++, C#, Java,
74 Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
75 protocol, asynchronous method invocation and dispatch, dynamic
76 transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
77 firewall solution, and much more.
78
79 %package devel
80 Summary:        Tools for developing Ice applications in C++
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83
84 %description devel
85 Tools for developing Ice applications in C++.
86
87 %package servers
88 Summary:        Ice services to run through /etc/rc.d/init.d
89 Group:          Development/Tools
90 Requires(post,preun):   /sbin/chkconfig
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       rc-scripts
93
94 %description servers
95 Ice services to run through /etc/rc.d/init.d
96
97 %package -n icegrid-gui
98 Summary:        IceGrid Admin Tool
99 Group:          Development/Tools
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       java-%{name} = %{version}-%{release}
102 Requires:       java-jgoodies-forms
103 Requires:       java-jgoodies-looks
104 Requires:       jpackage-utils
105
106 %description -n icegrid-gui
107 Graphical administration tool for IceGrid
108
109 %package -n java-%{name}
110 Summary:        The Ice runtime for Java
111 Group:          Libraries/Java
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       db-java
114 Requires:       jpackage-utils
115
116 %description -n java-%{name}
117 The Ice runtime for Java
118
119 %package -n csharp-%{name}
120 Summary:        The Ice runtime for C#
121 Group:          Libraries
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       mono >= 1.2.2
124
125 %description -n csharp-%{name}
126 The Ice runtime for C#
127
128 %package -n ruby-%{name}
129 Summary:        The Ice runtime for Ruby applications
130 Group:          Development/Languages
131 Requires:       %{name} = %{version}-%{release}
132 %{?ruby_mod_ver_requires_eq}
133
134 %description -n ruby-%{name}
135 The Ice runtime for Ruby applications.
136
137 %package -n python-%{name}
138 Summary:        The Ice runtime for Python applications
139 Group:          Development/Languages/Python
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       python >= 1:2.3.4
142
143 %description -n python-%{name}
144 The Ice runtime for Python applications.
145
146 %package -n php-%{name}
147 Summary:        The Ice runtime for PHP applications
148 Group:          Development/Languages/PHP
149 Requires:       %{name} = %{version}-%{release}
150 %{?requires_php_extension}
151
152 %description -n php-%{name}
153 The Ice runtime for PHP applications.
154
155 %prep
156 %setup -q -n Ice-%{version} -a1 -a2
157 %patch0 -p0
158 %patch1 -p1
159 %patch2 -p1
160 %patch3 -p1
161
162 # no longer included in 3.4
163 rm -f *man-pages/slice2docbook.1
164
165 # Fix the encoding and line-endings of all the IceGridAdmin documentation files
166 cd java/resources/IceGridAdmin
167 %undos *.js *.css
168 for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
169         iconv -f ISO88591 -t UTF8 $f -o $f.tmp
170         mv $f.tmp $f
171 done
172 cd -
173
174 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' cpp/src/ca/iceca
175
176 %if %{with java}
177 # we nuke it only when we build new class later, as ice build system expects the file being around
178 rm cpp/src/ca/ImportKey.class
179 %endif
180
181 # update path to our install
182 sed -i -e 's,/usr/share/Ice-%{version},%{_datadir}/Ice,' cpp/src/ca/iceca Ice-rpmbuild-%{version}/icegridregistry.conf
183
184 # force our CC/CXX as build system compares for exactly "c++" to setup other rules
185 sed -i -e 's,c++,%{__cxx},g' cpp/config/Make.rules.Linux
186
187 %build
188 # Compile the main Ice runtime
189 # TODO: CC/CXX passing as make param breaks build system
190
191 %if %{with java}
192 # Rebuild the Java ImportKey class - need it early for main cpp build
193 javac cpp/src/ca/ImportKey.java
194 %endif
195
196 %{__make} -C cpp \
197         CC="%{__cc}" \
198         CXX="%{__cxx}" \
199         CFLAGS="%{rpmcflags} -fPIC" \
200         CXXFLAGS="%{rpmcxxflags} -fPIC" \
201         embedded_runpath_prefix=""
202
203 %if %{with gui}
204 # Create the IceGrid icon
205 convert java/resources/icons/icegrid.ico temp.png
206 mv temp-8.png java/resources/icons/icegrid.png
207 rm temp*.png
208 %endif
209
210 %if %{with java}
211
212 # Set the CLASSPATH correctly for the Java compile
213 export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
214
215 %{__make} -C java \
216         CC="%{__cc}" \
217         CXX="%{__cxx}" \
218         CFLAGS="%{rpmcflags} -fPIC" \
219         CXXFLAGS="%{rpmcxxflags} -fPIC" \
220         embedded_runpath_prefix=""
221 %endif
222
223 %if %{with dotnet}
224 %{__make} -C cs \
225         CC="%{__cc}" \
226         CXX="%{__cxx}" \
227         CFLAGS="%{rpmcflags} -fPIC" \
228         CXXFLAGS="%{rpmcxxflags} -fPIC" \
229         embedded_runpath_prefix=""
230 %endif
231
232 %if %{with python}
233 %{__make} -C py \
234         CC="%{__cc}" \
235         CXX="%{__cxx}" \
236         CFLAGS="%{rpmcflags} -fPIC" \
237         CXXFLAGS="%{rpmcxxflags} -fPIC" \
238         embedded_runpath_prefix=""
239 %endif
240
241 %if %{with ruby}
242 %{__make} -C rb \
243         CC="%{__cc}" \
244         CXX="%{__cxx}" \
245         CFLAGS="%{rpmcflags} -fPIC" \
246         CXXFLAGS="%{rpmcxxflags} -fPIC" \
247         embedded_runpath_prefix=""
248 %endif
249
250 %if %{with php}
251 %{__make} -C php \
252         CC="%{__cc}" \
253         CXX="%{__cxx}" \
254         PHP_HOME=%{_prefix} \
255         CFLAGS="%{rpmcflags} -fPIC" \
256         CXXFLAGS="%{rpmcxxflags} -fPIC" \
257         embedded_runpath_prefix=""
258 %endif
259
260 %install
261 rm -rf $RPM_BUILD_ROOT
262 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_docdir}/Ice-%{version},%{_datadir}/Ice}
263
264 %{__make} -C cpp install \
265         prefix=$RPM_BUILD_ROOT
266
267 # Move the ImportKey.class file
268 mv $RPM_BUILD_ROOT/lib/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
269
270 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
271 mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
272 mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
273
274 mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
275
276 # Copy the man pages into the correct directory
277 install -d $RPM_BUILD_ROOT%{_mandir}/man1
278 cp -a *man-pages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
279
280 %if %{with java}
281 %{__make} -C java install \
282         prefix=$RPM_BUILD_ROOT
283
284 # Move Java stuff where it should be
285 install -d $RPM_BUILD_ROOT%{_javadir}
286 mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
287 ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
288 mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
289 ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
290
291 # Register ant target
292 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ant.d,%{_javadir}/ant}
293 mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice-%{version}.jar
294 ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice.jar
295 echo 'ice ant/ant-ice' > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ice
296 %endif
297
298 %if %{with gui}
299 # Install the IceGrid GUI
300 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
301 mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
302 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
303 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
304 cp -a java/resources/icons/icegrid.png $RPM_BUILD_ROOT%{_pixmapsdir}
305 mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
306 %endif
307
308 %if %{with dotnet}
309 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
310 %{__make} -C cs install \
311         prefix=$RPM_BUILD_ROOT \
312         GACINSTALL=yes \
313         GAC_ROOT=$RPM_BUILD_ROOT%{_libdir} \
314
315 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
316 # .NET spec files (for csharp-devel) -- convert the paths
317 for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
318         sed -i -e "s#/lib/#%{_libdir}/#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
319         sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
320         mv $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/$f.pc
321         mv $RPM_BUILD_ROOT%{_bindir}/$f.xml $RPM_BUILD_ROOT%{_libdir}/mono/gac/$f/%{version}.*/
322 done
323 %endif
324
325 %if %{with python}
326 %{__make} -C py install \
327         prefix=$RPM_BUILD_ROOT
328 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
329 install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
330 mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
331 rm -f $RPM_BUILD_ROOT/python/IcePy.so*
332 mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
333 cp -a Ice-rpmbuild-%{version}/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
334 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
335 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
336 %py_postclean
337 %endif
338
339 %if %{with ruby}
340 %{__make} -C rb install \
341         prefix=$RPM_BUILD_ROOT
342 %{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
343 install -d $RPM_BUILD_ROOT%{ruby_sitearchdir}
344 mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_sitearchdir}/IceRuby.so
345 rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
346 mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_sitearchdir}
347 %endif
348
349 %if %{with php}
350 %{__make} -C php install \
351         prefix=$RPM_BUILD_ROOT
352 # Put the PHP stuff into the right place
353 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
354 cp -a Ice-rpmbuild-%{version}/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
355 mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
356 mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
357 %endif
358
359 # move as last, bindings reinstall these if missing
360 mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
361
362 # Move the license files into the documentation directory
363 mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
364 mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
365 # Copy in the other files too
366 cp CHANGES RELEASE_NOTES  $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
367
368 # Install the servers
369 install -d $RPM_BUILD_ROOT%{_sysconfdir}
370 cp -a Ice-rpmbuild-%{version}/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
371 install -d $RPM_BUILD_ROOT%{_initrddir}
372 for i in icegridregistry icegridnode glacier2router; do
373         cp -a Ice-rpmbuild-%{version}/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
374 done
375 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
376
377 %clean
378 rm -rf $RPM_BUILD_ROOT
379
380 %post   -p /sbin/ldconfig
381 %postun -p /sbin/ldconfig
382
383 %post -n php-%{name}
384 %php_webserver_restart
385
386 %postun -n php-%{name}
387 if [ "$1" = 0 ]; then
388         %php_webserver_restart
389 fi
390
391 %files
392 %defattr(644,root,root,755)
393 %doc %{_docdir}/Ice-%{version}
394 %attr(755,root,root) %{_bindir}/dumpdb
395 %attr(755,root,root) %{_bindir}/glacier2router
396 %attr(755,root,root) %{_bindir}/icebox
397 %attr(755,root,root) %{_bindir}/iceboxadmin
398 %attr(755,root,root) %{_bindir}/iceca
399 %attr(755,root,root) %{_bindir}/icegridadmin
400 %attr(755,root,root) %{_bindir}/icegridnode
401 %attr(755,root,root) %{_bindir}/icegridregistry
402 %attr(755,root,root) %{_bindir}/icepatch2calc
403 %attr(755,root,root) %{_bindir}/icepatch2client
404 %attr(755,root,root) %{_bindir}/icepatch2server
405 %attr(755,root,root) %{_bindir}/icestormadmin
406 %attr(755,root,root) %{_bindir}/icestormmigrate
407 %attr(755,root,root) %{_bindir}/slice2html
408 %attr(755,root,root) %{_bindir}/transformdb
409 %{_mandir}/man1/dumpdb.1*
410 %{_mandir}/man1/glacier2router.1*
411 %{_mandir}/man1/icebox.1*
412 %{_mandir}/man1/iceboxadmin.1*
413 %{_mandir}/man1/icegridadmin.1*
414 %{_mandir}/man1/icegridnode.1*
415 %{_mandir}/man1/icegridregistry.1*
416 %{_mandir}/man1/icepatch2calc.1*
417 %{_mandir}/man1/icepatch2client.1*
418 %{_mandir}/man1/icepatch2server.1*
419 %{_mandir}/man1/icestormadmin.1*
420 %{_mandir}/man1/slice2html.1*
421 %{_mandir}/man1/transformdb.1*
422 %attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
423 %attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
424 %attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
425 %attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
426 %attr(755,root,root) %{_libdir}/libIce.so.*.*.*
427 %attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
428 %attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
429 %attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
430 %attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
431 %attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
432 %attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
433 %attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
434 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
435 %attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
436 %attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
437 %attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
438 %attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
439 %attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
440 %attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
441 %attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
442 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
443 %attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
444 %attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
445 %attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
446 %attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
447 %attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
448 %attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
449 %attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
450 %attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
451 %attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
452 %{_datadir}/Ice
453
454 %if %{with gui}
455 # Exclude the stuff that's in IceGrid
456 %exclude %{_docdir}/Ice-%{version}/IceGridAdmin
457 %exclude %{_datadir}/Ice/IceGridGUI.jar
458
459 %files -n icegrid-gui
460 %defattr(644,root,root,755)
461 %doc %{_docdir}/Ice-%{version}/IceGridAdmin
462 %attr(755,root,root) %{_bindir}/icegridgui
463 %{_datadir}/Ice/IceGridGUI.jar
464 %{_mandir}/man1/icegridgui.1*
465 %{_desktopdir}/IceGridAdmin.desktop
466 %{_pixmapsdir}/icegrid.png
467 %endif
468
469 %files devel
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_bindir}/slice2cpp
472 %attr(755,root,root) %{_bindir}/slice2freeze
473 %attr(755,root,root) %{_libdir}/libFreeze.so
474 %attr(755,root,root) %{_libdir}/libGlacier2.so
475 %attr(755,root,root) %{_libdir}/libIce.so
476 %attr(755,root,root) %{_libdir}/libIceBox.so
477 %attr(755,root,root) %{_libdir}/libIceDB.so
478 %attr(755,root,root) %{_libdir}/libIceGrid.so
479 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
480 %attr(755,root,root) %{_libdir}/libIcePatch2.so
481 %attr(755,root,root) %{_libdir}/libIceSSL.so
482 %attr(755,root,root) %{_libdir}/libIceStorm.so
483 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
484 %attr(755,root,root) %{_libdir}/libIceStormService.so
485 %attr(755,root,root) %{_libdir}/libIceUtil.so
486 %attr(755,root,root) %{_libdir}/libIceXML.so
487 %attr(755,root,root) %{_libdir}/libSlice.so
488 %{_includedir}/Freeze
489 %{_includedir}/Glacier2
490 %{_includedir}/Ice
491 %{_includedir}/IceBox
492 %{_includedir}/IceGrid
493 %{_includedir}/IcePatch2
494 %{_includedir}/IceSSL
495 %{_includedir}/IceStorm
496 %{_includedir}/IceUtil
497 %{_includedir}/IceXML
498 %{_includedir}/Slice
499 %{_mandir}/man1/slice2cpp.1*
500 %{_mandir}/man1/slice2freeze.1*
501 %if %{with java}
502 %{_sysconfdir}/ant.d/ice
503 %{_javadir}/ant/ant-ice-%{version}.jar
504 %{_javadir}/ant/ant-ice.jar
505 %endif
506
507 %if %{with dotnet}
508 %{_pkgconfigdir}/Glacier2.pc
509 %{_pkgconfigdir}/Ice.pc
510 %{_pkgconfigdir}/IceBox.pc
511 %{_pkgconfigdir}/IceGrid.pc
512 %{_pkgconfigdir}/IcePatch2.pc
513 %{_pkgconfigdir}/IceStorm.pc
514 %endif
515
516 # as we do not have -devel for each binding, these are in main -devel
517 # -csharp
518 %attr(755,root,root) %{_bindir}/slice2cs
519 %{_mandir}/man1/slice2cs.1*
520 # -java
521 %attr(755,root,root) %{_bindir}/slice2freezej
522 %attr(755,root,root) %{_bindir}/slice2java
523 %{_mandir}/man1/slice2freezej.1*
524 %{_mandir}/man1/slice2java.1*
525 # -php
526 %attr(755,root,root) %{_bindir}/slice2php
527 # -python
528 %attr(755,root,root) %{_bindir}/slice2py
529 %{_mandir}/man1/slice2py.1*
530 # -ruby
531 %attr(755,root,root) %{_bindir}/slice2rb
532 %{_mandir}/man1/slice2rb.1*
533
534 %files servers
535 %defattr(644,root,root,755)
536 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
537 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
538 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
539 %attr(754,root,root) /etc/rc.d/init.d/glacier2router
540 %attr(754,root,root) /etc/rc.d/init.d/icegridnode
541 %attr(754,root,root) /etc/rc.d/init.d/icegridregistry
542
543 %if %{with dotnet}
544 %files -n csharp-%{name}
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_bindir}/iceboxnet.exe
547 %{_mandir}/man1/iceboxnet.exe.1*
548 %{_libdir}/mono/Glacier2
549 %{_libdir}/mono/Ice
550 %{_libdir}/mono/IceBox
551 %{_libdir}/mono/IceGrid
552 %{_libdir}/mono/IcePatch2
553 %{_libdir}/mono/IceStorm
554 %{_libdir}/mono/gac/Glacier2
555 %{_libdir}/mono/gac/Ice
556 %{_libdir}/mono/gac/IceBox
557 %{_libdir}/mono/gac/IceGrid
558 %{_libdir}/mono/gac/IcePatch2
559 %{_libdir}/mono/gac/IceStorm
560 %endif
561
562 %if %{with python}
563 %files -n python-%{name}
564 %defattr(644,root,root,755)
565 %{py_sitedir}/ice.pth
566 %dir %{py_sitedir}/Ice
567 %dir %{py_sitedir}/Ice/IceBox
568 %dir %{py_sitedir}/Ice/IceGrid
569 %dir %{py_sitedir}/Ice/IcePatch2
570 %dir %{py_sitedir}/Ice/IceStorm
571 %{py_sitedir}/Ice/*.py[co]
572 %{py_sitedir}/Ice/IceBox/*.py[co]
573 %{py_sitedir}/Ice/IceGrid/*.py[co]
574 %{py_sitedir}/Ice/IcePatch2/*.py[co]
575 %{py_sitedir}/Ice/IceStorm/*.py[co]
576 %attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
577 %endif
578
579 %if %{with ruby}
580 %files -n ruby-%{name}
581 %defattr(644,root,root,755)
582 %{ruby_sitearchdir}/Glacier2.rb
583 %{ruby_sitearchdir}/Glacier2
584 %{ruby_sitearchdir}/Ice.rb
585 %{ruby_sitearchdir}/Ice
586 %{ruby_sitearchdir}/IceBox.rb
587 %{ruby_sitearchdir}/IceBox
588 %{ruby_sitearchdir}/IceGrid.rb
589 %{ruby_sitearchdir}/IceGrid
590 %{ruby_sitearchdir}/IcePatch2.rb
591 %{ruby_sitearchdir}/IcePatch2
592 %{ruby_sitearchdir}/IceStorm.rb
593 %{ruby_sitearchdir}/IceStorm/IceStorm.rb
594 %attr(755,root,root) %{ruby_sitearchdir}/IceRuby.so
595 %endif
596
597 %if %{with java}
598 %files -n java-%{name}
599 %defattr(644,root,root,755)
600 %{_javadir}/Freeze-%{version}.jar
601 %{_javadir}/Freeze.jar
602 %{_javadir}/Ice-%{version}.jar
603 %{_javadir}/Ice.jar
604 %endif
605
606 %if %{with php}
607 %files -n php-%{name}
608 %defattr(644,root,root,755)
609 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
610 %attr(755,root,root) %{php_extensiondir}/IcePHP.so
611 %{php_data_dir}/Glacier2.php
612 %{php_data_dir}/Glacier2
613 %{php_data_dir}/Ice.php
614 %{php_data_dir}/Ice
615 %{php_data_dir}/IceBox.php
616 %{php_data_dir}/IceBox
617 %{php_data_dir}/IceGrid.php
618 %{php_data_dir}/IceGrid
619 %{php_data_dir}/IcePatch2.php
620 %{php_data_dir}/IcePatch2
621 %{php_data_dir}/IceStorm.php
622 %{php_data_dir}/IceStorm
623 %endif
This page took 0.069714 seconds and 4 git commands to generate.