]> git.pld-linux.org Git - packages/ice.git/blob - ice.spec
- BR rpm-javaprov conditionally
[packages/ice.git] / ice.spec
1 # TODO
2 # - finish (pldize) -servers package
3 #
4 # Conditional build:
5 %bcond_without  java            # Java bindings
6 %bcond_without  dotnet          # .NET bindings
7 %bcond_without  python          # Python bindings
8 %bcond_without  ruby            # Ruby bindings
9 %bcond_without  php                     # PHP bindings
10 %bcond_without  gui                     # IceGrid GUI
11
12 %if "%{pld_release}" == "ti"
13 %bcond_without  java_sun        # build with gcj
14 %else
15 %bcond_with     java_sun        # build with java-sun
16 %endif
17
18 %if %{without java}
19 %undefine       with_gui
20 %endif
21
22 %{?with_java:%include   /usr/lib/rpm/macros.java}
23 Summary:        The Ice base runtime and services
24 Name:           ice
25 Version:        3.4.0
26 Release:        0.6
27 License:        GPL v2 with exceptions (see ICE_LICENSE)
28 Group:          Applications
29 URL:            http://www.zeroc.com/
30 Source0:        http://www.zeroc.com/download/Ice/3.4/Ice-%{version}.tar.gz
31 # Source0-md5:  998b10627ade020cb00f5beb73efc0e0
32 # Extracted from http://zeroc.com/download/Ice/3.4/ice-3.4.0-1.src.rpm
33 Source1:        Ice-rpmbuild-%{version}.tar.gz
34 # Source1-md5:  869cc60645e7e2b4115584a5ab17d1e9
35 # Man pages courtesy of Francisco Moya's Debian packages
36 Source2:        Ice-3.3.0-man-pages.tbz2
37 # Source2-md5:  c6c17ee1be2e6b615af5b40edae88b75
38 Source3:        %{name}gridgui
39 Source4:        IceGridAdmin.desktop
40 Patch0:         %{name}-build.patch
41 Patch1:         dont-build-demo-test.patch
42 Patch2:         java-build.patch
43 Patch3:         jgoodies.patch
44 %{?with_gui:BuildRequires: ImageMagick}
45 BuildRequires:  db-cxx-devel
46 %if %{with java}
47 BuildRequires:  ant-nodeps
48 BuildRequires:  db-java-devel
49 %{!?with_java_sun:BuildRequires:        java-gcj-compat-devel}
50 BuildRequires:  java-jgoodies-forms
51 BuildRequires:  java-jgoodies-looks
52 %{?with_java_sun:BuildRequires: java-sun}
53 BuildRequires:  jpackage-utils
54 BuildRequires:  rpm >= 4.4.9-56
55 BuildRequires:  rpm-javaprov
56 %endif
57 BuildRequires:  mcpp-devel
58 %{?with_php:BuildRequires:      php-devel >= 3:5.0.0}
59 %{?with_python:BuildRequires:   rpm-pythonprov}
60 BuildRequires:  rpmbuild(macros) >= 1.533
61 %{?with_ruby:BuildRequires:     ruby >= 1:1.8.6}
62 # Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
63 ExcludeArch:    ppc64 sparc64
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 # Some file suffixes we need to grab the right stuff for the file lists
67 %define         soversion       34
68
69 %description
70 Ice is a modern alternative to object middleware such as CORBA or
71 COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
72 infrastructure for demanding technical applications. It features an
73 object-oriented specification language, easy to use C++, C#, Java,
74 Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
75 protocol, asynchronous method invocation and dispatch, dynamic
76 transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
77 firewall solution, and much more.
78
79 %package devel
80 Summary:        Tools for developing Ice applications in C++
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83
84 %description devel
85 Tools for developing Ice applications in C++.
86
87 %package servers
88 Summary:        Ice services to run through /etc/rc.d/init.d
89 Group:          Development/Tools
90 Requires(post,preun):   /sbin/chkconfig
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       rc-scripts
93
94 %description servers
95 Ice services to run through /etc/rc.d/init.d
96
97 %package -n icegrid-gui
98 Summary:        IceGrid Admin Tool
99 Group:          Development/Tools
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       java-%{name} = %{version}-%{release}
102 Requires:       java-jgoodies-forms
103 Requires:       java-jgoodies-looks
104 Requires:       jpackage-utils
105
106 %description -n icegrid-gui
107 Graphical administration tool for IceGrid
108
109 %package -n java-%{name}
110 Summary:        The Ice runtime for Java
111 Group:          Libraries/Java
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       db-java
114 Requires:       jpackage-utils
115
116 %description -n java-%{name}
117 The Ice runtime for Java
118
119 %package -n csharp-%{name}
120 Summary:        The Ice runtime for C#
121 Group:          Libraries
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       mono >= 1.2.2
124
125 %description -n csharp-%{name}
126 The Ice runtime for C#
127
128 %package -n ruby-%{name}
129 Summary:        The Ice runtime for Ruby applications
130 Group:          Development/Languages
131 Requires:       %{name} = %{version}-%{release}
132 %{?ruby_mod_ver_requires_eq}
133
134 %description -n ruby-%{name}
135 The Ice runtime for Ruby applications.
136
137 %package -n python-%{name}
138 Summary:        The Ice runtime for Python applications
139 Group:          Development/Languages/Python
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       python >= 1:2.3.4
142
143 %description -n python-%{name}
144 The Ice runtime for Python applications.
145
146 %package -n php-%{name}
147 Summary:        The Ice runtime for PHP applications
148 Group:          Development/Languages/PHP
149 Requires:       %{name} = %{version}-%{release}
150 %{?requires_php_extension}
151
152 %description -n php-%{name}
153 The Ice runtime for PHP applications.
154
155 %prep
156 %setup -q -n Ice-%{version} -a1 -a2
157 %patch0 -p0
158 %patch1 -p1
159 %patch2 -p1
160 %patch3 -p1
161
162 # no longer included in 3.4
163 rm -f *man-pages/slice2docbook.1
164
165 # Fix the encoding and line-endings of all the IceGridAdmin documentation files
166 cd java/resources/IceGridAdmin
167 %undos *.js *.css
168 for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
169         iconv -f ISO88591 -t UTF8 $f -o $f.tmp
170         mv $f.tmp $f
171 done
172 cd -
173
174 %if %{with java}
175 # we nuke it only when we build new class later, as ice build system expects the file being around
176 rm cpp/src/ca/ImportKey.class
177 %endif
178
179 # update path to our install
180 sed -i -e 's,/usr/share/Ice-%{version},%{_datadir}/Ice,' cpp/src/ca/iceca Ice-rpmbuild-%{version}/icegridregistry.conf
181
182 # force our CC/CXX as build system compares for exactly "c++" to setup other rules
183 sed -i -e 's,c++,%{__cxx},g' cpp/config/Make.rules.Linux
184
185 %build
186 # Compile the main Ice runtime
187 # TODO: CC/CXX passing as make param breaks build system
188
189 %if %{with java}
190 # Rebuild the Java ImportKey class - need it early for main cpp build
191 javac cpp/src/ca/ImportKey.java
192 %endif
193
194 %{__make} -C cpp \
195         CC="%{__cc}" \
196         CXX="%{__cxx}" \
197         CFLAGS="%{rpmcflags} -fPIC" \
198         CXXFLAGS="%{rpmcxxflags} -fPIC" \
199         embedded_runpath_prefix=""
200
201 %if %{with gui}
202 # Create the IceGrid icon
203 convert java/resources/icons/icegrid.ico temp.png
204 mv temp-8.png java/resources/icons/icegrid.png
205 rm temp*.png
206 %endif
207
208 %if %{with java}
209
210 # Set the CLASSPATH correctly for the Java compile
211 export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
212
213 %{__make} -C java \
214         CC="%{__cc}" \
215         CXX="%{__cxx}" \
216         CFLAGS="%{rpmcflags} -fPIC" \
217         CXXFLAGS="%{rpmcxxflags} -fPIC" \
218         embedded_runpath_prefix=""
219 %endif
220
221 %if %{with dotnet}
222 %{__make} -C cs \
223         CC="%{__cc}" \
224         CXX="%{__cxx}" \
225         CFLAGS="%{rpmcflags} -fPIC" \
226         CXXFLAGS="%{rpmcxxflags} -fPIC" \
227         embedded_runpath_prefix=""
228 %endif
229
230 %if %{with python}
231 %{__make} -C py \
232         CC="%{__cc}" \
233         CXX="%{__cxx}" \
234         CFLAGS="%{rpmcflags} -fPIC" \
235         CXXFLAGS="%{rpmcxxflags} -fPIC" \
236         embedded_runpath_prefix=""
237 %endif
238
239 %if %{with ruby}
240 %{__make} -C rb \
241         CC="%{__cc}" \
242         CXX="%{__cxx}" \
243         CFLAGS="%{rpmcflags} -fPIC" \
244         CXXFLAGS="%{rpmcxxflags} -fPIC" \
245         embedded_runpath_prefix=""
246 %endif
247
248 %if %{with php}
249 %{__make} -C php \
250         CC="%{__cc}" \
251         CXX="%{__cxx}" \
252         PHP_HOME=%{_prefix} \
253         CFLAGS="%{rpmcflags} -fPIC" \
254         CXXFLAGS="%{rpmcxxflags} -fPIC" \
255         embedded_runpath_prefix=""
256 %endif
257
258 %install
259 rm -rf $RPM_BUILD_ROOT
260 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_docdir}/Ice-%{version},%{_datadir}/Ice}
261
262 %{__make} -C cpp install \
263         prefix=$RPM_BUILD_ROOT
264
265 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
266 mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
267 mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
268 # Move the ImportKey.class file
269 mv $RPM_BUILD_ROOT/lib/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
270
271 mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
272
273 # Copy the man pages into the correct directory
274 install -d $RPM_BUILD_ROOT%{_mandir}/man1
275 cp -a *man-pages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
276
277 %if %{with java}
278 %{__make} -C java install \
279         prefix=$RPM_BUILD_ROOT
280
281 # Move Java stuff where it should be
282 install -d $RPM_BUILD_ROOT%{_javadir}
283 mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
284 ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
285 mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
286 ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
287
288 # Register ant target
289 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ant.d,%{_javadir}/ant}
290 mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice-%{version}.jar
291 ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice.jar
292 echo 'ice ant/ant-ice' > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ice
293 %endif
294
295 %if %{with gui}
296 # Install the IceGrid GUI
297 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
298 mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
299 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
300 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
301 cp -a java/resources/icons/icegrid.png $RPM_BUILD_ROOT%{_pixmapsdir}
302 mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
303 %endif
304
305 %if %{with dotnet}
306 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
307 %{__make} -C cs install \
308         prefix=$RPM_BUILD_ROOT \
309         GACINSTALL=yes \
310         GAC_ROOT=$RPM_BUILD_ROOT%{_libdir} \
311
312 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
313 # .NET spec files (for csharp-devel) -- convert the paths
314 for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
315         sed -i -e "s#/lib/#%{_libdir}/#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
316         sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
317         mv $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/$f.pc
318         mv $RPM_BUILD_ROOT%{_bindir}/$f.xml $RPM_BUILD_ROOT%{_libdir}/mono/gac/$f/%{version}.*/
319 done
320 %endif
321
322 %if %{with python}
323 %{__make} -C py install \
324         prefix=$RPM_BUILD_ROOT
325 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
326 install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
327 mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
328 rm -f $RPM_BUILD_ROOT/python/IcePy.so*
329 mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
330 cp -a Ice-rpmbuild-%{version}/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
331 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
332 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
333 %py_postclean
334 %endif
335
336 %if %{with ruby}
337 %{__make} -C rb install \
338         prefix=$RPM_BUILD_ROOT
339 %{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
340 install -d $RPM_BUILD_ROOT%{ruby_sitearchdir}
341 mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_sitearchdir}/IceRuby.so
342 rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
343 mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_sitearchdir}
344 %endif
345
346 %if %{with php}
347 %{__make} -C php install \
348         prefix=$RPM_BUILD_ROOT
349 # Put the PHP stuff into the right place
350 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
351 cp -a Ice-rpmbuild-%{version}/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
352 mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
353 mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
354 %endif
355
356 # move as last, bindings reinstall these if missing
357 mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
358
359 # Move the license files into the documentation directory
360 mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
361 mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
362 # Copy in the other files too
363 cp CHANGES RELEASE_NOTES  $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
364
365 # Install the servers
366 install -d $RPM_BUILD_ROOT%{_sysconfdir}
367 cp -a Ice-rpmbuild-%{version}/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
368 install -d $RPM_BUILD_ROOT%{_initrddir}
369 for i in icegridregistry icegridnode glacier2router; do
370         cp -a Ice-rpmbuild-%{version}/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
371 done
372 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
373
374 %clean
375 rm -rf $RPM_BUILD_ROOT
376
377 %post   -p /sbin/ldconfig
378 %postun -p /sbin/ldconfig
379
380 %post -n php-%{name}
381 %php_webserver_restart
382
383 %postun -n php-%{name}
384 if [ "$1" = 0 ]; then
385         %php_webserver_restart
386 fi
387
388 %files
389 %defattr(644,root,root,755)
390 %doc %{_docdir}/Ice-%{version}
391 %attr(755,root,root) %{_bindir}/dumpdb
392 %attr(755,root,root) %{_bindir}/glacier2router
393 %attr(755,root,root) %{_bindir}/icebox
394 %attr(755,root,root) %{_bindir}/iceboxadmin
395 %attr(755,root,root) %{_bindir}/iceca
396 %attr(755,root,root) %{_bindir}/icegridadmin
397 %attr(755,root,root) %{_bindir}/icegridnode
398 %attr(755,root,root) %{_bindir}/icegridregistry
399 %attr(755,root,root) %{_bindir}/icepatch2calc
400 %attr(755,root,root) %{_bindir}/icepatch2client
401 %attr(755,root,root) %{_bindir}/icepatch2server
402 %attr(755,root,root) %{_bindir}/icestormadmin
403 %attr(755,root,root) %{_bindir}/icestormmigrate
404 %attr(755,root,root) %{_bindir}/slice2html
405 %attr(755,root,root) %{_bindir}/transformdb
406 %{_mandir}/man1/dumpdb.1*
407 %{_mandir}/man1/glacier2router.1*
408 %{_mandir}/man1/icebox.1*
409 %{_mandir}/man1/iceboxadmin.1*
410 %{_mandir}/man1/icegridadmin.1*
411 %{_mandir}/man1/icegridnode.1*
412 %{_mandir}/man1/icegridregistry.1*
413 %{_mandir}/man1/icepatch2calc.1*
414 %{_mandir}/man1/icepatch2client.1*
415 %{_mandir}/man1/icepatch2server.1*
416 %{_mandir}/man1/icestormadmin.1*
417 %{_mandir}/man1/slice2html.1*
418 %{_mandir}/man1/transformdb.1*
419 %attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
420 %attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
421 %attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
422 %attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
423 %attr(755,root,root) %{_libdir}/libIce.so.*.*.*
424 %attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
425 %attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
426 %attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
427 %attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
429 %attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
430 %attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
431 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
432 %attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
433 %attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
434 %attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
435 %attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
436 %attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
437 %attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
438 %attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
439 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
440 %attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
441 %attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
442 %attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
443 %attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
444 %attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
445 %attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
446 %attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
447 %attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
448 %attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
449 %{_datadir}/Ice
450
451 %if %{with gui}
452 # Exclude the stuff that's in IceGrid
453 %exclude %{_docdir}/Ice-%{version}/IceGridAdmin
454 %exclude %{_datadir}/Ice/IceGridGUI.jar
455
456 %files -n icegrid-gui
457 %defattr(644,root,root,755)
458 %doc %{_docdir}/Ice-%{version}/IceGridAdmin
459 %attr(755,root,root) %{_bindir}/icegridgui
460 %{_datadir}/Ice/IceGridGUI.jar
461 %{_mandir}/man1/icegridgui.1*
462 %{_desktopdir}/IceGridAdmin.desktop
463 %{_pixmapsdir}/icegrid.png
464 %endif
465
466 %files devel
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_bindir}/slice2cpp
469 %attr(755,root,root) %{_bindir}/slice2freeze
470 %attr(755,root,root) %{_libdir}/libFreeze.so
471 %attr(755,root,root) %{_libdir}/libGlacier2.so
472 %attr(755,root,root) %{_libdir}/libIce.so
473 %attr(755,root,root) %{_libdir}/libIceBox.so
474 %attr(755,root,root) %{_libdir}/libIceDB.so
475 %attr(755,root,root) %{_libdir}/libIceGrid.so
476 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
477 %attr(755,root,root) %{_libdir}/libIcePatch2.so
478 %attr(755,root,root) %{_libdir}/libIceSSL.so
479 %attr(755,root,root) %{_libdir}/libIceStorm.so
480 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
481 %attr(755,root,root) %{_libdir}/libIceStormService.so
482 %attr(755,root,root) %{_libdir}/libIceUtil.so
483 %attr(755,root,root) %{_libdir}/libIceXML.so
484 %attr(755,root,root) %{_libdir}/libSlice.so
485 %{_includedir}/Freeze
486 %{_includedir}/Glacier2
487 %{_includedir}/Ice
488 %{_includedir}/IceBox
489 %{_includedir}/IceGrid
490 %{_includedir}/IcePatch2
491 %{_includedir}/IceSSL
492 %{_includedir}/IceStorm
493 %{_includedir}/IceUtil
494 %{_includedir}/IceXML
495 %{_includedir}/Slice
496 %{_mandir}/man1/slice2cpp.1*
497 %{_mandir}/man1/slice2freeze.1*
498 %if %{with java}
499 %{_sysconfdir}/ant.d/ant
500 %{_javadir}/ant/ant-ice-%{version}.jar
501 %{_javadir}/ant/ant-ice.jar
502 %endif
503
504 %if %{with dotnet}
505 %{_pkgconfigdir}/Glacier2.pc
506 %{_pkgconfigdir}/Ice.pc
507 %{_pkgconfigdir}/IceBox.pc
508 %{_pkgconfigdir}/IceGrid.pc
509 %{_pkgconfigdir}/IcePatch2.pc
510 %{_pkgconfigdir}/IceStorm.pc
511 %endif
512
513 # as we do not have -devel for each binding, these are in main -devel
514 # -csharp
515 %attr(755,root,root) %{_bindir}/slice2cs
516 %{_mandir}/man1/slice2cs.1*
517 # -java
518 %attr(755,root,root) %{_bindir}/slice2freezej
519 %attr(755,root,root) %{_bindir}/slice2java
520 %{_mandir}/man1/slice2freezej.1*
521 %{_mandir}/man1/slice2java.1*
522 # -php
523 %attr(755,root,root) %{_bindir}/slice2php
524 # -python
525 %attr(755,root,root) %{_bindir}/slice2py
526 %{_mandir}/man1/slice2py.1*
527 # -ruby
528 %attr(755,root,root) %{_bindir}/slice2rb
529 %{_mandir}/man1/slice2rb.1*
530
531 %files servers
532 %defattr(644,root,root,755)
533 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
534 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
535 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
536 %attr(754,root,root) /etc/rc.d/init.d/glacier2router
537 %attr(754,root,root) /etc/rc.d/init.d/icegridnode
538 %attr(754,root,root) /etc/rc.d/init.d/icegridregistry
539
540 %if %{with dotnet}
541 %files -n csharp-%{name}
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_bindir}/iceboxnet.exe
544 %{_mandir}/man1/iceboxnet.exe.1*
545 %{_libdir}/mono/Glacier2
546 %{_libdir}/mono/Ice
547 %{_libdir}/mono/IceBox
548 %{_libdir}/mono/IceGrid
549 %{_libdir}/mono/IcePatch2
550 %{_libdir}/mono/IceStorm
551 %{_libdir}/mono/gac/Glacier2
552 %{_libdir}/mono/gac/Ice
553 %{_libdir}/mono/gac/IceBox
554 %{_libdir}/mono/gac/IceGrid
555 %{_libdir}/mono/gac/IcePatch2
556 %{_libdir}/mono/gac/IceStorm
557 %endif
558
559 %if %{with python}
560 %files -n python-%{name}
561 %defattr(644,root,root,755)
562 %{py_sitedir}/ice.pth
563 %dir %{py_sitedir}/Ice
564 %dir %{py_sitedir}/Ice/IceBox
565 %dir %{py_sitedir}/Ice/IceGrid
566 %dir %{py_sitedir}/Ice/IcePatch2
567 %dir %{py_sitedir}/Ice/IceStorm
568 %{py_sitedir}/Ice/*.py[co]
569 %{py_sitedir}/Ice/IceBox/*.py[co]
570 %{py_sitedir}/Ice/IceGrid/*.py[co]
571 %{py_sitedir}/Ice/IcePatch2/*.py[co]
572 %{py_sitedir}/Ice/IceStorm/*.py[co]
573 %attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
574 %endif
575
576 %if %{with ruby}
577 %files -n ruby-%{name}
578 %defattr(644,root,root,755)
579 %{ruby_sitearchdir}/Glacier2.rb
580 %{ruby_sitearchdir}/Glacier2
581 %{ruby_sitearchdir}/Ice.rb
582 %{ruby_sitearchdir}/Ice
583 %{ruby_sitearchdir}/IceBox.rb
584 %{ruby_sitearchdir}/IceBox
585 %{ruby_sitearchdir}/IceGrid.rb
586 %{ruby_sitearchdir}/IceGrid
587 %{ruby_sitearchdir}/IcePatch2.rb
588 %{ruby_sitearchdir}/IcePatch2
589 %{ruby_sitearchdir}/IceStorm.rb
590 %{ruby_sitearchdir}/IceStorm/IceStorm.rb
591 %attr(755,root,root) %{ruby_sitearchdir}/IceRuby.so
592 %endif
593
594 %if %{with java}
595 %files -n java-%{name}
596 %defattr(644,root,root,755)
597 %{_javadir}/Freeze-%{version}.jar
598 %{_javadir}/Freeze.jar
599 %{_javadir}/Ice-%{version}.jar
600 %{_javadir}/Ice.jar
601 %endif
602
603 %if %{with php}
604 %files -n php-%{name}
605 %defattr(644,root,root,755)
606 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
607 %attr(755,root,root) %{php_extensiondir}/IcePHP.so
608 %{php_data_dir}/Glacier2.php
609 %{php_data_dir}/Glacier2
610 %{php_data_dir}/Ice.php
611 %{php_data_dir}/Ice
612 %{php_data_dir}/IceBox.php
613 %{php_data_dir}/IceBox
614 %{php_data_dir}/IceGrid.php
615 %{php_data_dir}/IceGrid
616 %{php_data_dir}/IcePatch2.php
617 %{php_data_dir}/IcePatch2
618 %{php_data_dir}/IceStorm.php
619 %{php_data_dir}/IceStorm
620 %endif
This page took 0.065389 seconds and 4 git commands to generate.