]> git.pld-linux.org Git - packages/hwloc.git/blob - hwloc.spec
- added notes on kerrighed and myriexpress
[packages/hwloc.git] / hwloc.spec
1 # TODO: CUDA >= 30.20, NVML/nvidia-ml on bcond?
2 # NOTES (as of 1.9):
3 # - kerrighed library is only checked for; kerrighed support in hwloc uses /proc filesystem
4 # - myriexpress (open-mx) library is only checked for, but not used by hwloc code
5 #   (just in one test); in binary packages only interface header is included
6 Summary:        Portable Hardware Locality
7 Summary(pl.UTF-8):      Przenośna lokalizacja sprzętu
8 Name:           hwloc
9 Version:        1.9
10 Release:        1
11 License:        BSD
12 Group:          Applications/System
13 Source0:        http://www.open-mpi.org/software/hwloc/v%{version}/downloads/%{name}-%{version}.tar.bz2
14 # Source0-md5:  1954f690211227cb0a665624aab6aaa6
15 URL:            http://www.open-mpi.org/projects/hwloc/
16 BuildRequires:  OpenCL-devel
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  cairo-devel
19 BuildRequires:  libXNVCtrl-devel
20 BuildRequires:  libibverbs-devel
21 BuildRequires:  libltdl-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libxml2-devel >= 2.0
24 BuildRequires:  ncurses-devel
25 BuildRequires:  numactl-devel
26 BuildRequires:  pkgconfig >= 1:0.9.0
27 BuildRequires:  xorg-lib-libX11-devel
28 BuildRequires:  xorg-lib-libXext-devel
29 BuildRequires:  xorg-lib-libpciaccess-devel
30 BuildRequires:  xorg-proto-xproto-devel
31 Requires:       %{name}-libs = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Portable Hardware Locality (hwloc) software package provides a
36 portable abstraction (across OS, versions, architectures, ...) of the
37 hierarchical topology of modern architectures, including NUMA memory
38 nodes, sockets, shared caches, cores and simultaneous multithreading.
39 It also gathers various system attributes such as cache and memory
40 information. It primarily aims at helping applications with gathering
41 information about modern computing hardware so as to exploit it
42 accordingly and efficiently.
43
44 %description -l pl.UTF-8
45 Pakiet HWLOC (Portable Hardware Locality) zapewnia przenośną (między
46 systemami operacyjnymi, werjami, architekturami...) abstrakcję
47 hierarchicznej topologii współczesnych architektur, w tym węzłów z
48 pamięcią NUMA, gniazd, współdzielonych pamięci podręcznych, rdzeni i
49 wielowątkowości. Gromadzi też różne właściwości systemów, takie jak
50 informacje o pamięci głównej i podręcznej. Głównym celem jest pomoc
51 aplikacjom w gromadzeniu informacji o współczesnym sprzęcie
52 obliczeniowym w celu jego właściwego i wydajnego wykorzystania.
53
54 %package libs
55 Summary:        Portable Hardware Locality (hwloc) library
56 Summary(pl.UTF-8):      Biblioteka przenośnej lokalizacji sprzętu (hwloc)
57 Group:          Libraries
58
59 %description libs
60 Portable Hardware Locality (hwloc) library.
61
62 %description libs -l pl.UTF-8
63 Biblioteka przenośnej lokalizacji sprzętu (hwloc).
64
65 %package devel
66 Summary:        Header files for hwloc library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki hwloc
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       libltdl-devel
71 Requires:       numactl-devel
72
73 %description devel
74 Header files for hwloc library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki hwloc.
78
79 %prep
80 %setup -q
81
82 %build
83 %configure \
84         --enable-plugins \
85         --disable-silent-rules
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libhwloc.la \
95         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   libs -p /sbin/ldconfig
101 %postun libs -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/hwloc-*
106 %attr(755,root,root) %{_bindir}/lstopo
107 %attr(755,root,root) %{_bindir}/lstopo-no-graphics
108 %dir %{_libdir}/%{name}
109 %attr(755,root,root) %{_libdir}/%{name}/hwloc_opencl.so
110 %attr(755,root,root) %{_libdir}/%{name}/hwloc_pci.so
111 %attr(755,root,root) %{_libdir}/%{name}/hwloc_xml_libxml.so
112 %{_datadir}/%{name}
113 %{_mandir}/man1/hwloc-*.1*
114 %{_mandir}/man1/lstopo.1*
115 %{_mandir}/man1/lstopo-no-graphics.1*
116 %{_mandir}/man7/hwloc.7*
117
118 %files libs
119 %defattr(644,root,root,755)
120 %doc AUTHORS COPYING NEWS README
121 %attr(755,root,root) %{_libdir}/libhwloc.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libhwloc.so.5
123
124 %files devel
125 %defattr(644,root,root,755)
126 %doc doc/doxygen-doc/html doc/doxygen-doc/hwloc-a4.pdf
127 %attr(755,root,root) %{_libdir}/libhwloc.so
128 %{_pkgconfigdir}/hwloc.pc
129 %{_includedir}/hwloc
130 %{_includedir}/hwloc.h
131 %{_mandir}/man3/HWLOC_*.3*
132 %{_mandir}/man3/hwloc_*.3*
133 %{_mandir}/man3/hwlocality_*.3*
This page took 0.067205 seconds and 4 git commands to generate.