]> git.pld-linux.org Git - projects/template-specs.git/blob - horde.spec
- no need for dot in find
[projects/template-specs.git] / horde.spec
1 # TODO
2 # - lighttpd support
3 %define _hordeapp skeleton
4 #define _snap   2005-08-01
5 #define _rc             rc1
6 %define _rel    1
7
8 # REPLACE words 'SKELETON', 'Skeleton', 'skeleton' with your application
9 # GET THE Summary from here: http://www.horde.org/source/modules.php
10 # FIND .htaccess FILES AND MAKE SURE APACHE CONF DISABLES ACCESS TO
11 # THOSE DIRS: find -name '.??*' IS EASY TO LOCATE.
12
13 %include        /usr/lib/rpm/macros.php
14 Summary:        Template for horde projects
15 Name:           horde-%{_hordeapp}
16 Version:        0.1
17 Release:        %{?_rc:0.%{_rc}.}%{?_snap:0.%(echo %{_snap} | tr -d -).}%{_rel}
18 License:        GPL v2 (CHECK IT FIRST, could be ASL)
19 Group:          Applications/WWW
20 # due builder limitations can't have complex macros in Source0
21 #Source0:       ftp://ftp.horde.org/pub/skeleton/%{_hordeapp}-h3-%{version}.tar.gz
22 #Source0:       ftp://ftp.horde.org/pub/skeleton/%{_hordeapp}-h3-%{version}-%{_rc}.tar.gz
23 #Source0:       ftp://ftp.horde.org/pub/snaps/%{_snap}/%{_hordeapp}-HEAD-%{_snap}.tar.gz
24 # Source0-md5:  -
25 # COPY IN SOURCES ../SOURCES/ingo.conf AS SOURCE1 HERE:
26 # cp ../SOURCES/{ingo,skeleton}.conf
27 # DON'T FORGET TO :%s#ingo#skeleton#g in that file
28 Source1:        %{_hordeapp}.conf
29 Patch0:         %{_hordeapp}-prefs.patch
30 URL:            http://www.horde.org/skeleton/
31 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
32 BuildRequires:  rpmbuild(macros) >= 1.264
33 BuildRequires:  tar >= 1:1.15.1
34 Requires:       apache(mod_access)
35 Requires:       horde >= 3.0
36 Requires:       webapps
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # horde accesses it directly in help->about
41 %define         _noautocompressdoc  CREDITS
42 %define         _noautoreq      'pear(Horde.*)'
43
44 %define         hordedir        /usr/share/horde
45 %define         _appdir         %{hordedir}/%{_hordeapp}
46 %define         _webapps        /etc/webapps
47 %define         _webapp         horde-%{_hordeapp}
48 %define         _sysconfdir     %{_webapps}/%{_webapp}
49
50 # GET DESCRIPTION FROM PROJECT URL
51 %description
52 SKELETON
53
54 The Horde Project writes web applications in PHP and releases them
55 under the GNU Public License. For more information (including help
56 with Skeleton) please visit <http://www.horde.org/>.
57
58 %description -l pl.UTF-8
59 SKELETON
60
61 Projekt Horde tworzy aplikacje WWW w PHP i wydaje je na licencji GNU
62 General Public License. Więcej informacji (włącznie z pomocą dla
63 Skeleton) można znaleźć na stronie <http://www.horde.org/>.
64
65 %prep
66 %setup -qcT -n %{?_snap:%{_hordeapp}-%{_snap}}%{!?_snap:%{_hordeapp}-%{version}%{?_rc:-%{_rc}}}
67 tar zxf %{SOURCE0} --strip-components=1
68
69 rm {,*/}.htaccess
70 for i in config/*.dist; do
71         mv $i config/$(basename $i .dist)
72 done
73 # considered harmful (horde/docs/SECURITY)
74 rm test.php
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/docs}
79
80 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
81 cp -a config/* $RPM_BUILD_ROOT%{_sysconfdir}
82 echo '<?php ?>' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.php
83 touch $RPM_BUILD_ROOT%{_sysconfdir}/conf.php.bak
84 cp -a lib locale templates themes $RPM_BUILD_ROOT%{_appdir}
85
86 ln -s %{_sysconfdir} $RPM_BUILD_ROOT%{_appdir}/config
87 ln -s %{_docdir}/%{name}-%{version}/CREDITS $RPM_BUILD_ROOT%{_appdir}/docs
88 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
89 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 if [ ! -f %{_sysconfdir}/conf.php.bak ]; then
96         install /dev/null -o root -g http -m660 %{_sysconfdir}/conf.php.bak
97 fi
98
99 # CHECK FIRST DOES IT HAVE SQL AND FILE THERE.
100 if [ "$1" = 1 ]; then
101 %banner %{name} -e <<-EOF
102         IMPORTANT:
103         If you are installing Skeleton for the first time, You may need to
104         create the Skeleton database tables. To do so run:
105         zcat %{_docdir}/%{name}-%{version}/scripts/sql/%{_hordeapp}.sql.gz | mysql horde
106 EOF
107 fi
108
109 %triggerin -- apache1 < 1.3.37-3, apache1-base
110 %webapp_register apache %{_webapp}
111
112 %triggerun -- apache1 < 1.3.37-3, apache1-base
113 %webapp_unregister apache %{_webapp}
114
115 %triggerin -- apache < 2.2.0, apache-base
116 %webapp_register httpd %{_webapp}
117
118 %triggerun -- apache < 2.2.0, apache-base
119 %webapp_unregister httpd %{_webapp}
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README docs/* scripts
124 %dir %attr(750,root,http) %{_sysconfdir}
125 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
126 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
127 %attr(660,root,http) %config(noreplace) %{_sysconfdir}/conf.php
128 %attr(660,root,http) %config(noreplace) %ghost %{_sysconfdir}/conf.php.bak
129 %attr(640,root,http) %config(noreplace) %{_sysconfdir}/[!c]*.php
130 %attr(640,root,http) %{_sysconfdir}/conf.xml
131
132 %dir %{_appdir}
133 %{_appdir}/*.php
134 %{_appdir}/config
135 %{_appdir}/docs
136 %{_appdir}/lib
137 %{_appdir}/locale
138 %{_appdir}/templates
139 %{_appdir}/themes
This page took 0.03936 seconds and 4 git commands to generate.