]> git.pld-linux.org Git - packages/hhvm.git/blob - hhvm.spec
-devel R libstdc++-devel for CMAKE_C_COMPILER, CMAKE_CXX_COMPILER, CMAKE_ASM_COMPILER
[packages/hhvm.git] / hhvm.spec
1 # NOTES:
2 # - hphp/runtime/base/runtime-option.cpp evalJitDefault enables jit if /.hhvm-jit exists (yes, in filesystem root)
3 # TODO
4 # - system libevent2: https://github.com/facebook/hiphop-php/pull/421
5 # - system libmbfl, system xhp, sqlite3
6 %define         githash f951cb8d8812c59344d5322454853b584b668636
7 Summary:        Virtual Machine, Runtime, and JIT for PHP
8 Name:           hhvm
9 Version:        2.3.2
10 Release:        0.8
11 License:        PHP 3.01
12 Group:          Development/Languages
13 Source0:        https://github.com/facebook/hhvm/archive/HHVM-%{version}.tar.gz
14 # Source0-md5:  471961d38ba52c66b7038c556b2b7bd8
15 # need fb.changes.patch, which is available for 1.4 only
16 Source1:        http://www.monkey.org/~provos/libevent-1.4.14b-stable.tar.gz
17 # Source1-md5:  a00e037e4d3f9e4fe9893e8a2d27918c
18 Source2:        https://github.com/facebook/folly/archive/4d6d659/folly-%{version}-4d6d659.tar.gz
19 Source100:      get-source.sh
20 Patch0:         cmake-missing-library.patch
21 Patch1:         libevent14.patch
22 Patch3:         system-xhp.patch
23 Patch4:         system-libafdt.patch
24 Patch5:         system-folly.patch
25 Patch6:         checksum.patch
26 Patch7:         imap-gss.patch
27 Patch8:         hphpize.patch
28 URL:            http://wiki.github.com/facebook/hiphop-php/
29 BuildRequires:  binutils-devel
30 BuildRequires:  bison >= 2.3
31 BuildRequires:  boost-devel >= 1.50
32 BuildRequires:  cmake >= 2.8.7
33 BuildRequires:  curl-devel >= 7.29.0
34 BuildRequires:  elfutils-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  flex >= 2.5.35
37 BuildRequires:  gcc >= 6:4.6.0
38 BuildRequires:  gd-devel
39 BuildRequires:  glog-devel >= 0.3.2
40 BuildRequires:  imap-devel >= 1:2007
41 #BuildRequires: jemalloc-devel >= 3.0.0
42 BuildRequires:  libafdt-devel >= 0.1.0
43 BuildRequires:  libcap-devel
44 BuildRequires:  libdwarf-devel
45 #BuildRequires: libevent-devel >= 1.4.14
46 BuildRequires:  libicu-devel >= 4.2
47 #BuildRequires: libmbfl-devel
48 BuildRequires:  libmcrypt-devel
49 BuildRequires:  libmemcached-devel >= 1.0.4
50 BuildRequires:  libstdc++-devel >= 6:4.3
51 BuildRequires:  libunwind-devel
52 BuildRequires:  libxml2-devel
53 BuildRequires:  mysql-devel
54 BuildRequires:  oniguruma-devel
55 BuildRequires:  openssl-devel
56 BuildRequires:  pcre-devel
57 #BuildRequires: php-xhp-devel >= 1.3.9-6
58 BuildRequires:  re2c >= 0.13.0
59 BuildRequires:  readline-devel
60 BuildRequires:  rpmbuild(macros) >= 1.675
61 BuildRequires:  tbb-devel >= 4.0.6000
62 BuildRequires:  zlib-devel
63 Provides:       php(apc)
64 Provides:       php(bcmath)
65 Provides:       php(bz2)
66 Provides:       php(ctype)
67 Provides:       php(curl)
68 Provides:       php(date)
69 Provides:       php(dom)
70 Provides:       php(exif)
71 Provides:       php(fb)
72 Provides:       php(fileinfo)
73 Provides:       php(filter)
74 Provides:       php(gd)
75 Provides:       php(hash)
76 Provides:       php(hotprofiler)
77 Provides:       php(iconv)
78 Provides:       php(icu_num_fmt)
79 Provides:       php(icu_ucsdet)
80 Provides:       php(icu_uspoof)
81 Provides:       php(idn)
82 Provides:       php(imap)
83 Provides:       php(json)
84 Provides:       php(ldap)
85 Provides:       php(mbstring)
86 Provides:       php(mcrypt)
87 Provides:       php(memcache)
88 Provides:       php(memcached)
89 Provides:       php(mysql)
90 Provides:       php(openssl)
91 Provides:       php(pcntl)
92 Provides:       php(pcre)
93 Provides:       php(pdo)
94 Provides:       php(pdo_mysql)
95 Provides:       php(pdo_sqlite)
96 Provides:       php(phar)
97 Provides:       php(posix)
98 Provides:       php(reflection)
99 Provides:       php(server)
100 Provides:       php(session)
101 Provides:       php(simplexml)
102 Provides:       php(soap)
103 Provides:       php(sockets)
104 Provides:       php(spl)
105 Provides:       php(sqlite3)
106 Provides:       php(sysvmsg)
107 Provides:       php(sysvsem)
108 Provides:       php(sysvshm)
109 Provides:       php(thread)
110 Provides:       php(thrift_protocol)
111 Provides:       php(tokenizer)
112 Provides:       php(xhprof)
113 Provides:       php(xml)
114 Provides:       php(xmlreader)
115 Provides:       php(xmlwriter)
116 Provides:       php(zip)
117 Provides:       php(zlib)
118 Obsoletes:      hiphop-php < 2.3.2-0.2
119 ExclusiveArch:  %{x8664}
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %description
123 HHVM (aka the HipHop Virtual Machine) is a new open-source virtual
124 machine designed for executing programs written in PHP. HHVM uses a
125 just-in-time compilation approach to achieve superior performance
126 while maintaining the flexibility that PHP developers are accustomed
127 to. To date, HHVM (and its predecessor HPHPc before it) has realized
128 over a 9x increase in web request throughput and over a 5x reduction
129 in memory consumption for Facebook compared with the Zend PHP 5.2
130 engine + APC.
131
132 HHVM can be run as a standalone webserver (i.e. without the Apache
133 webserver and the "mod_php" extension). HHVM can also be used together
134 with a FastCGI-based webserver, and work is in progress to make HHVM
135 work smoothly with Apache.
136
137 %package program
138 Summary:        /usr/bin/php symlink
139 Summary(pl.UTF-8):      Dowiązanie symboliczne /usr/bin/php
140 Group:          Development/Languages/PHP
141 Requires:       %{name} = %{version}-%{release}
142 Obsoletes:      /usr/bin/php
143
144 %description program
145 Package providing /usr/bin/php symlink to PHP CLI.
146
147 %description program -l pl.UTF-8
148 Pakiet dostarczający dowiązanie symboliczne /usr/bin/php do PHP CLI.
149
150 %package devel
151 Summary:        Files for HHVM modules development
152 Group:          Development/Languages/PHP
153 URL:            https://github.com/facebook/hhvm/wiki/Extension-API
154 Requires:       cmake >= 2.8.5
155 Requires:       libstdc++-devel >= 6:4.3
156
157 %description devel
158 HHVM provides a set of APIs for adding built-in functionality to the
159 runtime either by way of pure PHP code, or a combination of PHP and
160 C++.
161
162 %prep
163 %setup -q -a1 -a2 -n %{name}-HHVM-%{version}
164
165 mv folly-*/* hphp/submodules/folly
166
167 %patch6 -p1
168 %patch7 -p1
169 %patch8 -p1
170 #%patch5 -p1
171
172 # prefer ones from system
173 rm CMake/FindBISON.cmake
174 rm CMake/FindBoost.cmake
175 rm CMake/FindFLEX.cmake
176
177 ln -s libevent-1.4.*-stable libevent
178 %{__patch} -d libevent -p1 < hphp/third_party/libevent-1.4.14.fb-changes.diff
179
180 %if 0
181 %patch0 -p1
182 %patch1 -p1
183 #%patch3 -p1
184 %patch4 -p1
185
186
187 #rm -rf src/third_party/libmbfl
188 #sed -i -e '/add_subdirectory(third_party\/libmbfl)/d' src/CMakeLists.txt
189
190 rm -rf src/third_party/xhp
191 rm -rf src/third_party/libafdt
192 %endif
193
194 %build
195 # build libevent 1.4 with fb patches
196 if [ ! -d libevent/.libs ]; then
197         cd libevent
198         # TODO: should use static linking, but then it fails to detect libraries due missing -lrt
199         %configure \
200                 %{?0:--enable-static} \
201                 %{?0:--disable-shared}
202         %{__make}
203         ln -s .libs lib
204         ln -s . include
205         cd ..
206 fi
207
208 export HPHP_HOME=$(pwd)
209 export HPHP_LIB=$HPHP_HOME/bin
210 install -d $HPHP_LIB
211
212 # asm linking breaks on $CC containing spaces
213 if [[ "%{__cc}" = *ccache* ]]; then
214         cat <<-'EOF' > $HPHP_LIB/gcc
215         #!/bin/sh
216         exec %{__cc} "$@"
217         EOF
218         chmod +x $HPHP_LIB/gcc
219         CC=$HPHP_LIB/gcc
220 fi
221
222 %if 0
223 export LIBEVENT_PREFIX=$HPHP_HOME/libevent
224
225         -DLibEvent_LIB=$HPHP_HOME/libevent/libevent.so \
226         -DLibEvent_INCLUDE_PATHS=$HPHP_HOME/libevent \
227         -DLibEvent_LIB_PATHS=$HPHP_HOME/libevent/.libs \
228 %endif
229
230 %if 0
231 # out of dir build broken (can't find it's tools)
232 install -d build
233 cd build
234 %endif
235
236 %cmake \
237         -DLIBEVENT_LIB=$HPHP_HOME/libevent/lib/libevent.so \
238         -DLIBEVENT_INCLUDE_DIR=$HPHP_HOME/libevent \
239         -DCMAKE_PREFIX_PATH=%{_prefix} \
240         -DSKIP_BUNDLED_XHP=ON \
241         -DUSE_JEMALLOC=OFF \
242         -DUSE_TCMALLOC=OFF \
243         ./
244
245 # setup COMPILER_ID/HHVM_REPO_SCHEMA so it doesn't look it up from our package git repo
246 # see hphp/util/generate-buildinfo.sh
247 export COMPILER_ID=HPHP-%{version}-%{release}-%{githash}
248 export HHVM_REPO_SCHEMA=$(date +%N_%s)
249
250 %{__make}
251
252 %install
253 rm -rf $RPM_BUILD_ROOT
254 %{__make} install \
255         HPHP_HOME=$(pwd) \
256         DESTDIR=$RPM_BUILD_ROOT
257
258 ln -s hhvm $RPM_BUILD_ROOT%{_bindir}/php
259 ln -s hhvm $RPM_BUILD_ROOT%{_bindir}/hphp
260
261 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf
262 cp -p hphp/doc/mime.hdf $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf/static.mime-types.hdf
263
264 # install our libevent for now
265 install -d $RPM_BUILD_ROOT%{_libdir}
266 libtool --mode=install install -p libevent/libevent.la $RPM_BUILD_ROOT%{_libdir}
267 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libevent.{a,la,so}
268
269 # setup -devel
270 install -d $RPM_BUILD_ROOT%{_datadir}/cmake/Modules
271 cp -a CMake/* $RPM_BUILD_ROOT%{_datadir}/cmake/Modules
272
273 HPHP_HOME=$(pwd)
274 sed -e "
275         /HHVM_INCLUDE_DIRS/ s,$HPHP_HOME,%{_includedir},g
276 " hphp/tools/hphpize/hphpize.cmake > $RPM_BUILD_ROOT%{_datadir}/cmake/Modules/hphpize.cmake
277
278 oIFS=$IFS
279 IFS=";"
280 set -- $(sed -ne 's/set(HHVM_INCLUDE_DIRS "\(.*\)")/\1/p' hphp/tools/hphpize/hphpize.cmake)
281 for dir in "$@"; do
282         case "$dir" in
283         $HPHP_HOME/?*)
284                 find $dir -name '*.h' | while read file; do
285                         install -Dp $file $RPM_BUILD_ROOT%{_includedir}${file#$HPHP_HOME}
286                 done
287         ;;
288         esac
289 done
290 IFS=$oIFS
291
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 %post   -p /sbin/ldconfig
296 %postun -p /sbin/ldconfig
297
298 %files
299 %defattr(644,root,root,755)
300 %doc README.md hphp/NEWS
301 %attr(755,root,root) %{_bindir}/hhvm
302 %attr(755,root,root) %{_bindir}/hphp
303 %attr(755,root,root) %{_libdir}/libevent-1.4.so.*.*.*
304 %ghost %{_libdir}/libevent-1.4.so.2
305
306 %dir %{_datadir}/%{name}
307 %dir %{_datadir}/%{name}/hdf
308 %{_datadir}/%{name}/hdf/static.mime-types.hdf
309
310 %files program
311 %defattr(644,root,root,755)
312 %attr(755,root,root) %{_bindir}/php
313
314 %files devel
315 %defattr(644,root,root,755)
316 %attr(755,root,root) %{_bindir}/hphpize
317 %{_includedir}/hphp
318 %{_datadir}/cmake/Modules/hphpize.cmake
319 %{_datadir}/cmake/Modules/FindCClient.cmake
320 %{_datadir}/cmake/Modules/FindEditline.cmake
321 %{_datadir}/cmake/Modules/FindGD.cmake
322 %{_datadir}/cmake/Modules/FindGlog.cmake
323 %{_datadir}/cmake/Modules/FindICU.cmake
324 %{_datadir}/cmake/Modules/FindLdap.cmake
325 %{_datadir}/cmake/Modules/FindLibAfdt.cmake
326 %{_datadir}/cmake/Modules/FindLibCh.cmake
327 %{_datadir}/cmake/Modules/FindLibDL.cmake
328 %{_datadir}/cmake/Modules/FindLibDwarf.cmake
329 %{_datadir}/cmake/Modules/FindLibElf.cmake
330 %{_datadir}/cmake/Modules/FindLibEvent.cmake
331 %{_datadir}/cmake/Modules/FindLibEvent.cmake.bak
332 %{_datadir}/cmake/Modules/FindLibNuma.cmake
333 %{_datadir}/cmake/Modules/FindLibXed.cmake
334 %{_datadir}/cmake/Modules/FindLibiconv.cmake
335 %{_datadir}/cmake/Modules/FindLibinotify.cmake
336 %{_datadir}/cmake/Modules/FindLibmemcached.cmake
337 %{_datadir}/cmake/Modules/FindLibpam.cmake
338 %{_datadir}/cmake/Modules/FindMcrypt.cmake
339 %{_datadir}/cmake/Modules/FindMySQL.cmake
340 %{_datadir}/cmake/Modules/FindNcurses.cmake
341 %{_datadir}/cmake/Modules/FindONIGURUMA.cmake
342 %{_datadir}/cmake/Modules/FindPCRE.cmake
343 %{_datadir}/cmake/Modules/FindPThread.cmake
344 %{_datadir}/cmake/Modules/FindReadline.cmake
345 %{_datadir}/cmake/Modules/FindTBB.cmake
346 %{_datadir}/cmake/Modules/FollySetup.cmake
347 %{_datadir}/cmake/Modules/HPHPCompiler.cmake
348 %{_datadir}/cmake/Modules/HPHPFindLibs.cmake
349 %{_datadir}/cmake/Modules/HPHPFunctions.cmake
350 %{_datadir}/cmake/Modules/HPHPSetup.cmake
351 %{_datadir}/cmake/Modules/Options.cmake
This page took 0.094533 seconds and 4 git commands to generate.