]> git.pld-linux.org Git - packages/herqq.git/blob - herqq.spec
fix duplicate files
[packages/herqq.git] / herqq.spec
1 Summary:        A library for building UPnP devices and control points
2 Name:           herqq
3 Version:        1.0.0
4 Release:        4
5 License:        GPL v3+
6 Group:          Applications
7 Source0:        http://downloads.sourceforge.net/hupnp/%{name}-%{version}.zip
8 # Source0-md5:  45a0632f7c7b64bc0fdab852d36c1e61
9 URL:            http://www.herqq.org/
10 BuildRequires:  QtCore-devel
11 BuildRequires:  QtGui-devel
12 BuildRequires:  QtNetwork-devel
13 BuildRequires:  QtTest-devel
14 BuildRequires:  QtXml-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  qt4-build >= 4.3.3-3
17 BuildRequires:  qt4-qmake >= 4.3.3-3
18 BuildRequires:  rpmbuild(macros) >= 1.129
19 BuildRequires:  unzip
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Herqq UPnP (HUPnP) is a software library for building UPnP devices and
24 control points conforming to the UPnP Device Architecture version 1.1.
25 It is designed to be simple to use and robust in operation. It is
26 built using C++ and the Qt Framework following many of the design
27 principles and programming practices used in the Qt Framework. It
28 integrates into Qt-based software smoothly and enables truly rapid
29 UPnP development.
30
31 %package devel
32 Summary:        Header files for herqq library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki herqq
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for herqq library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki herqq.
42
43 %prep
44 %setup -q
45
46 %build
47 qmake-qt4
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install
54
55 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir}}
56
57 cp -a hupnp/bin/lib* $RPM_BUILD_ROOT%{_libdir}
58 rm $RPM_BUILD_ROOT%{_libdir}/lib*.so.1.0
59 cp -a hupnp/deploy/include/HUpnpCore $RPM_BUILD_ROOT%{_includedir}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(644,root,root,755)
69 %attr(755,root,root) %{_libdir}/libHUpnp.so.*.*.*
70 %attr(755,root,root) %ghost %{_libdir}/libHUpnp.so.1
71 %attr(755,root,root) %{_libdir}/libQtSolutions_SOAP-2.7.so.*.*.*
72 %attr(755,root,root) %ghost %{_libdir}/libQtSolutions_SOAP-2.7.so.1
73
74 %files devel
75 %defattr(644,root,root,755)
76 %doc hupnp/docs
77 %{_libdir}/libHUpnp.so
78 %{_libdir}/libQtSolutions_SOAP-2.7.so
79 %{_includedir}/HUpnpCore
This page took 0.068802 seconds and 4 git commands to generate.