]> git.pld-linux.org Git - packages/hdf.git/blob - hdf.spec
- updated shared patch, pass libdir (for lib64)
[packages/hdf.git] / hdf.spec
1 Summary:        Hierarchical Data Format library
2 Summary(pl):    Biblioteka HDF (Hierarchical Data Format)
3 Name:           hdf
4 Version:        4.1r5
5 Release:        3
6 Group:          Libraries
7 License:        Nearly BSD, but changed sources must be marked
8 Source0:        ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF_Current/tar/HDF%{version}.tar.gz
9 # Source0-md5:  f90de772dac93195def4a585da176db2
10 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
11 # Source1-md5:  607df78cacc131b37dfdb443e61e789a
12 Patch0:         %{name}-system-libs.patch
13 Patch1:         %{name}-strdup.patch
14 Patch2:         %{name}-shared.patch
15 Patch3:         %{name}-athlon.patch
16 URL:            http://hdf.ncsa.uiuc.edu/
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  gcc-g77
20 BuildRequires:  groff
21 BuildRequires:  libjpeg-devel >= 6b
22 BuildRequires:  libtool >= 2:1.4d-3
23 BuildRequires:  which
24 BuildRequires:  zlib-devel >= 1.1.3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 ExclusiveArch:  %{ix86} alpha
27
28 %description
29 HDF is a multi-object file format that facilitates the transfer of
30 various types of scientific data between machines and operating
31 systems. Machines currently supported include the Cray, HP, Vax, Sun,
32 IBM RS/6000, Silicon Graphics, Macintosh, and IBM PC computers. HDF
33 allows self-definitions of data content and easy extensibility for
34 future enhancements or compatibility with other standard formats. HDF
35 includes Fortran and C calling interfaces,and utilities to prepare raw
36 image of data files or for use with other NCSA software. The HDF
37 library contains interfaces for storing and retrieving compressed or
38 uncompressed 8-bit and 24-bit raster images with palettes,
39 n-Dimensional scientific datasets and binary tables. An interface is
40 also included that allows arbitray grouping of other HDF objects.
41
42 %description -l pl
43 HDF jest wieloobiektowym formatem plików u³atwiaj±cym przenoszenie
44 ró¿nych danych naukowych pomiêdzy ró¿nymi komputerami i systemami
45 operacyjnymi. Aktualnie obs³ugiwane s± m.in. Cray, HP, Vax, Sun, IBM
46 RS/6000, Silicon Graphics, Macintosh i IBM PC. HDF zawiera interfejsy
47 do Fortranu i C oraz narzêdzia do przygotowywania plików z danymi.
48 Biblioteka pozwala na przechowywanie i odczytywanie skompresowanych
49 lub nie 8-bitowych i 24-bitowych obrazków z palet±, wielowymiarowych
50 zestawów danych itp.
51
52 %package devel
53 Summary:        HDF library development package
54 Summary(pl):    Pliki nag³ówkowe biblioteki HDF
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}
57 Requires:       libjpeg-devel
58 Requires:       zlib-devel
59
60 %description devel
61 Header files for HDF library.
62
63 %description devel -l pl
64 Pliki nag³ówkowe biblioteki HDF.
65
66 %package static
67 Summary:        HDF static library
68 Summary(pl):    Statyczna biblioteka HDF
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}
71
72 %description static
73 Static version of HDF library.
74
75 %description static -l pl
76 Statyczna wersja biblioteki HDF.
77
78 %package progs
79 Summary:        HDF utilities
80 Summary(pl):    Narzêdzia do plików HDF
81 Group:          Applications/File
82 Requires:       %{name} = %{version}
83
84 %description progs
85 Utilities to convert from/to HDF format.
86
87 %description progs -l pl
88 Narzêdzia do konwersji z i to formatu HDF.
89
90 %prep
91 %setup -q -n HDF%{version}
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96
97 %build
98 install -m755 /usr/share/libtool/config.{guess,sub} .
99 install -m755 /usr/share/libtool/config.{guess,sub} hdf/fmpool
100 install -m755 /usr/share/libtool/config.{guess,sub} hdf/jpeg
101 ./configure %{_target_platform} \
102         --prefix=%{_prefix} \
103         --exec-prefix=%{_exec_prefix}
104
105 %{__make} \
106         libdir=%{_libdir} \
107         LIBDIR=%{_libdir} \
108         CFLAGS="%{rpmcflags} -ansi -D_BSD_SOURCE -DHAVE_NETCDF" \
109         FFLAGS="%{rpmcflags}" \
110         YACC="bison -y" \
111         LTTAG="--tag=F77"
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT{%{_libdir},%{_mandir}/man{3,7},%{_includedir}/hdf}
116
117 %{__make} install \
118         prefix=$RPM_BUILD_ROOT%{_prefix} \
119         libdir=$RPM_BUILD_ROOT%{_libdir} \
120         LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
121         exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
122         mandir=$RPM_BUILD_ROOT%{_mandir} \
123         infodir=$RPM_BUILD_ROOT%{_infodir}
124
125 mv -f $RPM_BUILD_ROOT%{_includedir}/*.{h,inc,f90} $RPM_BUILD_ROOT%{_includedir}/hdf
126
127 install man/gr_chunk.3 $RPM_BUILD_ROOT%{_mandir}/man3
128 mv -f $RPM_BUILD_ROOT%{_mandir}/man1/hdf.1 $RPM_BUILD_ROOT%{_mandir}/man7/hdf.7
129
130 # resolve conflict with netcdf and move manuals to FHS location
131 # NOTE: don't let adapter change %%{_prefix}/man to %%{_mandir}
132 for i in ncdump ncgen ; do
133         mv -f $RPM_BUILD_ROOT%{_bindir}/$i $RPM_BUILD_ROOT%{_bindir}/hdf$i
134         mv -f $RPM_BUILD_ROOT/usr/man/man1/$i.1 $RPM_BUILD_ROOT%{_mandir}/man1/hdf$i.1
135 done
136
137 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc COPYING README release_notes/bugs* release_notes/ABOUT*
148 %attr(755,root,root) %{_libdir}/lib*.so.*.*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %doc release_notes/compile*
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_libdir}/lib*.la
155 %{_includedir}/hdf
156 %{_mandir}/man[37]/*
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/lib*.a
161
162 %files progs
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/*
165 %{_mandir}/man1/*
This page took 0.035575 seconds and 4 git commands to generate.