]> git.pld-linux.org Git - packages/hdf.git/blob - hdf.spec
- added athlon.patch
[packages/hdf.git] / hdf.spec
1 Summary:        Hierarchical Data Format library
2 Summary(pl):    Biblioteka HDF (Hierarchical Data Format)
3 Name:           hdf
4 Version:        4.1r5
5 Release:        2.1
6 Group:          Libraries
7 License:        Nearly BSD, but changed sources must be marked
8 Source0:        ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF_Current/tar/HDF%{version}.tar.gz
9 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
10 Patch0:         %{name}-system-libs.patch
11 Patch1:         %{name}-strdup.patch
12 Patch2:         %{name}-shared.patch
13 Patch3:         %{name}-athlon.patch
14 URL:            http://hdf.ncsa.uiuc.edu/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  gcc-g77
18 BuildRequires:  libjpeg-devel >= 6b
19 BuildRequires:  libtool >= 0:1.4.2
20 BuildRequires:  zlib-devel >= 1.1.3
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 ExclusiveArch:  %{ix86} alpha
23
24 %description
25 HDF is a multi-object file format that facilitates the transfer of
26 various types of scientific data between machines and operating
27 systems. Machines currently supported include the Cray, HP, Vax, Sun,
28 IBM RS/6000, Silicon Graphics, Macintosh, and IBM PC computers. HDF
29 allows self-definitions of data content and easy extensibility for
30 future enhancements or compatibility with other standard formats. HDF
31 includes Fortran and C calling interfaces,and utilities to prepare raw
32 image of data files or for use with other NCSA software. The HDF
33 library contains interfaces for storing and retrieving compressed or
34 uncompressed 8-bit and 24-bit raster images with palettes,
35 n-Dimensional scientific datasets and binary tables. An interface is
36 also included that allows arbitray grouping of other HDF objects.
37
38 %description -l pl
39 HDF jest wieloobiektowym formatem plików u³atwiaj±cym przenoszenie
40 ró¿nych danych naukowych pomiêdzy ró¿nymi komputerami i systemami
41 operacyjnymi. Aktualnie obs³ugiwane s± m.in. Cray, HP, Vax, Sun, IBM
42 RS/6000, Silicon Graphics, Macintosh i IBM PC. HDF zawiera interfejsy
43 do Fortranu i C oraz narzêdzia do przygotowywania plików z danymi.
44 Biblioteka pozwala na przechowywanie i odczytywanie skompresowanych
45 lub nie 8-bitowych i 24-bitowych obrazków z palet±, wielowymiarowych
46 zestawów danych itp.
47
48 %package devel
49 Summary:        HDF library development package
50 Summary(pl):    Pliki nag³ówkowe biblioteki HDF
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}
53
54 %description devel
55 Header files for HDF library.
56
57 %description devel -l pl
58 Pliki nag³ówkowe biblioteki HDF.
59
60 %package static
61 Summary:        HDF static library
62 Summary(pl):    Statyczna biblioteka HDF
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}
65
66 %description static
67 Static version of HDF library.
68
69 %description static -l pl
70 Statyczna wersja biblioteki HDF.
71
72 %package progs
73 Summary:        HDF utilities
74 Summary(pl):    Narzêdzia do plików HDF
75 Group:          Applications/File
76 Requires:       %{name} = %{version}
77
78 %description progs
79 Utilities to convert from/to HDF format.
80
81 %description progs -l pl
82 Narzêdzia do konwersji z i to formatu HDF.
83
84 %prep
85 %setup -q -n HDF%{version}
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90
91 %build
92 ./configure %{_target_platform} \
93         --prefix=%{_prefix} --exec-prefix=%{_exec_prefix}
94
95 # libtool 1.4d requires --tag for g77, but doesn't have good tag for g77
96 grep -q -e '--tag' `which libtool` && LTTAG="--tag=dummy"
97
98 %{__make} CFLAGS="%{rpmcflags} -ansi -D_BSD_SOURCE -DHAVE_NETCDF" \
99         FFLAGS="%{rpmcflags}" YACC="bison -y" LTTAG="$LTTAG"
100
101 # avoid relinking
102 cd mfhdf/libsrc
103 sed -e '/^relink_command/d' libmfhdf.la > libmfhdf.la.tmp
104 mv -f libmfhdf.la.tmp libmfhdf.la
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_libdir},%{_mandir}/man{3,7},%{_includedir}/hdf}
109
110 %{__make} install \
111         prefix=$RPM_BUILD_ROOT%{_prefix} \
112         exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
113         mandir=$RPM_BUILD_ROOT%{_mandir} \
114         infodir=$RPM_BUILD_ROOT%{_infodir}
115
116 mv -f $RPM_BUILD_ROOT%{_includedir}/*.{h,inc,f90} $RPM_BUILD_ROOT%{_includedir}/hdf
117
118 install man/gr_chunk.3 $RPM_BUILD_ROOT%{_mandir}/man3
119 mv -f $RPM_BUILD_ROOT%{_mandir}/man1/hdf.1 $RPM_BUILD_ROOT%{_mandir}/man7/hdf.7
120
121 # resolve conflict with netcdf and move manuals to FHS location
122 # NOTE: don't let adapter change %%{_prefix}/man to %%{_mandir}
123 for i in ncdump ncgen ; do
124         mv -f $RPM_BUILD_ROOT%{_bindir}/$i $RPM_BUILD_ROOT%{_bindir}/hdf$i
125         mv -f $RPM_BUILD_ROOT/usr/man/man1/$i.1 $RPM_BUILD_ROOT%{_mandir}/man1/hdf$i.1
126 done
127
128 # remove unwanted path from libtool script
129 cat $RPM_BUILD_ROOT%{_libdir}/libmfhdf.la | \
130         awk '/^dependency_libs/ { gsub("-L[ \t]*[^ \t]*/\.libs ","") } //' \
131         > $RPM_BUILD_ROOT%{_libdir}/libmfhdf.la.tmp
132 mv -f $RPM_BUILD_ROOT%{_libdir}/libmfhdf.la.tmp $RPM_BUILD_ROOT%{_libdir}/libmfhdf.la
133
134 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc COPYING README release_notes/bugs* release_notes/ABOUT*
145 %attr(755,root,root) %{_libdir}/lib*.so.*.*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc release_notes/compile*
150 %attr(755,root,root) %{_libdir}/lib*.so
151 %{_libdir}/lib*.la
152 %{_includedir}/hdf
153 %{_mandir}/man[37]/*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
158
159 %files progs
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/*
162 %{_mandir}/man1/*
This page took 0.443289 seconds and 4 git commands to generate.