]> git.pld-linux.org Git - packages/hdf.git/blob - hdf.spec
- removed obsolete SWAP workaround
[packages/hdf.git] / hdf.spec
1 #
2 # Conditional build:
3 %bcond_without  szip    # build without SZIP support
4 #
5 Summary:        Hierarchical Data Format library
6 Summary(pl):    Biblioteka HDF (Hierarchical Data Format)
7 Name:           hdf
8 Version:        4.2r1
9 Release:        3
10 Group:          Libraries
11 License:        Nearly BSD, but changed sources must be marked
12 Source0:        ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF_Current/src/HDF%{version}.tar.gz
13 # Source0-md5:  9082c6fa913b9188452fa6c5217e1573
14 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
15 # Source1-md5:  607df78cacc131b37dfdb443e61e789a
16 Patch0:         %{name}-shared.patch
17 Patch1:         %{name}-opt.patch
18 Patch2:         %{name}-morearchs.patch
19 Patch3:         %{name}-nosz.patch
20 URL:            http://hdf.ncsa.uiuc.edu/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  bison
24 BuildRequires:  flex
25 BuildRequires:  gcc-fortran
26 BuildRequires:  groff
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libtool >= 2:1.4d-3
29 BuildRequires:  netcdf-devel
30 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
31 BuildRequires:  which
32 BuildRequires:  zlib-devel >= 1.1.3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 HDF is a multi-object file format that facilitates the transfer of
37 various types of scientific data between machines and operating
38 systems. Machines currently supported include the Cray, HP, Vax, Sun,
39 IBM RS/6000, Silicon Graphics, Macintosh, and IBM PC computers. HDF
40 allows self-definitions of data content and easy extensibility for
41 future enhancements or compatibility with other standard formats. HDF
42 includes Fortran and C calling interfaces,and utilities to prepare raw
43 image of data files or for use with other NCSA software. The HDF
44 library contains interfaces for storing and retrieving compressed or
45 uncompressed 8-bit and 24-bit raster images with palettes,
46 n-Dimensional scientific datasets and binary tables. An interface is
47 also included that allows arbitray grouping of other HDF objects.
48
49 %description -l pl
50 HDF jest wieloobiektowym formatem plików u³atwiaj±cym przenoszenie
51 ró¿nych danych naukowych pomiêdzy ró¿nymi komputerami i systemami
52 operacyjnymi. Aktualnie obs³ugiwane s± m.in. Cray, HP, Vax, Sun, IBM
53 RS/6000, Silicon Graphics, Macintosh i IBM PC. HDF zawiera interfejsy
54 do Fortranu i C oraz narzêdzia do przygotowywania plików z danymi.
55 Biblioteka pozwala na przechowywanie i odczytywanie skompresowanych
56 lub nie 8-bitowych i 24-bitowych obrazków z palet±, wielowymiarowych
57 zestawów danych itp.
58
59 %package devel
60 Summary:        HDF library development package
61 Summary(pl):    Pliki nag³ówkowe biblioteki HDF
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       libjpeg-devel >= 6b
65 %{?with_szip:Requires:  szip-devel >= 2.0}
66 Requires:       zlib-devel >= 1.1.3
67
68 %description devel
69 Header files for HDF library.
70
71 %description devel -l pl
72 Pliki nag³ówkowe biblioteki HDF.
73
74 %package static
75 Summary:        HDF static library
76 Summary(pl):    Statyczna biblioteka HDF
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static version of HDF library.
82
83 %description static -l pl
84 Statyczna wersja biblioteki HDF.
85
86 %package progs
87 Summary:        HDF utilities
88 Summary(pl):    Narzêdzia do plików HDF
89 Group:          Applications/File
90 Requires:       %{name} = %{version}-%{release}
91
92 %description progs
93 Utilities to convert from/to HDF format.
94
95 %description progs -l pl
96 Narzêdzia do konwersji z i do formatu HDF.
97
98 %prep
99 %setup -q -n HDF%{version}
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103 %patch3 -p1
104
105 %build
106 cp -f /usr/share/automake/config.* hdf/fmpool
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 # need to pass F77 to override F77=g77 in config/linux-gnu
113 %configure \
114         F77="%{_target_cpu}-pld-linux-gfortran" \
115         %{?with_szip:--with-szlib}
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT{%{_libdir},%{_mandir}/man{3,7},%{_includedir}/hdf}
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 mv -f $RPM_BUILD_ROOT%{_includedir}/*.{h,inc,f90} $RPM_BUILD_ROOT%{_includedir}/hdf
127
128 install man/gr_chunk.3 $RPM_BUILD_ROOT%{_mandir}/man3
129 mv -f $RPM_BUILD_ROOT%{_mandir}/man1/hdf.1 $RPM_BUILD_ROOT%{_mandir}/man7/hdf.7
130
131 # resolve conflict with netcdf
132 for i in ncdump ncgen ; do
133         mv -f $RPM_BUILD_ROOT%{_bindir}/$i $RPM_BUILD_ROOT%{_bindir}/hdf$i
134         mv -f $RPM_BUILD_ROOT%{_mandir}/man1/$i.1 $RPM_BUILD_ROOT%{_mandir}/man1/hdf$i.1
135 done
136
137 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc COPYING README release_notes/*
148 %attr(755,root,root) %{_libdir}/libdf.so.*.*
149 %attr(755,root,root) %{_libdir}/libmfhdf.so.*.*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libdf.so
154 %attr(755,root,root) %{_libdir}/libmfhdf.so
155 %{_libdir}/libdf.la
156 %{_libdir}/libmfhdf.la
157 %{_includedir}/hdf
158 %{_mandir}/man[37]/*
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/libdf.a
163 %{_libdir}/libmfhdf.a
164
165 %files progs
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/*
168 %{_mandir}/man1/*
This page took 0.217064 seconds and 4 git commands to generate.