]> git.pld-linux.org Git - packages/hdf.git/blob - hdf.spec
- updated to 4.2r1, updated shared,opt patches, added nosz patch
[packages/hdf.git] / hdf.spec
1 #
2 # Conditional build:
3 %bcond_without  szip    # build without SZIP support
4 #
5 Summary:        Hierarchical Data Format library
6 Summary(pl):    Biblioteka HDF (Hierarchical Data Format)
7 Name:           hdf
8 Version:        4.2r1
9 Release:        1
10 Group:          Libraries
11 License:        Nearly BSD, but changed sources must be marked
12 Source0:        ftp://ftp.ncsa.uiuc.edu/HDF/HDF/HDF_Current/src/HDF%{version}.tar.gz
13 # Source0-md5:  9082c6fa913b9188452fa6c5217e1573
14 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
15 # Source1-md5:  607df78cacc131b37dfdb443e61e789a
16 Patch0:         %{name}-shared.patch
17 Patch1:         %{name}-opt.patch
18 Patch2:         %{name}-morearchs.patch
19 Patch3:         %{name}-nosz.patch
20 URL:            http://hdf.ncsa.uiuc.edu/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  bison
24 BuildRequires:  flex
25 BuildRequires:  gcc-g77
26 BuildRequires:  groff
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libtool >= 2:1.4d-3
29 %{?with_szip:BuildRequires:     szip-devel >= 2.0}
30 BuildRequires:  which
31 BuildRequires:  zlib-devel >= 1.1.3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 HDF is a multi-object file format that facilitates the transfer of
36 various types of scientific data between machines and operating
37 systems. Machines currently supported include the Cray, HP, Vax, Sun,
38 IBM RS/6000, Silicon Graphics, Macintosh, and IBM PC computers. HDF
39 allows self-definitions of data content and easy extensibility for
40 future enhancements or compatibility with other standard formats. HDF
41 includes Fortran and C calling interfaces,and utilities to prepare raw
42 image of data files or for use with other NCSA software. The HDF
43 library contains interfaces for storing and retrieving compressed or
44 uncompressed 8-bit and 24-bit raster images with palettes,
45 n-Dimensional scientific datasets and binary tables. An interface is
46 also included that allows arbitray grouping of other HDF objects.
47
48 %description -l pl
49 HDF jest wieloobiektowym formatem plików u³atwiaj±cym przenoszenie
50 ró¿nych danych naukowych pomiêdzy ró¿nymi komputerami i systemami
51 operacyjnymi. Aktualnie obs³ugiwane s± m.in. Cray, HP, Vax, Sun, IBM
52 RS/6000, Silicon Graphics, Macintosh i IBM PC. HDF zawiera interfejsy
53 do Fortranu i C oraz narzêdzia do przygotowywania plików z danymi.
54 Biblioteka pozwala na przechowywanie i odczytywanie skompresowanych
55 lub nie 8-bitowych i 24-bitowych obrazków z palet±, wielowymiarowych
56 zestawów danych itp.
57
58 %package devel
59 Summary:        HDF library development package
60 Summary(pl):    Pliki nag³ówkowe biblioteki HDF
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       libjpeg-devel >= 6b
64 %{?with_szip:Requires:  szip-devel >= 2.0}
65 Requires:       zlib-devel >= 1.1.3
66
67 %description devel
68 Header files for HDF library.
69
70 %description devel -l pl
71 Pliki nag³ówkowe biblioteki HDF.
72
73 %package static
74 Summary:        HDF static library
75 Summary(pl):    Statyczna biblioteka HDF
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static version of HDF library.
81
82 %description static -l pl
83 Statyczna wersja biblioteki HDF.
84
85 %package progs
86 Summary:        HDF utilities
87 Summary(pl):    Narzêdzia do plików HDF
88 Group:          Applications/File
89 Requires:       %{name} = %{version}-%{release}
90
91 %description progs
92 Utilities to convert from/to HDF format.
93
94 %description progs -l pl
95 Narzêdzia do konwersji z i do formatu HDF.
96
97 %prep
98 %setup -q -n HDF%{version}
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102 %patch3 -p1
103
104 %ifarch ppc ppc64 sparc sparcv9 sparc64
105 %{__perl} -pi -e 's/^SWAP.*$/SWAP=/' config/mh-linux
106 %endif
107
108 %build
109 cp -f /usr/share/automake/config.* hdf/fmpool
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         %{?with_szip:--with-szlib}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{_libdir},%{_mandir}/man{3,7},%{_includedir}/hdf}
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 mv -f $RPM_BUILD_ROOT%{_includedir}/*.{h,inc,f90} $RPM_BUILD_ROOT%{_includedir}/hdf
128
129 install man/gr_chunk.3 $RPM_BUILD_ROOT%{_mandir}/man3
130 mv -f $RPM_BUILD_ROOT%{_mandir}/man1/hdf.1 $RPM_BUILD_ROOT%{_mandir}/man7/hdf.7
131
132 # resolve conflict with netcdf
133 for i in ncdump ncgen ; do
134         mv -f $RPM_BUILD_ROOT%{_bindir}/$i $RPM_BUILD_ROOT%{_bindir}/hdf$i
135         mv -f $RPM_BUILD_ROOT%{_mandir}/man1/$i.1 $RPM_BUILD_ROOT%{_mandir}/man1/hdf$i.1
136 done
137
138 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc COPYING README release_notes/*
149 %attr(755,root,root) %{_libdir}/libdf.so.*.*
150 %attr(755,root,root) %{_libdir}/libmfhdf.so.*.*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libdf.so
155 %attr(755,root,root) %{_libdir}/libmfhdf.so
156 %{_libdir}/libdf.la
157 %{_libdir}/libmfhdf.la
158 %{_includedir}/hdf
159 %{_mandir}/man[37]/*
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/libdf.a
164 %{_libdir}/libmfhdf.a
165
166 %files progs
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_bindir}/*
169 %{_mandir}/man1/*
This page took 0.076337 seconds and 3 git commands to generate.