]> git.pld-linux.org Git - packages/gupnp.git/blob - gupnp.spec
- updated to 0.20.0
[packages/gupnp.git] / gupnp.spec
1 #
2 # Conditional build:
3 %bcond_without  vala    # Vala API
4 #
5 Summary:        UPnP library based on GObject and libsoup
6 Summary(pl.UTF-8):      Biblioteka UPnP oparta na bibliotekach GObject i libsoup
7 Name:           gupnp
8 # note: 0.20.x is stable, 0.21.x unstable
9 Version:        0.20.0
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp/0.20/%{name}-%{version}.tar.xz
14 # Source0-md5:  5d6403a0521b33a904e4c118d2188751
15 URL:            http://gupnp.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  docbook-dtd44-xml
20 BuildRequires:  glib2-devel >= 1:2.26.0
21 BuildRequires:  gobject-introspection-devel >= 0.6.4
22 BuildRequires:  gssdp-devel >= 0.13.0
23 BuildRequires:  gtk-doc >= 1.0
24 BuildRequires:  libsoup-devel >= 2.28.2
25 BuildRequires:  libtool >= 2:2.2
26 BuildRequires:  libuuid-devel >= 1.36
27 BuildRequires:  libxml2-devel >= 1:2.6.30
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  tar >= 1:1.22
31 %{?with_vala:BuildRequires:     vala >= 2:0.14}
32 BuildRequires:  xz
33 Requires:       glib2 >= 1:2.26.0
34 Requires:       gssdp >= 0.13.0
35 Requires:       libsoup >= 2.28.2
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GUPnP is an object-oriented open source framework for creating UPnP
40 devices and control points, written in C using GObject and libsoup.
41 The GUPnP API is intended to be easy to use, efficient and flexible.
42
43 %description -l pl.UTF-8
44 GUPnp to zorientowany obiektowo, mający otwarte źródła szkielet do
45 tworzenia urządzeń i punktów sterujących UPnP, napisany w C z użyciem
46 bibliotek GObject i libsoup. API GUPnp ma być łatwe w użyciu, wydajne
47 i elastyczne.
48
49 %package devel
50 Summary:        Header files for gupnp
51 Summary(pl.UTF-8):      Pliki nagłówkowe gupnp
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel >= 1:2.26.0
55 Requires:       gssdp-devel >= 0.13.0
56 Requires:       libsoup-devel >= 2.28.2
57 Requires:       libuuid-devel >= 1.36
58 Requires:       libxml2-devel >= 1:2.6.30
59
60 %description devel
61 This package contains header files for the Linux SDK for UPnP Devices
62 (gupnp).
63
64 %description devel -l pl.UTF-8
65 Ten pakiet zawiera pliki nagłówkowe dla linuksowego pakietu
66 programistycznego do urządzeń UPnP (gupnp).
67
68 %package static
69 Summary:        Static gupnp libraries
70 Summary(pl.UTF-8):      Statyczne biblioteki gupnp
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static gupnp libraries.
76
77 %description static -l pl.UTF-8
78 Statyczne biblioteki gupnp.
79
80 %package apidocs
81 Summary:        gupnp API documentation
82 Summary(pl.UTF-8):      Dokumentacja API gupnp
83 Group:          Documentation
84 Requires:       gtk-doc-common
85
86 %description apidocs
87 gupnp API documentation.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API gupnp.
91
92 %package -n vala-gupnp
93 Summary:        Vala API for gupnp library
94 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97 Requires:       vala >= 2:0.14
98 Requires:       vala-gssdp >= 0.13.0
99
100 %description -n vala-gupnp
101 Vala API for gupnp library.
102
103 %description -n vala-gupnp -l pl.UTF-8
104 API języka Vala dla biblioteki gupnp.
105
106 %prep
107 %setup -q
108
109 %build
110 %{__gtkdocize}
111 %{__libtoolize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --disable-silent-rules \
118         --enable-gtk-doc \
119         --with-html-dir=%{_gtkdocdir} \
120         --with-context-manager=network-manager
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog NEWS README
141 %attr(755,root,root) %{_bindir}/gupnp-binding-tool
142 %attr(755,root,root) %{_libdir}/libgupnp-1.0.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libgupnp-1.0.so.4
144 %{_libdir}/girepository-1.0/GUPnP-1.0.typelib
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libgupnp-1.0.so
149 %{_datadir}/gir-1.0/GUPnP-1.0.gir
150 %{_includedir}/gupnp-1.0
151 %{_pkgconfigdir}/gupnp-1.0.pc
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libgupnp-1.0.a
156
157 %files apidocs
158 %defattr(644,root,root,755)
159 %{_gtkdocdir}/gupnp
160
161 %if %{with vala}
162 %files -n vala-gupnp
163 %defattr(644,root,root,755)
164 %{_datadir}/vala/vapi/gupnp-1.0.deps
165 %{_datadir}/vala/vapi/gupnp-1.0.vapi
166 %endif
This page took 0.030346 seconds and 3 git commands to generate.