]> git.pld-linux.org Git - packages/gtkmm4.git/blob - gtkmm3.spec
b3e77ffd344676a206e58dd1b93de8404dbf4b65
[packages/gtkmm4.git] / gtkmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 %define         glibmm_ver      2.38.0
6 %define         gtk3_ver        3.10.0
7 Summary:        A C++ interface for the GTK+ (a GUI library for X)
8 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
9 Name:           gtkmm3
10 Version:        3.10.1
11 Release:        1
12 License:        LGPL v2+
13 Group:          X11/Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/3.10/gtkmm-%{version}.tar.xz
15 # Source0-md5:  993c6a53b8c736a475fcbb1fd4e9c393
16 URL:            http://www.gtkmm.org/
17 BuildRequires:  atkmm-devel >= 2.22.2
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  cairomm-devel >= 1.9.2
21 BuildRequires:  gdk-pixbuf2-devel >= 2.22.1
22 BuildRequires:  glibmm-devel >= %{glibmm_ver}
23 BuildRequires:  gtk+3-devel >= %{gtk3_ver}
24 BuildRequires:  libsigc++-devel
25 BuildRequires:  libstdc++-devel >= 5:3.3.1
26 BuildRequires:  libtool >= 2:2.0
27 BuildRequires:  mm-common >= 0.9.6
28 BuildRequires:  pangomm-devel >= 2.28.0
29 BuildRequires:  perl-base >= 1:5.6.0
30 BuildRequires:  pkgconfig
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 Requires:       atkmm >= 2.22.2
34 Requires:       cairomm >= 1.9.2
35 Requires:       gdk-pixbuf2 >= 2.22.1
36 Requires:       glibmm >= %{glibmm_ver}
37 Requires:       gtk+3 >= %{gtk3_ver}
38 Requires:       pangomm >= 2.28.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
43 library. The interface provides a convenient interface for C++
44 programmers to create GUIs with GTK+'s flexible object-oriented
45 framework. Features include type safe callbacks, widgets that are
46 extensible using inheritance and over 110 classes that can be freely
47 combined to quickly create complex user interfaces.
48
49 %description -l pl.UTF-8
50 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
51 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
52 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
53
54 %package devel
55 Summary:        gtkmm and gdkmm header files
56 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       atkmm-devel >= 2.22.2
60 Requires:       cairomm-devel >= 1.9.2
61 Requires:       gdk-pixbuf2-devel >= 2.22.1
62 Requires:       glibmm-devel >= %{glibmm_ver}
63 Requires:       gtk+3-devel >= %{gtk3_ver}
64 Requires:       pangomm-devel >= 2.28.0
65
66 %description devel
67 Header files for gtkmm library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki gtkmm.
71
72 %package static
73 Summary:        gtkmm and gdkmm static libraries
74 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
75 Group:          X11/Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 gtkmm and gdkmm static libraries.
80
81 %description static -l pl.UTF-8
82 Biblioteki statyczne gtkmm i gdkmm.
83
84 %package apidocs
85 Summary:        Reference documentation for gtkmm and gdkmm
86 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
87 Group:          Documentation
88 Requires:       devhelp
89
90 %description apidocs
91 Reference documentation for gtkmm and gdkmm.
92
93 %description apidocs -l pl.UTF-8
94 Szczegółowa dokumentacja gtkmm i gdkmm.
95
96 %prep
97 %setup -q -n gtkmm-%{version}
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I build
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         %{?with_static_libs:--enable-static}
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS PORTING README
127 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
129 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
135 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
136 %{_libdir}/gdkmm-3.0
137 %{_libdir}/gtkmm-3.0
138 %{_includedir}/gdkmm-3.0
139 %{_includedir}/gtkmm-3.0
140 %{_pkgconfigdir}/gdkmm-3.0.pc
141 %{_pkgconfigdir}/gtkmm-3.0.pc
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libgdkmm-3.0.a
147 %{_libdir}/libgtkmm-3.0.a
148 %endif
149
150 %files apidocs
151 %defattr(644,root,root,755)
152 %{_docdir}/gtkmm-3.0
153 %{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.090337 seconds and 3 git commands to generate.