]> git.pld-linux.org Git - packages/gtkmm.git/blob - gtkmm.spec
- updated to 2.18.2
[packages/gtkmm.git] / gtkmm.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        A C++ interface for the GTK+ (a GUI library for X)
6 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
7 Name:           gtkmm
8 Version:        2.18.2
9 Release:        1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.18/%{name}-%{version}.tar.bz2
13 # Source0-md5:  3e43e9eef1da8988a76a2815d6b31c91
14 URL:            http://www.gtkmm.org/
15 BuildRequires:  atk-devel >= 1:1.24.0
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  cairomm-devel >= 1.6.3
19 BuildRequires:  glibmm-devel >= 2.22.0
20 BuildRequires:  gtk+2-devel >= 2:2.18.0
21 BuildRequires:  libsigc++-devel
22 BuildRequires:  libstdc++-devel >= 5:3.3.1
23 BuildRequires:  libtool >= 2:1.4d-3
24 BuildRequires:  mm-common >= 0.8
25 BuildRequires:  pangomm-devel >= 2.26.0
26 BuildRequires:  perl-base >= 1:5.6.0
27 BuildRequires:  pkgconfig
28 Requires:       %{name}-atk = %{version}-%{release}
29 Requires:       cairomm >= 1.6.3
30 Requires:       glibmm >= 2.22.0
31 Requires:       gtk+2 >= 2:2.18.0
32 Requires:       pangomm >= 2.26.0
33 Obsoletes:      Gtk--
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
38 library. The interface provides a convenient interface for C++
39 programmers to create GUIs with GTK+'s flexible object-oriented
40 framework. Features include type safe callbacks, widgets that are
41 extensible using inheritance and over 110 classes that can be freely
42 combined to quickly create complex user interfaces.
43
44 %description -l pl.UTF-8
45 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
46 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
47 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
48
49 %package devel
50 Summary:        gtkmm and gdkmm header files
51 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       %{name}-atk-devel = %{version}-%{release}
55 Requires:       glibmm-devel >= 2.22.0
56 Requires:       gtk+2-devel >= 2:2.18.0
57 Requires:       pangomm-devel >= 2.26.0
58
59 %description devel
60 Header files for gtkmm library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki gtkmm.
64
65 %package doc
66 Summary:        Reference documentation for gtkmm and gdkmm
67 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
68 Group:          Documentation
69 Requires:       devhelp
70
71 %description doc
72 Reference documentation for gtkmm and gdkmm.
73
74 %description doc -l pl.UTF-8
75 Szczegółowa dokumentacja gtkmm i gdkmm.
76
77 %package static
78 Summary:        gtkmm and gdkmm static libraries
79 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
80 Group:          X11/Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 gtkmm and gdkmm static libraries.
85
86 %description static -l pl.UTF-8
87 Biblioteki statyczne gtkmm i gdkmm.
88
89 %package atk
90 Summary:        A C++ interface for atk library
91 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk
92 Group:          X11/Libraries
93 Requires:       atk >= 1:1.24.0
94 Requires:       glibmm >= 2.22.0
95
96 %description atk
97 A C++ interface for atk library.
98
99 %description atk -l pl.UTF-8
100 Interfejs C++ dla biblioteki atk.
101
102 %package atk-devel
103 Summary:        A C++ interface for atk library - header files
104 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - pliki nagłówkowe
105 Group:          X11/Development/Libraries
106 Requires:       %{name}-atk = %{version}-%{release}
107 Requires:       atk-devel >= 1:1.24.0
108 Requires:       glibmm-devel >= 2.22.0
109
110 %description atk-devel
111 A C++ interface for atk library - header files.
112
113 %description atk-devel -l pl.UTF-8
114 Interfejs C++ dla biblioteki atk - pliki nagłówkowe.
115
116 %package atk-static
117 Summary:        A C++ interface for atk library - static version
118 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - wersja statyczna
119 Group:          X11/Development/Libraries
120 Requires:       %{name}-atk-devel = %{version}-%{release}
121
122 %description atk-static
123 A C++ interface for atk library - static version.
124
125 %description atk-static -l pl.UTF-8
126 Interfejs C++ dla biblioteki atk - wersja statyczna.
127
128 %prep
129 %setup -q
130
131 %build
132 %{__libtoolize}
133 %{__aclocal} -I build
134 %{__autoconf}
135 %{__automake}
136 %configure \
137         --disable-demos \
138         %{?with_static_libs:--enable-static}
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %post   atk -p /sbin/ldconfig
155 %postun atk -p /sbin/ldconfig
156
157 %files
158 %defattr(644,root,root,755)
159 %doc AUTHORS ChangeLog NEWS PORTING README
160 %attr(755,root,root) %{_libdir}/libgdkmm-2.4.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-2.4.so.1
162 %attr(755,root,root) %{_libdir}/libgtkmm-2.4.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-2.4.so.1
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libgdkmm-2.4.so
168 %attr(755,root,root) %{_libdir}/libgtkmm-2.4.so
169 %{_libdir}/libgdkmm-2.4.la
170 %{_libdir}/libgtkmm-2.4.la
171 %{_libdir}/gdkmm-2.4
172 %{_libdir}/gtkmm-2.4
173 %{_includedir}/gdkmm-2.4
174 %{_includedir}/gtkmm-2.4
175 %{_pkgconfigdir}/gdkmm-2.4.pc
176 %{_pkgconfigdir}/gtkmm-2.4.pc
177
178 %files doc
179 %defattr(644,root,root,755)
180 %{_docdir}/gtkmm-2.4
181 %{_datadir}/devhelp/books/gtkmm-2.4
182
183 %if %{with static_libs}
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libgdkmm-2.4.a
187 %{_libdir}/libgtkmm-2.4.a
188 %endif
189
190 %files atk
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libatkmm-1.6.so.*.*.*
193 %attr(755,root,root) %ghost %{_libdir}/libatkmm-1.6.so.1
194
195 %files atk-devel
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/libatkmm-1.6.so
198 %{_libdir}/libatkmm-1.6.la
199 %{_pkgconfigdir}/atkmm-1.6.pc
200 %{_includedir}/atkmm-1.6
201
202 %if %{with static_libs}
203 %files atk-static
204 %defattr(644,root,root,755)
205 %{_libdir}/libatkmm-1.6.a
206 %endif
This page took 0.035861 seconds and 3 git commands to generate.