]> git.pld-linux.org Git - packages/gtkmm.git/blob - gtkmm.spec
77d4f1793a184d0712473ab59afbd8e48c17383e
[packages/gtkmm.git] / gtkmm.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        A C++ interface for the GTK+ (a GUI library for X)
6 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
7 Name:           gtkmm
8 Version:        2.14.1
9 Release:        1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.14/%{name}-%{version}.tar.bz2
13 # Source0-md5:  0209b424987a74c956ea6b70fddaaa37
14 URL:            http://www.gtkmm.org/
15 BuildRequires:  atk-devel >= 1:1.24.0
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  cairomm-devel >= 1.6.3
19 BuildRequires:  glibmm-devel >= 2.18.0
20 BuildRequires:  gtk+2-devel >= 2:2.14.0
21 BuildRequires:  libstdc++-devel >= 5:3.3.1
22 BuildRequires:  libtool >= 2:1.4d-3
23 BuildRequires:  pangomm-devel >= 2.14.0
24 BuildRequires:  perl-base >= 1:5.6.0
25 BuildRequires:  pkgconfig
26 Requires:       %{name}-atk = %{version}-%{release}
27 Requires:       cairomm >= 1.6.3
28 Requires:       glibmm >= 2.18.0
29 Requires:       gtk+2 >= 2:2.14.0
30 Requires:       pangomm >= 2.14.0
31 Obsoletes:      Gtk--
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
36 library. The interface provides a convenient interface for C++
37 programmers to create GUIs with GTK+'s flexible object-oriented
38 framework. Features include type safe callbacks, widgets that are
39 extensible using inheritance and over 110 classes that can be freely
40 combined to quickly create complex user interfaces.
41
42 %description -l pl.UTF-8
43 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
44 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
45 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
46
47 %package devel
48 Summary:        gtkmm and gdkmm header files
49 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       %{name}-atk-devel = %{version}-%{release}
53 Requires:       glibmm-devel >= 2.18.0
54 Requires:       gtk+2-devel >= 2:2.14.0
55 Requires:       pangomm-devel >= 2.14.0
56
57 %description devel
58 Header files for gtkmm library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki gtkmm.
62
63 %package doc
64 Summary:        Reference documentation for gtkmm and gdkmm
65 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
66 Group:          Documentation
67 Requires:       devhelp
68
69 %description doc
70 Reference documentation for gtkmm and gdkmm.
71
72 %description doc -l pl.UTF-8
73 Szczegółowa dokumentacja gtkmm i gdkmm.
74
75 %package static
76 Summary:        gtkmm and gdkmm static libraries
77 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
78 Group:          X11/Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 gtkmm and gdkmm static libraries.
83
84 %description static -l pl.UTF-8
85 Biblioteki statyczne gtkmm i gdkmm.
86
87 %package atk
88 Summary:        A C++ interface for atk library
89 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk
90 Group:          X11/Libraries
91 Requires:       atk >= 1:1.24.0
92 Requires:       glibmm >= 2.18.0
93
94 %description atk
95 A C++ interface for atk library.
96
97 %description atk -l pl.UTF-8
98 Interfejs C++ dla biblioteki atk.
99
100 %package atk-devel
101 Summary:        A C++ interface for atk library - header files
102 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - pliki nagłówkowe
103 Group:          X11/Development/Libraries
104 Requires:       %{name}-atk = %{version}-%{release}
105 Requires:       atk-devel >= 1:1.24.0
106 Requires:       glibmm-devel >= 2.18.0
107
108 %description atk-devel
109 A C++ interface for atk library - header files.
110
111 %description atk-devel -l pl.UTF-8
112 Interfejs C++ dla biblioteki atk - pliki nagłówkowe.
113
114 %package atk-static
115 Summary:        A C++ interface for atk library - static version
116 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - wersja statyczna
117 Group:          X11/Development/Libraries
118 Requires:       %{name}-atk-devel = %{version}-%{release}
119
120 %description atk-static
121 A C++ interface for atk library - static version.
122
123 %description atk-static -l pl.UTF-8
124 Interfejs C++ dla biblioteki atk - wersja statyczna.
125
126 %prep
127 %setup -q
128
129 %build
130 %{__libtoolize}
131 %{__aclocal} -I scripts
132 %{__autoconf}
133 %{__automake}
134 %configure \
135         --disable-demos \
136         %{?with_static_libs:--enable-static}
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %post   atk -p /sbin/ldconfig
153 %postun atk -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog CHANGES NEWS PORTING README
158 %attr(755,root,root) %{_libdir}/libgdkmm-2.4.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-2.4.so.1
160 %attr(755,root,root) %{_libdir}/libgtkmm-2.4.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-2.4.so.1
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libgdkmm-2.4.so
166 %attr(755,root,root) %{_libdir}/libgtkmm-2.4.so
167 %{_libdir}/libgdkmm-2.4.la
168 %{_libdir}/libgtkmm-2.4.la
169 %{_libdir}/gdkmm-2.4
170 %{_libdir}/gtkmm-2.4
171 %{_includedir}/gdkmm-2.4
172 %{_includedir}/gtkmm-2.4
173 %{_pkgconfigdir}/gdkmm-2.4.pc
174 %{_pkgconfigdir}/gtkmm-2.4.pc
175
176 %files doc
177 %defattr(644,root,root,755)
178 %{_docdir}/gtkmm-2.4
179 %{_datadir}/devhelp/books/gtkmm-2.4
180
181 %if %{with static_libs}
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/libgdkmm-2.4.a
185 %{_libdir}/libgtkmm-2.4.a
186 %endif
187
188 %files atk
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libatkmm-1.6.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libatkmm-1.6.so.1
192
193 %files atk-devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libatkmm-1.6.so
196 %{_libdir}/libatkmm-1.6.la
197 %{_pkgconfigdir}/atkmm-1.6.pc
198 %{_includedir}/atkmm-1.6
199
200 %if %{with static_libs}
201 %files atk-static
202 %defattr(644,root,root,755)
203 %{_libdir}/libatkmm-1.6.a
204 %endif
This page took 0.039298 seconds and 2 git commands to generate.