]> git.pld-linux.org Git - packages/gtkmm.git/blob - gtkmm.spec
5abd12ee38f40a48c22a269bfaf61c8b5d180a54
[packages/gtkmm.git] / gtkmm.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        A C++ interface for the GTK+ (a GUI library for X)
6 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
7 Name:           gtkmm
8 Version:        2.24.0
9 Release:        0.1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.24/%{name}-%{version}.tar.bz2
13 # Source0-md5:  d0413781fdb884e0ccba52844c94485f
14 URL:            http://www.gtkmm.org/
15 BuildRequires:  atkmm-devel >= 2.22.0
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  cairomm-devel >= 1.6.3
19 BuildRequires:  glibmm-devel >= 2.24.0
20 BuildRequires:  gtk+2-devel >= 2:2.24.0
21 BuildRequires:  libsigc++-devel
22 BuildRequires:  libstdc++-devel >= 5:3.3.1
23 BuildRequires:  libtool >= 2:1.4d-3
24 BuildRequires:  mm-common >= 0.8
25 BuildRequires:  pangomm-devel >= 2.27.1
26 BuildRequires:  perl-base >= 1:5.6.0
27 BuildRequires:  pkgconfig
28 Requires:       atkmm >= 2.22.0
29 Requires:       cairomm >= 1.6.3
30 Requires:       glibmm >= 2.24.0
31 Requires:       gtk+2 >= 2:2.20.0
32 Requires:       pangomm >= 2.26.0
33 Obsoletes:      Gtk--
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
38 library. The interface provides a convenient interface for C++
39 programmers to create GUIs with GTK+'s flexible object-oriented
40 framework. Features include type safe callbacks, widgets that are
41 extensible using inheritance and over 110 classes that can be freely
42 combined to quickly create complex user interfaces.
43
44 %description -l pl.UTF-8
45 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
46 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
47 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
48
49 %package devel
50 Summary:        gtkmm and gdkmm header files
51 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       atkmm-devel >= 2.22.0
55 Requires:       glibmm-devel >= 2.24.0
56 Requires:       gtk+2-devel >= 2:2.20.0
57 Requires:       pangomm-devel >= 2.26.0
58
59 %description devel
60 Header files for gtkmm library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki gtkmm.
64
65 %package doc
66 Summary:        Reference documentation for gtkmm and gdkmm
67 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
68 Group:          Documentation
69 Requires:       devhelp
70
71 %description doc
72 Reference documentation for gtkmm and gdkmm.
73
74 %description doc -l pl.UTF-8
75 Szczegółowa dokumentacja gtkmm i gdkmm.
76
77 %package static
78 Summary:        gtkmm and gdkmm static libraries
79 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
80 Group:          X11/Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 gtkmm and gdkmm static libraries.
85
86 %description static -l pl.UTF-8
87 Biblioteki statyczne gtkmm i gdkmm.
88
89 %prep
90 %setup -q
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I build
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         %{?with_static_libs:--enable-static}
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS PORTING README
120 %attr(755,root,root) %{_libdir}/libgdkmm-2.4.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-2.4.so.1
122 %attr(755,root,root) %{_libdir}/libgtkmm-2.4.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-2.4.so.1
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libgdkmm-2.4.so
128 %attr(755,root,root) %{_libdir}/libgtkmm-2.4.so
129 %{_libdir}/gdkmm-2.4
130 %{_libdir}/gtkmm-2.4
131 %{_includedir}/gdkmm-2.4
132 %{_includedir}/gtkmm-2.4
133 %{_pkgconfigdir}/gdkmm-2.4.pc
134 %{_pkgconfigdir}/gtkmm-2.4.pc
135
136 %files doc
137 %defattr(644,root,root,755)
138 %{_docdir}/gtkmm-2.4
139 %{_datadir}/devhelp/books/gtkmm-2.4
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libgdkmm-2.4.a
145 %{_libdir}/libgtkmm-2.4.a
146 %endif
This page took 0.069029 seconds and 2 git commands to generate.