]> git.pld-linux.org Git - packages/gtkmm.git/blob - gtkmm.spec
- check C++ compiler before using it (fixes build with libtool 2.2)
[packages/gtkmm.git] / gtkmm.spec
1 # TODO
2 # - think of eliminating cpp runtime dep, as cpp pulls gcc
3 #
4 # Conditional build:
5 %bcond_without  examples        # don't build examples
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        A C++ interface for the GTK+ (a GUI library for X)
10 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
11 Name:           gtkmm
12 Version:        2.12.3
13 Release:        1
14 License:        LGPL v2+
15 Group:          X11/Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.12/%{name}-%{version}.tar.bz2
17 # Source0-md5:  d7e47028df7867d85372d82d9fb1d8b6
18 URL:            http://gtkmm.sourceforge.net/
19 BuildRequires:  atk-devel >= 1:1.20.0
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  cairomm-devel >= 1.4.4
23 BuildRequires:  glibmm-devel >= 2.14.1
24 BuildRequires:  gtk+2-devel >= 2:2.12.0
25 BuildRequires:  libstdc++-devel >= 5:3.3.1
26 BuildRequires:  libtool >= 2:1.4d-3
27 BuildRequires:  pango-devel >= 1:1.18.1
28 BuildRequires:  perl-base >= 1:5.6.0
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpm-perlprov >= 3.0.3-16
31 Requires:       %{name}-atk = %{version}-%{release}
32 Requires:       %{name}-pango = %{version}-%{release}
33 Requires:       cairomm >= 1.4.4
34 Requires:       cpp
35 Requires:       gtk+2 >= 2:2.12.0
36 Obsoletes:      Gtk--
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
41 library. The interface provides a convenient interface for C++
42 programmers to create GUIs with GTK+'s flexible object-oriented
43 framework. Features include type safe callbacks, widgets that are
44 extensible using inheritance and over 110 classes that can be freely
45 combined to quickly create complex user interfaces.
46
47 %description -l pl.UTF-8
48 GTK-- jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
49 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
50 także biblioteka GDK-- - wrapper C++ dla GDK (General Drawing Kit).
51
52 %package devel
53 Summary:        GTK-- and GDK-- header files, development documentation
54 Summary(pl.UTF-8):      Pliki nagłówkowe GTK-- i GDK--, dokumentacja dla programistów
55 Group:          X11/Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       %{name}-atk-devel = %{version}-%{release}
58 Requires:       %{name}-pango-devel = %{version}-%{release}
59 Requires:       gtk+2-devel >= 2:2.12.0
60
61 %description devel
62 Header files and development documentation for GTK-- library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe i dokumentacja dla programistów do biblioteki GTK--.
66
67 %package doc
68 Summary:        Reference documentation and examples for GTK-- and GDK--
69 Summary(pl.UTF-8):      Szczegółowa dokumentacja i przykłady dla GTK-- i GDK--
70 Group:          Documentation
71 Requires:       devhelp
72
73 %description doc
74 Reference documentation and examples for GTK-- and GDK--.
75
76 %description doc -l pl.UTF-8
77 Szczegółowa dokumentacja i przykłady dla GTK-- i GDK--.
78
79 %package static
80 Summary:        GTK-- and GDK-- static libraries
81 Summary(pl.UTF-8):      Biblioteki statyczne GTK-- i GDK--
82 Group:          X11/Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 GTK-- and GDK-- static libraries.
87
88 %description static -l pl.UTF-8
89 Biblioteki statyczne GTK-- i GDK--.
90
91 %package atk
92 Summary:        A C++ interface for atk library
93 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk
94 Group:          X11/Development/Libraries
95 Requires:       atk >= 1:1.20.0
96 Requires:       glibmm >= 2.14.1
97
98 %description atk
99 A C++ interface for atk library.
100
101 %description atk -l pl.UTF-8
102 Interfejs C++ dla biblioteki atk.
103
104 %package atk-devel
105 Summary:        A C++ interface for atk library - header files
106 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - pliki nagłówkowe
107 Group:          X11/Development/Libraries
108 Requires:       %{name}-atk = %{version}-%{release}
109 Requires:       atk-devel >= 1:1.20.0
110 Requires:       glibmm-devel >= 2.14.1
111
112 %description atk-devel
113 A C++ interface for atk library - header files.
114
115 %description atk-devel -l pl.UTF-8
116 Interfejs C++ dla biblioteki atk - pliki nagłówkowe.
117
118 %package atk-static
119 Summary:        A C++ interface for atk library - static version
120 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki atk - wersja statyczna
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-atk-devel = %{version}-%{release}
123
124 %description atk-static
125 A C++ interface for atk library - static version.
126
127 %description atk-static -l pl.UTF-8
128 Interfejs C++ dla biblioteki atk - wersja statyczna.
129
130 %package pango
131 Summary:        A C++ interface for pango library
132 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki pango
133 Group:          X11/Development/Libraries
134 Requires:       cairomm >= 1.4.4
135 Requires:       glibmm >= 2.14.1
136 Requires:       pango >= 1:1.18.1
137
138 %description pango
139 A C++ interface for pango library.
140
141 %description pango -l pl.UTF-8
142 Interfejs C++ dla biblioteki pango.
143
144 %package pango-devel
145 Summary:        A C++ interface for pango library - header files
146 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki pango - pliki nagłówkowe
147 Group:          X11/Development/Libraries
148 Requires:       %{name}-pango = %{version}-%{release}
149 Requires:       cairomm-devel >= 1.4.4
150 Requires:       glibmm-devel >= 2.14.1
151 Requires:       pango-devel >= 1:1.18.1
152
153 %description pango-devel
154 A C++ interface for pango library - header files.
155
156 %description pango-devel -l pl.UTF-8
157 Interfejs C++ dla biblioteki pango - pliki nagłówkowe.
158
159 %package pango-static
160 Summary:        A C++ interface for pango library - static version
161 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki pango - wersja statyczna
162 Group:          X11/Development/Libraries
163 Requires:       %{name}-pango-devel = %{version}-%{release}
164
165 %description pango-static
166 A C++ interface for pango library - static version.
167
168 %description pango-static -l pl.UTF-8
169 Interfejs C++ dla biblioteki pango - wersja statyczna.
170
171 %prep
172 %setup -q
173
174 %build
175 %{__libtoolize}
176 %{__aclocal} -I scripts
177 %{__autoconf}
178 %{__automake}
179 # exceptions and rtti are used in this package --misiek
180 %configure \
181         --disable-demos \
182         %{!?with_examples:--disable-examples} \
183         %{?with_static_libs:--enable-static}
184
185 %{__make}
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
190
191 %{__make} install \
192         DESTDIR=$RPM_BUILD_ROOT \
193         pkgconfigdir=%{_pkgconfigdir}
194
195 mv -f $RPM_BUILD_ROOT%{_docdir}/gtkmm-2.4/{examples,tests} \
196         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post   -p /sbin/ldconfig
202 %postun -p /sbin/ldconfig
203
204 %post   atk -p /sbin/ldconfig
205 %postun atk -p /sbin/ldconfig
206
207 %post   pango -p /sbin/ldconfig
208 %postun pango -p /sbin/ldconfig
209
210 %files
211 %defattr(644,root,root,755)
212 %doc AUTHORS ChangeLog CHANGES NEWS PORTING README
213 %attr(755,root,root) %{_libdir}/libg[dt]kmm*.so.*.*
214
215 %files devel
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libg[dt]kmm*.so
218 %{_libdir}/libg[dt]kmm*.la
219 %{_libdir}/g[dt]kmm-2.4
220 %{_includedir}/g[dt]kmm-2.4
221 %{_pkgconfigdir}/g[dt]kmm*.pc
222
223 %files doc
224 %defattr(644,root,root,755)
225 %doc %{_docdir}/gtkmm-2.4
226 %{?with_examples:%{_examplesdir}/%{name}-%{version}}
227 %doc %{_datadir}/devhelp/books/gtkmm-2.4
228
229 %if %{with static_libs}
230 %files static
231 %defattr(644,root,root,755)
232 %{_libdir}/libg[dt]kmm*.a
233 %endif
234
235 %files atk
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_libdir}/libatkmm*.so.*.*
238
239 %files atk-devel
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_libdir}/libatkmm*.so
242 %{_libdir}/libatkmm*.la
243 %{_pkgconfigdir}/atkmm*.pc
244 %{_includedir}/atkmm-1.6
245
246 %if %{with static_libs}
247 %files atk-static
248 %defattr(644,root,root,755)
249 %{_libdir}/libatkmm*.a
250 %endif
251
252 %files pango
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_libdir}/libpangomm*.so.*.*
255
256 %files pango-devel
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{_libdir}/libpangomm*.so
259 %{_libdir}/libpangomm*.la
260 %{_pkgconfigdir}/pangomm*.pc
261 %{_includedir}/pangomm-1.4
262
263 %if %{with static_libs}
264 %files pango-static
265 %defattr(644,root,root,755)
266 %{_libdir}/libpangomm*.a
267 %endif
This page took 0.059356 seconds and 3 git commands to generate.