]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
- up to 2.20.0
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - BATTERY_STATUS (BR: upower-devel)
3 # - FTL_JIT on !x86_64?
4 # - MEDIA_STREAM (BR: openwebrtc)
5 #
6 # Conditional build:
7 %bcond_without  gtk2            # WebKitPluginProcess2 to load GTK+ 2.x based plugins
8 %bcond_without  introspection   # disable introspection
9 %bcond_with     cairogl         # accelerated 2D canvas using cairo-gl
10 %bcond_with     seccomp         # seccomp filters (broken as of 2.6.5)
11 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
12 #
13 # it's not possible to build this with debuginfo on 32bit archs due to
14 # memory constraints during linking
15 %ifarch %{ix86} x32
16 %define         _enable_debug_packages          0
17 %endif
18 Summary:        Port of WebKit embeddable web component to GTK+ 3
19 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
20 Name:           gtk-webkit4
21 Version:        2.20.0
22 Release:        1
23 License:        BSD-like
24 Group:          X11/Libraries
25 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
26 # Source0-md5:  51cc47345c3ec53802718cd6fc9b746f
27 Patch0:         x32.patch
28 Patch1:         %{name}-icu59.patch
29 URL:            https://webkitgtk.org/
30 BuildRequires:  /usr/bin/ld.gold
31 BuildRequires:  EGL-devel
32 BuildRequires:  OpenGL-GLX-devel
33 BuildRequires:  OpenGLESv2-devel
34 BuildRequires:  at-spi2-core-devel >= 2.6.0
35 BuildRequires:  atk-devel
36 BuildRequires:  bison >= 2.3
37 BuildRequires:  cairo-devel >= 1.10.2
38 BuildRequires:  cmake >= 2.8.12
39 BuildRequires:  docbook-dtd412-xml
40 BuildRequires:  enchant-devel >= 0.22
41 BuildRequires:  flex >= 2.5.34
42 BuildRequires:  fontconfig-devel >= 2.8.0
43 BuildRequires:  freetype-devel >= 1:2.4.2
44 BuildRequires:  gcc-c++ >= 6:4.9
45 BuildRequires:  geoclue2-devel >= 2.1.5
46 BuildRequires:  gettext-devel
47 BuildRequires:  glib2-devel >= 1:2.36.0
48 BuildRequires:  glibc-misc
49 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
50 BuildRequires:  gperf >= 3.0.1
51 BuildRequires:  gstreamer-devel >= 1.2.3
52 BuildRequires:  gstreamer-plugins-bad-devel >= 1.6.0
53 BuildRequires:  gstreamer-plugins-base-devel >= 1.2.3
54 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.24.10}
55 BuildRequires:  gtk+3-devel >= 3.12.0
56 BuildRequires:  gtk-doc >= 1.10
57 BuildRequires:  harfbuzz-devel >= 0.9.7
58 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
59 BuildRequires:  hyphen-devel
60 BuildRequires:  libicu-devel >= 59
61 BuildRequires:  libjpeg-devel
62 BuildRequires:  libnotify-devel
63 BuildRequires:  libpng-devel
64 BuildRequires:  libsecret-devel
65 BuildRequires:  libsoup-devel >= 2.42.0
66 BuildRequires:  libstdc++-devel >= 6:4.9
67 BuildRequires:  libwebp-devel
68 BuildRequires:  libxml2-devel >= 1:2.8.0
69 BuildRequires:  libxslt-devel >= 1.1.7
70 BuildRequires:  pango-devel >= 1:1.32.0
71 BuildRequires:  perl-base >= 1:5.10.0
72 BuildRequires:  pkgconfig
73 %if %{with cairogl}
74 BuildRequires:  pkgconfig(cairo-egl)
75 BuildRequires:  pkgconfig(cairo-gl)
76 BuildRequires:  pkgconfig(cairo-glx)
77 %endif
78 BuildRequires:  python >= 1:2.7.0
79 BuildRequires:  rpmbuild(macros) >= 1.699
80 BuildRequires:  ruby >= 1:1.9
81 BuildRequires:  ruby-modules >= 1:1.9
82 BuildRequires:  sqlite3-devel >= 3
83 BuildRequires:  tar >= 1:1.22
84 BuildRequires:  woff2-devel
85 BuildRequires:  xorg-lib-libXcomposite-devel
86 BuildRequires:  xorg-lib-libXdamage-devel
87 BuildRequires:  xorg-lib-libXrender-devel
88 BuildRequires:  xorg-lib-libXt-devel
89 BuildRequires:  xz
90 BuildRequires:  zlib-devel
91 Requires:       cairo >= 1.10.2
92 Requires:       enchant >= 0.22
93 Requires:       fontconfig-libs >= 2.8.0
94 Requires:       freetype >= 1:2.4.2
95 Requires:       glib2 >= 1:2.36.0
96 Requires:       gstreamer >= 1.2.3
97 Requires:       gstreamer-plugins-base >= 1.2.3
98 %{?with_gtk2:Requires:  gtk+2 >= 2:2.24.10}
99 Requires:       gtk+3 >= 3.12.0
100 Requires:       harfbuzz >= 0.9.7
101 Requires:       libsoup >= 2.42.0
102 Requires:       libxml2 >= 1:2.8.0
103 Requires:       libxslt >= 1.1.7
104 Requires:       pango >= 1:1.32.0
105 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
106 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
107 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 # __once_call, __once_called non-function symbols from libstdc++
111 %define         skip_post_check_so      lib.*gtk-4.0.*
112
113 %description
114 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
115 3.
116
117 %description -l pl.UTF-8
118 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
119
120 %package devel
121 Summary:        Development files for WebKit for GTK+ 3
122 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
123 Group:          X11/Development/Libraries
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       glib2-devel >= 1:2.36.0
126 Requires:       gtk+3-devel >= 3.12.0
127 Requires:       libsoup-devel >= 2.42.0
128 Requires:       libstdc++-devel >= 6:4.9
129
130 %description devel
131 Development files for WebKit for GTK+ 3.
132
133 %description devel -l pl.UTF-8
134 Pliki programistyczne komponentu WebKit dla GTK+ 3.
135
136 %package apidocs
137 Summary:        WebKit API documentation
138 Summary(pl.UTF-8):      Dokumentacja API WebKita
139 Group:          Documentation
140 Requires:       gtk-doc-common
141 %if "%{_rpmversion}" >= "5"
142 BuildArch:      noarch
143 %endif
144
145 %description apidocs
146 WebKit API documentation.
147
148 %description apidocs -l pl.UTF-8
149 Dokumentacja API WebKita.
150
151 %prep
152 %setup -q -n webkitgtk-%{version}
153 %patch0 -p1
154 %patch1 -p1
155
156 %build
157 install -d build
158 cd build
159 %cmake .. \
160         %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
161         -DENABLE_CREDENTIAL_STORAGE=ON \
162         -DENABLE_GEOLOCATION=ON \
163         -DENABLE_GTKDOC=ON \
164         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
165         %{!?with_gtk2:-DENABLE_PLUGIN_PROCESS_GTK2=OFF} \
166         %{?with_seccomp:-DENABLE_SECCOMP_FILTERS=ON} \
167         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
168 %ifarch x32
169         -DENABLE_JIT=OFF \
170 %endif
171         -DENABLE_VIDEO=ON \
172         -DENABLE_WEB_AUDIO=ON \
173         -DENABLE_WEBGL=ON \
174         -DPORT=GTK \
175         -DSHOULD_INSTALL_JS_SHELL=ON
176
177 %{__make}
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181
182 %{__make} -C build install \
183         DESTDIR=$RPM_BUILD_ROOT
184
185 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
186 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
187 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
188 %endif
189
190 %find_lang WebKit2GTK-4.0
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post   -p /sbin/ldconfig
196 %postun -p /sbin/ldconfig
197
198 %files -f WebKit2GTK-4.0.lang
199 %defattr(644,root,root,755)
200 %doc NEWS
201 %attr(755,root,root) %{_bindir}/WebKitWebDriver
202 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
204 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
206 %if %{with introspection}
207 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
208 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
209 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
210 %endif
211 %dir %{_libexecdir}/webkit2gtk-4.0
212 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitNetworkProcess
213 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitPluginProcess
214 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitPluginProcess2
215 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitStorageProcess
216 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitWebProcess
217 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/jsc
218 %dir %{_libdir}/webkit2gtk-4.0
219 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
220 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
221
222 %files devel
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
225 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
226 %if %{with introspection}
227 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
228 %{_datadir}/gir-1.0/WebKit2-4.0.gir
229 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
230 %endif
231 %{_includedir}/webkitgtk-4.0
232 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
233 %{_pkgconfigdir}/webkit2gtk-4.0.pc
234 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
235
236 %files apidocs
237 %defattr(644,root,root,755)
238 %{_gtkdocdir}/webkit2gtk-4.0
239 %{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.044059 seconds and 4 git commands to generate.