]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
Update to 2.18.0
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - BATTERY_STATUS (BR: upower-devel)
3 # - FTL_JIT on !x86_64?
4 # - MEDIA_STREAM (BR: openwebrtc)
5 #
6 # Conditional build:
7 %bcond_without  gtk2            # WebKitPluginProcess2 to load GTK+ 2.x based plugins
8 %bcond_without  introspection   # disable introspection
9 %bcond_with     cairogl         # accelerated 2D canvas using cairo-gl
10 %bcond_with     seccomp         # seccomp filters (broken as of 2.6.5)
11 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
12 #
13 # it's not possible to build this with debuginfo on 32bit archs due to
14 # memory constraints during linking
15 %ifarch %{ix86} x32
16 %define         _enable_debug_packages          0
17 %endif
18 Summary:        Port of WebKit embeddable web component to GTK+ 3
19 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
20 Name:           gtk-webkit4
21 Version:        2.18.0
22 Release:        1
23 License:        BSD-like
24 Group:          X11/Libraries
25 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
26 # Source0-md5:  10d86dd5a5b68875654cc38af139f382
27 Patch0:         x32.patch
28 Patch1:         %{name}-icu59.patch
29 URL:            https://webkitgtk.org/
30 BuildRequires:  /usr/bin/ld.gold
31 BuildRequires:  EGL-devel
32 BuildRequires:  OpenGL-GLX-devel
33 BuildRequires:  OpenGLESv2-devel
34 BuildRequires:  at-spi2-core-devel >= 2.6.0
35 BuildRequires:  atk-devel
36 BuildRequires:  bison >= 2.3
37 BuildRequires:  cairo-devel >= 1.10.2
38 BuildRequires:  cmake >= 2.8.12
39 BuildRequires:  docbook-dtd412-xml
40 BuildRequires:  enchant-devel >= 0.22
41 BuildRequires:  flex >= 2.5.34
42 BuildRequires:  fontconfig-devel >= 2.8.0
43 BuildRequires:  freetype-devel >= 1:2.4.2
44 BuildRequires:  gcc-c++ >= 6:4.9
45 BuildRequires:  geoclue2-devel >= 2.1.5
46 BuildRequires:  gettext-devel
47 BuildRequires:  glib2-devel >= 1:2.36.0
48 BuildRequires:  glibc-misc
49 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
50 BuildRequires:  gperf >= 3.0.1
51 BuildRequires:  gstreamer-devel >= 1.2.3
52 BuildRequires:  gstreamer-plugins-bad-devel >= 1.6.0
53 BuildRequires:  gstreamer-plugins-base-devel >= 1.2.3
54 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.24.10}
55 BuildRequires:  gtk+3-devel >= 3.12.0
56 BuildRequires:  gtk-doc >= 1.10
57 BuildRequires:  harfbuzz-devel >= 0.9.7
58 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
59 BuildRequires:  hyphen-devel
60 BuildRequires:  libicu-devel >= 59
61 BuildRequires:  libjpeg-devel
62 BuildRequires:  libnotify-devel
63 BuildRequires:  libpng-devel
64 BuildRequires:  libsecret-devel
65 BuildRequires:  libsoup-devel >= 2.42.0
66 BuildRequires:  libstdc++-devel >= 6:4.9
67 BuildRequires:  libwebp-devel
68 BuildRequires:  libxml2-devel >= 1:2.8.0
69 BuildRequires:  libxslt-devel >= 1.1.7
70 BuildRequires:  pango-devel >= 1:1.32.0
71 BuildRequires:  perl-base >= 1:5.10.0
72 BuildRequires:  pkgconfig
73 %if %{with cairogl}
74 BuildRequires:  pkgconfig(cairo-egl)
75 BuildRequires:  pkgconfig(cairo-gl)
76 BuildRequires:  pkgconfig(cairo-glx)
77 %endif
78 BuildRequires:  python >= 1:2.7.0
79 BuildRequires:  rpmbuild(macros) >= 1.699
80 BuildRequires:  ruby >= 1:1.9
81 BuildRequires:  ruby-modules >= 1:1.9
82 BuildRequires:  sqlite3-devel >= 3
83 BuildRequires:  tar >= 1:1.22
84 BuildRequires:  xorg-lib-libXcomposite-devel
85 BuildRequires:  xorg-lib-libXdamage-devel
86 BuildRequires:  xorg-lib-libXrender-devel
87 BuildRequires:  xorg-lib-libXt-devel
88 BuildRequires:  xz
89 BuildRequires:  zlib-devel
90 Requires:       cairo >= 1.10.2
91 Requires:       enchant >= 0.22
92 Requires:       fontconfig-libs >= 2.8.0
93 Requires:       freetype >= 1:2.4.2
94 Requires:       glib2 >= 1:2.36.0
95 Requires:       gstreamer >= 1.2.3
96 Requires:       gstreamer-plugins-base >= 1.2.3
97 %{?with_gtk2:Requires:  gtk+2 >= 2:2.24.10}
98 Requires:       gtk+3 >= 3.12.0
99 Requires:       harfbuzz >= 0.9.7
100 Requires:       libsoup >= 2.42.0
101 Requires:       libxml2 >= 1:2.8.0
102 Requires:       libxslt >= 1.1.7
103 Requires:       pango >= 1:1.32.0
104 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
105 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
106 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 # __once_call, __once_called non-function symbols from libstdc++
110 %define         skip_post_check_so      lib.*gtk-4.0.*
111
112 %description
113 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
114 3.
115
116 %description -l pl.UTF-8
117 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
118
119 %package devel
120 Summary:        Development files for WebKit for GTK+ 3
121 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
122 Group:          X11/Development/Libraries
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       glib2-devel >= 1:2.36.0
125 Requires:       gtk+3-devel >= 3.12.0
126 Requires:       libsoup-devel >= 2.42.0
127 Requires:       libstdc++-devel >= 6:4.9
128
129 %description devel
130 Development files for WebKit for GTK+ 3.
131
132 %description devel -l pl.UTF-8
133 Pliki programistyczne komponentu WebKit dla GTK+ 3.
134
135 %package apidocs
136 Summary:        WebKit API documentation
137 Summary(pl.UTF-8):      Dokumentacja API WebKita
138 Group:          Documentation
139 Requires:       gtk-doc-common
140 %if "%{_rpmversion}" >= "5"
141 BuildArch:      noarch
142 %endif
143
144 %description apidocs
145 WebKit API documentation.
146
147 %description apidocs -l pl.UTF-8
148 Dokumentacja API WebKita.
149
150 %prep
151 %setup -q -n webkitgtk-%{version}
152 %patch0 -p1
153 %patch1 -p1
154
155 %build
156 install -d build
157 cd build
158 %cmake .. \
159         %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
160         -DENABLE_CREDENTIAL_STORAGE=ON \
161         -DENABLE_GEOLOCATION=ON \
162         -DENABLE_GTKDOC=ON \
163         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
164         %{!?with_gtk2:-DENABLE_PLUGIN_PROCESS_GTK2=OFF} \
165         %{?with_seccomp:-DENABLE_SECCOMP_FILTERS=ON} \
166         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
167 %ifarch x32
168         -DENABLE_JIT=OFF \
169 %endif
170         -DENABLE_VIDEO=ON \
171         -DENABLE_WEB_AUDIO=ON \
172         -DENABLE_WEBGL=ON \
173         -DPORT=GTK \
174         -DSHOULD_INSTALL_JS_SHELL=ON
175
176 %{__make}
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180
181 %{__make} -C build install \
182         DESTDIR=$RPM_BUILD_ROOT
183
184 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
185 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
186 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
187 %endif
188
189 %find_lang WebKit2GTK-4.0
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post   -p /sbin/ldconfig
195 %postun -p /sbin/ldconfig
196
197 %files -f WebKit2GTK-4.0.lang
198 %defattr(644,root,root,755)
199 %doc NEWS
200 %attr(755,root,root) %{_bindir}/WebKitWebDriver
201 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
202 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
203 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
204 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
205 %if %{with introspection}
206 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
207 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
208 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
209 %endif
210 %dir %{_libdir}/webkit2gtk-4.0
211 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitNetworkProcess
212 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess
213 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess2
214 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitStorageProcess
215 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitWebProcess
216 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/jsc
217 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
218 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
219
220 %files devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
223 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
224 %if %{with introspection}
225 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
226 %{_datadir}/gir-1.0/WebKit2-4.0.gir
227 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
228 %endif
229 %{_includedir}/webkitgtk-4.0
230 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
231 %{_pkgconfigdir}/webkit2gtk-4.0.pc
232 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
233
234 %files apidocs
235 %defattr(644,root,root,755)
236 %{_gtkdocdir}/webkit2gtk-4.0
237 %{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.04218 seconds and 4 git commands to generate.