]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
Update to 2.12.0
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - GAMEPAD
3 # - BATTERY_STATUS (BR: upower-devel)
4 # - FTL_JIT (BR: llvm, libcxxabi?)
5 # - MEDIA_STREAM (BR: openwebrtc)
6 #
7 # Conditional build:
8 %bcond_without  gtk2            # WebKitPluginProcess2 to load GTK+ 2.x based plugins
9 %bcond_without  introspection   # disable introspection
10 %bcond_with     seccomp         # seccomp filters (broken as of 2.6.5)
11 %bcond_with     wayland         # Wayland target (broken as of 2.6.[0-5])
12 #
13 # it's not possible to build this with debuginfo on 32bit archs due to
14 # memory constraints during linking
15 %ifarch %{ix86} x32
16 %define         _enable_debug_packages          0
17 %endif
18 Summary:        Port of WebKit embeddable web component to GTK+ 3
19 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
20 Name:           gtk-webkit4
21 Version:        2.12.0
22 Release:        1
23 License:        BSD-like
24 Group:          X11/Libraries
25 Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
26 # Source0-md5:  d233b5594c37a961308c230207d8b64f
27 Patch0:         x32.patch
28 URL:            http://webkitgtk.org/
29 BuildRequires:  /usr/bin/ld.gold
30 BuildRequires:  EGL-devel
31 BuildRequires:  OpenGLESv2-devel
32 BuildRequires:  OpenGL-GLX-devel
33 BuildRequires:  at-spi2-core-devel >= 2.6.0
34 BuildRequires:  atk-devel
35 BuildRequires:  bison >= 2.3
36 BuildRequires:  cairo-devel >= 1.10.2
37 BuildRequires:  cmake >= 2.8.12
38 BuildRequires:  enchant-devel >= 0.22
39 BuildRequires:  flex >= 2.5.34
40 BuildRequires:  fontconfig-devel >= 2.8.0
41 BuildRequires:  freetype-devel >= 1:2.4.2
42 BuildRequires:  gcc-c++ >= 6:4.9
43 BuildRequires:  geoclue2-devel >= 2.1.5
44 BuildRequires:  gettext-devel
45 BuildRequires:  glib2-devel >= 1:2.36.0
46 BuildRequires:  glibc-misc
47 BuildRequires:  gnutls-devel >= 3.0.0
48 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
49 BuildRequires:  gperf >= 3.0.1
50 BuildRequires:  gstreamer-devel >= 1.0.3
51 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.3
52 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.24.10}
53 BuildRequires:  gtk+3-devel >= 3.12.0
54 BuildRequires:  gtk-doc >= 1.10
55 BuildRequires:  harfbuzz-devel >= 0.9.7
56 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
57 BuildRequires:  hyphen-devel
58 BuildRequires:  libicu-devel >= 4.2.1
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libnotify-devel
61 BuildRequires:  libpng-devel
62 BuildRequires:  libsecret-devel
63 BuildRequires:  libsoup-devel >= 2.42.0
64 BuildRequires:  libstdc++-devel >= 6:4.9
65 BuildRequires:  libwebp-devel
66 BuildRequires:  libxml2-devel >= 1:2.8.0
67 BuildRequires:  libxslt-devel >= 1.1.7
68 BuildRequires:  pango-devel >= 1:1.32.0
69 BuildRequires:  perl-base >= 1:5.10.0
70 BuildRequires:  pkgconfig
71 BuildRequires:  python >= 1:2.7.0
72 BuildRequires:  rpmbuild(macros) >= 1.699
73 BuildRequires:  ruby >= 1.8.7
74 BuildRequires:  sqlite3-devel >= 3
75 BuildRequires:  tar >= 1:1.22
76 #BuildRequires: udev-glib-devel
77 BuildRequires:  xorg-lib-libXcomposite-devel
78 BuildRequires:  xorg-lib-libXdamage-devel
79 BuildRequires:  xorg-lib-libXrender-devel
80 BuildRequires:  xorg-lib-libXt-devel
81 BuildRequires:  xz
82 BuildRequires:  zlib-devel
83 Requires:       cairo >= 1.10.2
84 Requires:       enchant >= 0.22
85 Requires:       fontconfig-libs >= 2.8.0
86 Requires:       freetype >= 1:2.4.2
87 Requires:       glib2 >= 1:2.36.0
88 Requires:       gstreamer >= 1.0.3
89 Requires:       gstreamer-plugins-base >= 1.0.3
90 %{?with_gtk2:Requires:  gtk+2 >= 2:2.24.10}
91 Requires:       gtk+3 >= 3.12.0
92 Requires:       harfbuzz >= 0.9.7
93 Requires:       libsoup >= 2.42.0
94 Requires:       libxml2 >= 1:2.8.0
95 Requires:       libxslt >= 1.1.7
96 Requires:       pango >= 1:1.32.0
97 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 # __once_call, __once_called non-function symbols from libstdc++
101 %define         skip_post_check_so      lib.*gtk-4.0.*
102
103 %description
104 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
105 3.
106
107 %description -l pl.UTF-8
108 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
109
110 %package devel
111 Summary:        Development files for WebKit for GTK+ 3
112 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
113 Group:          X11/Development/Libraries
114 Requires:       %{name} = %{version}-%{release}
115 Requires:       glib2-devel >= 1:2.36.0
116 Requires:       gtk+3-devel >= 3.12.0
117 Requires:       libsoup-devel >= 2.42.0
118 Requires:       libstdc++-devel >= 6:4.9
119
120 %description devel
121 Development files for WebKit for GTK+ 3.
122
123 %description devel -l pl.UTF-8
124 Pliki programistyczne komponentu WebKit dla GTK+ 3.
125
126 %package apidocs
127 Summary:        WebKit API documentation
128 Summary(pl.UTF-8):      Dokumentacja API WebKita
129 Group:          Documentation
130 Requires:       gtk-doc-common
131 %if "%{_rpmversion}" >= "5"
132 BuildArch:      noarch
133 %endif
134
135 %description apidocs
136 WebKit API documentation.
137
138 %description apidocs -l pl.UTF-8
139 Dokumentacja API WebKita.
140
141 %prep
142 %setup -q -n webkitgtk-%{version}
143 %patch0 -p1
144
145 %build
146 install -d build
147 cd build
148 %cmake .. \
149         -DENABLE_CREDENTIAL_STORAGE=ON \
150         -DENABLE_GEOLOCATION=ON \
151         -DENABLE_GTKDOC=ON \
152         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
153         %{!?with_gtk2:-DENABLE_PLUGIN_PROCESS_GTK2=OFF} \
154         %{?with_seccomp:-DENABLE_SECCOMP_FILTERS=ON} \
155         %{?with_wayland:-DENABLE_WAYLAND_TARGET=ON} \
156 %ifarch x32
157         -DENABLE_JIT=OFF \
158 %endif
159         -DENABLE_VIDEO=ON \
160         -DENABLE_WEB_AUDIO=ON \
161         -DENABLE_WEBGL=ON \
162         -DPORT=GTK \
163         -DSHOULD_INSTALL_JS_SHELL=ON
164
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169
170 %{__make} -C build install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
174 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
175 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
176 %endif
177
178 %find_lang WebKit2GTK-4.0
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post   -p /sbin/ldconfig
184 %postun -p /sbin/ldconfig
185
186 %files -f WebKit2GTK-4.0.lang
187 %defattr(644,root,root,755)
188 %doc NEWS
189 %attr(755,root,root) %{_bindir}/jsc
190 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
192 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
193 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
194 %if %{with introspection}
195 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
196 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
197 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
198 %endif
199 %dir %{_libdir}/webkit2gtk-4.0
200 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitDatabaseProcess
201 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitNetworkProcess
202 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess
203 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess2
204 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitWebProcess
205 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
206 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
207
208 %files devel
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
211 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
212 %if %{with introspection}
213 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
214 %{_datadir}/gir-1.0/WebKit2-4.0.gir
215 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
216 %endif
217 %{_includedir}/webkitgtk-4.0
218 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
219 %{_pkgconfigdir}/webkit2gtk-4.0.pc
220 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
221
222 %files apidocs
223 %defattr(644,root,root,755)
224 %{_gtkdocdir}/webkit2gtk-4.0
225 %{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.080808 seconds and 4 git commands to generate.