]> git.pld-linux.org Git - packages/gtk-webkit4.git/blob - gtk-webkit4.spec
- updated to 2.38.5
[packages/gtk-webkit4.git] / gtk-webkit4.spec
1 # TODO: review configure options:
2 # - FTL_JIT on !x86_64?
3 # - WEB_RTC+MEDIA_STREAM (experimental; BR: openwebrtc)
4 # - AVIF? (experimental; BR: libavif-devel >= 0.9.0)
5 # - JPEGXL? (experimental; BR: libjxl-devel)
6 # - THUNDER? (BR: Thunder + ThunderClientLibraries)
7 #
8 # Conditional build:
9 %bcond_without  introspection   # GObject introspection
10 %bcond_without  libsoup2        # webkit-4.0 (libsoup2 based) variant
11 %bcond_without  libsoup3        # webkit-4.1 (libsoup3 based) variant (HTTP/2 support)
12 %bcond_without  gtk3            # webkit-4.x (gtk3 based) variants
13 %bcond_without  gtk4            # webkit-5.0 (gtk4/libsoup3 based) variant
14 %bcond_without  wayland         # Wayland target (requires GTK+ wayland target)
15 %bcond_with     lowmem          # try to reduce build memory usage (disable unified build, adjust gcc gc)
16 #
17 # it's not possible to build this with debuginfo on 32bit archs due to
18 # memory constraints during linking
19 %ifarch %{ix86} x32
20 %define         _enable_debug_packages          0
21 %endif
22 Summary:        Port of WebKit embeddable web component to GTK+ 3
23 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3
24 Name:           gtk-webkit4
25 # NOTE: 2.34.x is stable, 2.35.x devel
26 Version:        2.38.5
27 Release:        1
28 License:        BSD-like
29 Group:          X11/Libraries
30 Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
31 # Source0-md5:  de05d314a3ecb5fb3835e4d84f8f466d
32 Patch0:         x32.patch
33 Patch1:         %{name}-icu59.patch
34 Patch2:         %{name}-gir.patch
35 URL:            https://webkitgtk.org/
36 BuildRequires:  /usr/bin/ld.gold
37 BuildRequires:  EGL-devel
38 BuildRequires:  OpenGL-GLX-devel
39 BuildRequires:  OpenGLESv2-devel
40 BuildRequires:  at-spi2-core-devel >= 2.5.3
41 BuildRequires:  atk-devel >= 1:2.16.0
42 BuildRequires:  bubblewrap >= 0.3.1
43 BuildRequires:  cairo-devel >= 1.16.0
44 BuildRequires:  cmake >= 3.20
45 BuildRequires:  docbook-dtd412-xml
46 BuildRequires:  enchant2-devel >= 2
47 BuildRequires:  fontconfig-devel >= 2.13.0
48 BuildRequires:  freetype-devel >= 1:2.9.0
49 BuildRequires:  gcc-c++ >= 6:7.3.0
50 BuildRequires:  gettext-devel
51 BuildRequires:  gettext-tools
52 BuildRequires:  gi-docgen
53 BuildRequires:  glib2-devel >= 1:2.67.1
54 BuildRequires:  glibc-misc
55 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
56 BuildRequires:  gperf >= 3.0.1
57 BuildRequires:  gstreamer-devel >= 1.14
58 BuildRequires:  gstreamer-gl-devel >= 1.10.0
59 # codecparsers,mpegts with -DUSE_GSTREAMER_MPEGTS=ON
60 #BuildRequires: gstreamer-plugins-bad-devel >= 1.10.0
61 # app,audio,fft,pbutils,tag,video
62 BuildRequires:  gstreamer-plugins-base-devel >= 1.10.0
63 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.22.0}
64 %{?with_gtk4:BuildRequires:     gtk4-devel >= 4.0}
65 BuildRequires:  gtk-doc >= 1.10
66 BuildRequires:  harfbuzz-devel >= 1.4.2
67 BuildRequires:  harfbuzz-icu-devel >= 1.4.2
68 BuildRequires:  hyphen-devel
69 BuildRequires:  lcms2-devel >= 2
70 BuildRequires:  libgcrypt-devel >= 1.7.0
71 BuildRequires:  libicu-devel >= 61.2
72 BuildRequires:  libjpeg-devel
73 BuildRequires:  libmanette-devel >= 0.2.4
74 BuildRequires:  libnotify-devel
75 BuildRequires:  libpng-devel
76 BuildRequires:  libseccomp-devel
77 BuildRequires:  libsecret-devel
78 %{?with_libsoup2:BuildRequires: libsoup-devel >= 2.54}
79 %{?with_libsoup3:BuildRequires: libsoup3-devel >= 3.0}
80 # -std=c++2a
81 BuildRequires:  libstdc++-devel >= 6:8.3
82 BuildRequires:  libtasn1-devel
83 BuildRequires:  libwebp-devel
84 BuildRequires:  libwpe-devel >= 1.3.0
85 BuildRequires:  libxml2-devel >= 1:2.8.0
86 BuildRequires:  libxslt-devel >= 1.1.7
87 BuildRequires:  openjpeg2-devel >= 2.2.0
88 BuildRequires:  pango-devel >= 1:1.32.0
89 BuildRequires:  perl-base >= 1:5.10.0
90 BuildRequires:  pkgconfig
91 BuildRequires:  python >= 1:2.7.0
92 BuildRequires:  rpm-build >= 4.6
93 BuildRequires:  rpmbuild(macros) >= 1.699
94 BuildRequires:  ruby >= 1:1.9
95 BuildRequires:  ruby-modules >= 1:1.9
96 BuildRequires:  sqlite3-devel >= 3
97 BuildRequires:  systemd-devel
98 BuildRequires:  tar >= 1:1.22
99 %if %{with wayland}
100 BuildRequires:  wayland-devel
101 BuildRequires:  wayland-egl-devel
102 BuildRequires:  wayland-protocols >= 1.12
103 %endif
104 BuildRequires:  wpebackend-fdo-devel >= 1.6.0
105 BuildRequires:  woff2-devel >= 1.0.2
106 BuildRequires:  xdg-dbus-proxy
107 BuildRequires:  xorg-lib-libICE-devel
108 BuildRequires:  xorg-lib-libXcomposite-devel
109 BuildRequires:  xorg-lib-libXdamage-devel
110 BuildRequires:  xorg-lib-libXext-devel
111 BuildRequires:  xorg-lib-libXrender-devel
112 BuildRequires:  xorg-lib-libXt-devel
113 BuildRequires:  xz
114 BuildRequires:  zlib-devel
115 Requires:       at-spi2-core-libs >= 2.5.3
116 Requires:       atk >= 1:2.16.0
117 Requires:       cairo >= 1.16.0
118 Requires:       fontconfig-libs >= 2.13.0
119 Requires:       freetype >= 1:2.9.0
120 Requires:       glib2 >= 1:2.67.1
121 Requires:       gstreamer >= 1.2.3
122 Requires:       gstreamer-plugins-base >= 1.2.3
123 Requires:       gtk+3 >= 3.22.0
124 Requires:       harfbuzz >= 1.4.2
125 Requires:       libgcrypt >= 1.7.0
126 Requires:       libsoup >= 2.54
127 Requires:       libwpe >= 1.3.0
128 Requires:       libxml2 >= 1:2.8.0
129 Requires:       libxslt >= 1.1.7
130 Requires:       openjpeg2 >= 2.2.0
131 Requires:       pango >= 1:1.32.0
132 Requires:       woff2 >= 1.0.2
133 Requires:       wpebackend-fdo >= 1.6.0
134 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
135 # Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
136 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 hppa mips ppc ppc64 ppc64le s390 s390x sh4
137 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
138
139 # __once_call, __once_called non-function symbols from libstdc++
140 %define         skip_post_check_so      lib.*gtk-4.0.*
141
142 %description
143 gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
144 3.
145
146 %description -l pl.UTF-8
147 gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
148
149 %package devel
150 Summary:        Development files for WebKit for GTK+ 3
151 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3
152 Group:          X11/Development/Libraries
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       glib2-devel >= 1:2.67.1
155 Requires:       gtk+3-devel >= 3.22.0
156 Requires:       libsoup-devel >= 2.54
157 Requires:       libstdc++-devel >= 6:8.3
158
159 %description devel
160 Development files for WebKit for GTK+ 3.
161
162 %description devel -l pl.UTF-8
163 Pliki programistyczne komponentu WebKit dla GTK+ 3.
164
165 %package apidocs
166 Summary:        API documentation for WebKit GTK+ 3 port
167 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK+ 3
168 Group:          Documentation
169 Requires:       gtk-doc-common
170 BuildArch:      noarch
171
172 %description apidocs
173 API documentation for WebKit GTK+ 3 port.
174
175 %description apidocs -l pl.UTF-8
176 Dokumentacja API portu WebKitu do GTK+ 3.
177
178 %package -n gtk-webkit4.1
179 Summary:        Port of WebKit embeddable web component to GTK+ 3 with HTTP/2 support
180 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+ 3 z obsługą HTTP/2
181 Group:          X11/Libraries
182 Requires:       at-spi2-core-libs >= 2.5.3
183 Requires:       atk >= 1:2.16.0
184 Requires:       cairo >= 1.16.0
185 Requires:       fontconfig-libs >= 2.13.0
186 Requires:       freetype >= 1:2.9.0
187 Requires:       glib2 >= 1:2.67.1
188 Requires:       gstreamer >= 1.2.3
189 Requires:       gstreamer-plugins-base >= 1.2.3
190 Requires:       gtk+3 >= 3.22.0
191 Requires:       harfbuzz >= 1.4.2
192 Requires:       libgcrypt >= 1.7.0
193 Requires:       libsoup3 >= 3.0
194 Requires:       libwpe >= 1.3.0
195 Requires:       libxml2 >= 1:2.8.0
196 Requires:       libxslt >= 1.1.7
197 Requires:       openjpeg2 >= 2.2.0
198 Requires:       pango >= 1:1.32.0
199 Requires:       woff2 >= 1.0.2
200 Requires:       wpebackend-fdo >= 1.6.0
201
202 %description -n gtk-webkit4.1
203 gtk-webkit4.1 is a port of the WebKit embeddable web component to GTK+
204 3 with HTTP/2 (libsoup 3) support.
205
206 %description -n gtk-webkit4.1 -l pl.UTF-8
207 gtk-webkit4.1 to port osadzalnego komponentu WWW WebKit do GTK+ 3 z
208 obsługą HTTP/2 (libsoup 3).
209
210 %package -n gtk-webkit4.1-devel
211 Summary:        Development files for WebKit for GTK+ 3 with HTTP/2 support
212 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 3 z obsługą HTTP/2
213 Group:          X11/Development/Libraries
214 Requires:       gtk-webkit4.1 = %{version}-%{release}
215 Requires:       glib2-devel >= 1:2.67.1
216 Requires:       gtk+3-devel >= 3.22.0
217 Requires:       libsoup3-devel >= 3.0
218 Requires:       libstdc++-devel >= 6:8.3
219
220 %description -n gtk-webkit4.1-devel
221 Development files for WebKit for GTK+ 3 with HTTP/2 support.
222
223 %description -n gtk-webkit4.1-devel -l pl.UTF-8
224 Pliki programistyczne komponentu WebKit dla GTK+ 3 z obsługą HTTP/2.
225
226 %package -n gtk-webkit4.1-apidocs
227 Summary:        API documentation for WebKit GTK+ 3 port with HTTP/2 support
228 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK+ 3 z obsługą HTTP/2
229 Group:          Documentation
230 Requires:       gtk-doc-common
231 BuildArch:      noarch
232
233 %description -n gtk-webkit4.1-apidocs
234 API documentation for WebKit GTK+ 3 port with HTTP/2 support.
235
236 %description -n gtk-webkit4.1-apidocs -l pl.UTF-8
237 Dokumentacja API portu WebKitu do GTK+ 3 z obsługą HTTP/2.
238
239 %package -n gtk-webkit5
240 Summary:        Port of WebKit embeddable web component to GTK 4
241 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK 4
242 Group:          X11/Libraries
243 Requires:       at-spi2-core-libs >= 2.5.3
244 Requires:       atk >= 1:2.16.0
245 Requires:       cairo >= 1.16.0
246 Requires:       fontconfig-libs >= 2.13.0
247 Requires:       freetype >= 1:2.9.0
248 Requires:       glib2 >= 1:2.67.1
249 Requires:       gstreamer >= 1.2.3
250 Requires:       gstreamer-plugins-base >= 1.2.3
251 Requires:       gtk4 >= 4.0
252 Requires:       harfbuzz >= 1.4.2
253 Requires:       libgcrypt >= 1.7.0
254 Requires:       libsoup3 >= 3.0
255 Requires:       libwpe >= 1.3.0
256 Requires:       libxml2 >= 1:2.8.0
257 Requires:       libxslt >= 1.1.7
258 Requires:       openjpeg2 >= 2.2.0
259 Requires:       pango >= 1:1.32.0
260 Requires:       woff2 >= 1.0.2
261 Requires:       wpebackend-fdo >= 1.6.0
262
263 %description -n gtk-webkit5
264 gtk-webkit5 is a port of the WebKit embeddable web component to GTK 4.
265
266 %description -n gtk-webkit5 -l pl.UTF-8
267 gtk-webkit5 to port osadzalnego komponentu WWW WebKit do GTK+ 4.
268
269 %package -n gtk-webkit5-devel
270 Summary:        Development files for WebKit for GTK 4
271 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK 4
272 Group:          X11/Development/Libraries
273 Requires:       gtk-webkit5 = %{version}-%{release}
274 Requires:       glib2-devel >= 1:2.67.1
275 Requires:       gtk4-devel >= 4.0
276 Requires:       libsoup3-devel >= 3.0
277 Requires:       libstdc++-devel >= 6:8.3
278
279 %description -n gtk-webkit5-devel
280 Development files for WebKit for GTK 4.
281
282 %description -n gtk-webkit5-devel -l pl.UTF-8
283 Pliki programistyczne komponentu WebKit dla GTK 4.
284
285 %package -n gtk-webkit5-apidocs
286 Summary:        API documentation for WebKit GTK 4 port
287 Summary(pl.UTF-8):      Dokumentacja API portu WebKitu do GTK 4
288 Group:          Documentation
289 Requires:       gtk-doc-common
290 BuildArch:      noarch
291
292 %description -n gtk-webkit5-apidocs
293 API documentation for WebKit GTK 4 port.
294
295 %description -n gtk-webkit5-apidocs -l pl.UTF-8
296 Dokumentacja API portu WebKitu do GTK 4.
297
298 %prep
299 %setup -q -n webkitgtk-%{version}
300 %patch0 -p1
301 %patch1 -p1
302 %patch2 -p1
303
304 %build
305 %if %{with lowmem}
306 CXXFLAGS="%{rpmcxxflags} --param ggc-min-expand=30 --param ggc-min-heapsize=768"
307 %endif
308 for kind in %{?with_gtk3:%{?with_libsoup2:soup2} %{?with_libsoup3:soup3}} %{?with_gtk4:gtk4} ; do
309 install -d build-${kind}
310 %cmake -B build-${kind} \
311         -DENABLE_GEOLOCATION=ON \
312         -DENABLE_GTKDOC=ON \
313         %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
314         %{?with_lowmem:-DENABLE_UNIFIED_BUILDS=OFF} \
315         -DENABLE_VIDEO=ON \
316         %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
317         -DENABLE_WEB_AUDIO=ON \
318         -DENABLE_WEBGL=ON \
319 %ifarch x32
320         -DENABLE_C_LOOP=ON \
321         -DENABLE_JIT=OFF \
322         -DENABLE_SAMPLING_PROFILER=OFF \
323 %endif
324 %ifarch %{ix86} %{x8664} x32
325         -DHAVE_SSE2_EXTENSIONS=ON \
326 %endif
327         -DPORT=GTK \
328         -DSHOULD_INSTALL_JS_SHELL=ON \
329         $([ "$kind" = "gtk4" ] && echo -DUSE_GTK4=ON) \
330         $([ "$kind" = "soup2" ] && echo -DUSE_SOUP2=ON)
331
332 %{__make} -C build-${kind}
333 done
334
335 %install
336 rm -rf $RPM_BUILD_ROOT
337
338 for kind in %{?with_gtk3:%{?with_libsoup2:soup2} %{?with_libsoup3:soup3}} %{?with_gtk4:gtk4} ; do
339 %{__make} -C build-${kind} install \
340         DESTDIR=$RPM_BUILD_ROOT
341 done
342
343 %if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
344 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
345 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
346 %endif
347
348 %{?with_gtk3:%{?with_libsoup2:%find_lang WebKit2GTK-4.0}}
349 %{?with_gtk3:%{?with_libsoup3:%find_lang WebKit2GTK-4.1}}
350 %{?with_gtk4:%find_lang WebKit2GTK-5.0}
351
352 %clean
353 rm -rf $RPM_BUILD_ROOT
354
355 %post   -p /sbin/ldconfig
356 %postun -p /sbin/ldconfig
357
358 %post   -n gtk-webkit4.1 -p /sbin/ldconfig
359 %postun -n gtk-webkit4.1 -p /sbin/ldconfig
360
361 %post   -n gtk-webkit5 -p /sbin/ldconfig
362 %postun -n gtk-webkit5 -p /sbin/ldconfig
363
364 %if %{with gtk3} && %{with libsoup2}
365 %files -f WebKit2GTK-4.0.lang
366 %defattr(644,root,root,755)
367 %doc NEWS
368 %attr(755,root,root) %{_bindir}/WebKitWebDriver
369 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
370 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
371 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
372 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
373 %if %{with introspection}
374 %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
375 %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
376 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
377 %endif
378 %if "%{_libexecdir}" != "%{_libdir}"
379 %dir %{_libexecdir}/webkit2gtk-4.0
380 %endif
381 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/MiniBrowser
382 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitNetworkProcess
383 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/WebKitWebProcess
384 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.0/jsc
385 %dir %{_libdir}/webkit2gtk-4.0
386 %dir %{_libdir}/webkit2gtk-4.0/injected-bundle
387 %attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
388
389 %files devel
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
392 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
393 %if %{with introspection}
394 %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
395 %{_datadir}/gir-1.0/WebKit2-4.0.gir
396 %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
397 %endif
398 %{_includedir}/webkitgtk-4.0
399 %{_pkgconfigdir}/javascriptcoregtk-4.0.pc
400 %{_pkgconfigdir}/webkit2gtk-4.0.pc
401 %{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
402
403 %files apidocs
404 %defattr(644,root,root,755)
405 %{_gtkdocdir}/javascriptcoregtk-4.0
406 %{_gtkdocdir}/webkit2gtk-4.0
407 %{_gtkdocdir}/webkit2gtk-web-extension-4.0
408 %endif
409
410 %if %{with gtk3} && %{with libsoup3}
411 %files -n gtk-webkit4.1 -f WebKit2GTK-4.1.lang
412 %defattr(644,root,root,755)
413 %doc NEWS
414 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so.*.*.*
415 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.1.so.0
416 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.1.so.0
418 %if %{with introspection}
419 %{_libdir}/girepository-1.0/JavaScriptCore-4.1.typelib
420 %{_libdir}/girepository-1.0/WebKit2-4.1.typelib
421 %{_libdir}/girepository-1.0/WebKit2WebExtension-4.1.typelib
422 %endif
423 %if "%{_libexecdir}" != "%{_libdir}"
424 %dir %{_libexecdir}/webkit2gtk-4.1
425 %endif
426 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/MiniBrowser
427 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/WebKitNetworkProcess
428 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/WebKitWebProcess
429 %attr(755,root,root) %{_libexecdir}/webkit2gtk-4.1/jsc
430 %dir %{_libdir}/webkit2gtk-4.1
431 %dir %{_libdir}/webkit2gtk-4.1/injected-bundle
432 %attr(755,root,root) %{_libdir}/webkit2gtk-4.1/injected-bundle/libwebkit2gtkinjectedbundle.so
433
434 %files -n gtk-webkit4.1-devel
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_libdir}/libwebkit2gtk-4.1.so
437 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.1.so
438 %if %{with introspection}
439 %{_datadir}/gir-1.0/JavaScriptCore-4.1.gir
440 %{_datadir}/gir-1.0/WebKit2-4.1.gir
441 %{_datadir}/gir-1.0/WebKit2WebExtension-4.1.gir
442 %endif
443 %{_includedir}/webkitgtk-4.1
444 %{_pkgconfigdir}/javascriptcoregtk-4.1.pc
445 %{_pkgconfigdir}/webkit2gtk-4.1.pc
446 %{_pkgconfigdir}/webkit2gtk-web-extension-4.1.pc
447
448 %files -n gtk-webkit4.1-apidocs
449 %defattr(644,root,root,755)
450 %{_gtkdocdir}/javascriptcoregtk-4.1
451 %{_gtkdocdir}/webkit2gtk-4.1
452 %{_gtkdocdir}/webkit2gtk-web-extension-4.1
453 %endif
454
455 %if %{with gtk4}
456 %files -n gtk-webkit5 -f WebKit2GTK-5.0.lang
457 %defattr(644,root,root,755)
458 %doc NEWS
459 %attr(755,root,root) %{_libdir}/libwebkit2gtk-5.0.so.*.*.*
460 %attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-5.0.so.0
461 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-5.0.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-5.0.so.0
463 %if %{with introspection}
464 %{_libdir}/girepository-1.0/JavaScriptCore-5.0.typelib
465 %{_libdir}/girepository-1.0/WebKit2-5.0.typelib
466 %{_libdir}/girepository-1.0/WebKit2WebExtension-5.0.typelib
467 %endif
468 %if "%{_libexecdir}" != "%{_libdir}"
469 %dir %{_libexecdir}/webkit2gtk-5.0
470 %endif
471 %attr(755,root,root) %{_libexecdir}/webkit2gtk-5.0/MiniBrowser
472 %attr(755,root,root) %{_libexecdir}/webkit2gtk-5.0/WebKitNetworkProcess
473 %attr(755,root,root) %{_libexecdir}/webkit2gtk-5.0/WebKitWebProcess
474 %attr(755,root,root) %{_libexecdir}/webkit2gtk-5.0/jsc
475 %dir %{_libdir}/webkit2gtk-5.0
476 %dir %{_libdir}/webkit2gtk-5.0/injected-bundle
477 %attr(755,root,root) %{_libdir}/webkit2gtk-5.0/injected-bundle/libwebkit2gtkinjectedbundle.so
478
479 %files -n gtk-webkit5-devel
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{_libdir}/libwebkit2gtk-5.0.so
482 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-5.0.so
483 %if %{with introspection}
484 %{_datadir}/gir-1.0/JavaScriptCore-5.0.gir
485 %{_datadir}/gir-1.0/WebKit2-5.0.gir
486 %{_datadir}/gir-1.0/WebKit2WebExtension-5.0.gir
487 %endif
488 %{_includedir}/webkitgtk-5.0
489 %{_pkgconfigdir}/javascriptcoregtk-5.0.pc
490 %{_pkgconfigdir}/webkit2gtk-5.0.pc
491 %{_pkgconfigdir}/webkit2gtk-web-extension-5.0.pc
492
493 %files -n gtk-webkit5-apidocs
494 %defattr(644,root,root,755)
495 %{_gtkdocdir}/javascriptcoregtk-5.0
496 %{_gtkdocdir}/webkit2gtk-5.0
497 %{_gtkdocdir}/webkit2gtk-web-extension-5.0
498 %endif
This page took 0.594089 seconds and 3 git commands to generate.