]> git.pld-linux.org Git - packages/gtk-webkit3.git/blob - gtk-webkit3.spec
- greek locale fix
[packages/gtk-webkit3.git] / gtk-webkit3.spec
1 # TODO: 
2 # - review configure options
3 #
4 # Conditional build:
5 %bcond_without  introspection   # disable introspection
6 #
7 Summary:        Port of WebKit embeddable web component to GTK+
8 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
9 Name:           gtk-webkit3
10 Version:        1.3.13
11 Release:        3
12 License:        BSD-like
13 Group:          X11/Libraries
14 Source0:        http://webkitgtk.org/webkit-%{version}.tar.gz
15 # Source0-md5:  984adaafac545a89c24351fd4dbd743c
16 URL:            http://webkitgtk.org/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  bison
20 BuildRequires:  cairo-devel >= 1.6
21 BuildRequires:  enchant-devel >= 0.22
22 BuildRequires:  flex >= 2.5.33
23 BuildRequires:  fontconfig-devel >= 2.4.0
24 BuildRequires:  freetype-devel >= 1:2.1.8
25 BuildRequires:  geoclue-devel
26 BuildRequires:  gettext-devel
27 BuildRequires:  glib2-devel >= 1:2.28.0
28 BuildRequires:  glibc-misc
29 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.10.0}
30 BuildRequires:  gperf
31 BuildRequires:  gstreamer-devel >= 0.10
32 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.25
33 BuildRequires:  gtk+3-devel >= 3.0.0
34 BuildRequires:  gtk-doc >= 1.10
35 BuildRequires:  libicu-devel >= 4.2.1
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libsoup-devel >= 2.34.0
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool >= 2:1.5
41 BuildRequires:  libxml2-devel >= 1:2.6.30
42 BuildRequires:  libxslt-devel >= 1.1.7
43 BuildRequires:  pango-devel >= 1:1.12
44 BuildRequires:  pkgconfig
45 BuildRequires:  rpmbuild(macros) >= 1.592
46 BuildRequires:  sqlite3-devel
47 BuildRequires:  xorg-lib-libXft-devel >= 2.0.0
48 BuildRequires:  xorg-lib-libXt-devel
49 Requires(post,postun):  glib2 >= 1:2.26.0
50 Requires:       cairo >= 1.6
51 Requires:       enchant >= 0.22
52 Requires:       gstreamer-plugins-base >= 0.10.25
53 Requires:       gtk+3 >= 3.0.0
54 Requires:       libsoup >= 2.34.0
55 Requires:       libxml2 >= 1:2.6.30
56 Requires:       libxslt >= 1.1.7
57 Requires:       pango >= 1:1.12
58 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 webkit is a port of the WebKit embeddable web component to GTK+.
63
64 %description -l pl.UTF-8
65 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
66
67 %package devel
68 Summary:        Development files for WebKit
69 Summary(pl.UTF-8):      Pliki programistyczne WebKit
70 Group:          X11/Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       glib2-devel >= 1:2.28.0
73 Requires:       gtk+3-devel >= 3.0.0
74 Requires:       libsoup-devel >= 2.34.0
75
76 %description devel
77 Development files for WebKit.
78
79 %description devel -l pl.UTF-8
80 Pliki programistyczne WebKit.
81
82 %prep
83 %setup -q -n webkit-%{version}
84 mv Source/WebKit/gtk/po/{gr,el}.po
85 mv Source/WebKit/gtk/po/{gr,el}.mo
86
87 %build
88 %{__gtkdocize}
89 %{__libtoolize}
90 %{__aclocal} -I Source/autotools
91 %{__autoheader}
92 %{__automake}
93 %{__autoconf}
94 %configure \
95         --disable-silent-rules \
96         %{__enable_disable introspection} \
97         --with-gtk=3.0 \
98         --enable-3d-transforms \
99         --enable-dom-storage \
100         --enable-geolocation \
101         --enable-icon-database \
102         --enable-video \
103         --with-font-backend=freetype
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libwebkitgtk-3.0.la
114
115 %find_lang webkit-3.0
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 /sbin/ldconfig
122 %glib_compile_schemas
123
124 %postun
125 /sbin/ldconfig
126 %glib_compile_schemas
127
128 %files -f webkit-3.0.lang
129 %defattr(644,root,root,755)
130 %doc ChangeLog
131 %attr(755,root,root) %{_bindir}/jsc-3
132 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-3.0.so.0
134 %if %{with introspection}
135 %{_libdir}/girepository-1.0/JSCore-3.0.typelib
136 %{_libdir}/girepository-1.0/WebKit-3.0.typelib
137 %endif
138 %dir %{_datadir}/webkit-3.0
139 %{_datadir}/webkit-3.0/resources
140 %dir %{_datadir}/webkitgtk-3.0
141 %{_datadir}/webkitgtk-3.0/images
142 %{_datadir}/webkitgtk-3.0/webinspector
143 %{_datadir}/glib-2.0/schemas/org.webkitgtk-3.0.gschema.xml
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so
148 %if %{with introspection}
149 %{_datadir}/gir-1.0/JSCore-3.0.gir
150 %{_datadir}/gir-1.0/WebKit-3.0.gir
151 %endif
152 %{_includedir}/webkit-3.0
153 %{_pkgconfigdir}/webkitgtk-3.0.pc
This page took 0.076823 seconds and 4 git commands to generate.